Xorg assert failure: X: ../../../../include/privates.h:123: dixGetPrivateAddr: Assertion `key->initialized' failed.

Bug #1218456 reported by J on 2013-08-29
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Unity System Compositor
Critical
Unassigned
xorg-server (Ubuntu)
Critical
Unassigned

Bug Description

X fails to start with latest version unity-system-compositor

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: xserver-xorg-core 2:1.14.2.901-2ubuntu4
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.12.1-0ubuntu2
Architecture: i386
AssertionMessage: X: ../../../../include/privates.h:123: dixGetPrivateAddr: Assertion `key->initialized' failed.
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CrashCounter: 1
Date: Thu Aug 29 12:05:11 2013
DistUpgraded: 2013-07-12 12:32:26,641 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
DkmsStatus: virtualbox, 4.2.16, 3.11.0-4-generic, i686: installed
ExecutablePath: /usr/bin/Xorg
ExecutableTimestamp: 1377778058
ExtraDebuggingInterest: No
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 12) (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. Device [1462:1039]
MachineType: MICRO-STAR INTERNATIONAL CO., LTD MS-1454
MarkForUpload: True
ProcCmdline: /usr/bin/X -core :0 -auth /var/run/lightdm/root/:0 -mir 0 -mirSocket /tmp/mir_socket -nolisten tcp
ProcCwd: /etc/X11
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-4-generic root=UUID=93d6f3de-6246-4db0-9847-98af40412ef1 ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 __assert_fail_base (fmt=0xb72a2654 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0xb771f422 "key->initialized", file=file@entry=0xb772347c "../../../../include/privates.h", line=line@entry=123, function=function@entry=0xb7737678 "dixGetPrivateAddr") at assert.c:92
 __GI___assert_fail (assertion=0xb771f422 "key->initialized", file=0xb772347c "../../../../include/privates.h", line=123, function=0xb7737678 "dixGetPrivateAddr") at assert.c:101
 ?? ()
 xf86InitCursor ()
 xf86_cursors_init ()
Title: Xorg assert failure: X: ../../../../include/privates.h:123: dixGetPrivateAddr: Assertion `key->initialized' failed.
UpgradeStatus: Upgraded to saucy on 2013-07-12 (47 days ago)
UserGroups:

XorgConf:
 Section "Device"
    Identifier "intel"
    Driver "intel"
    Option "AccelMethod" "sna"
 EndSection
dmi.bios.date: 03/30/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: E1454IMS.110
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: MS-1454
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: REV:1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: MS-1454
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrE1454IMS.110:bd03/30/2010:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-1454:pvrREV1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rnMS-1454:rvrREV1.0:cvnMS-1454:ct10:cvrN/A:
dmi.product.name: MS-1454
dmi.product.version: REV:1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO., LTD
version.compiz: compiz 1:0.9.10+13.10.20130828.2-0ubuntu1
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.14.2.901-2ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.14-4ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Thu Aug 29 12:16:52 2013
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs: Output XMIR-1 XMIR-2 XMIR-3
xserver.version: 2:1.14.2.901-2ubuntu4
xserver.video_driver: intel

J (jsartti) wrote :

StacktraceTop:
 __assert_fail_base (fmt=0xb72a2654 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0xb771f422 "key->initialized", file=file@entry=0xb772347c "../../../../include/privates.h", line=line@entry=123, function=function@entry=0xb7737678 <__PRETTY_FUNCTION__.9079> "dixGetPrivateAddr") at assert.c:92
 __GI___assert_fail (assertion=assertion@entry=0xb771f422 "key->initialized", file=file@entry=0xb772347c "../../../../include/privates.h", line=line@entry=123, function=function@entry=0xb7737678 <__PRETTY_FUNCTION__.9079> "dixGetPrivateAddr") at assert.c:101
 dixGetPrivateAddr (key=<optimized out>, key=<optimized out>, privates=0xb91a9070) at ../../../../include/privates.h:123
 dixGetPrivateAddr (key=<optimized out>, key=<optimized out>, privates=0xb91a9070) at ../../../../hw/xfree86/ramdac/xf86Cursor.c:120
 dixSetPrivate (val=<optimized out>, key=0xb77a3eec <xf86CursorScreenKeyRec>, privates=0xb91a9070) at ../../../../include/privates.h:149

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Same crash with driver xserver-xorg-video-ati and mir enabled after latest updates. Even the failsafe session failed to start.
X starts fine without unity-system-compositor

Changed in xorg-server (Ubuntu):
importance: Medium → Critical
information type: Private → Public
Changed in unity-system-compositor (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
Jean-Baptiste Lallement (jibel) wrote :

Latest updates on this system.

description: updated
jerrylamos (jerrylamos) wrote :

VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6310]

built in monitor 1366x768, external VGA monitor 1600x900

Boots to black screen on both

Will boot with nomodeset running external monitor as follows.

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 1152 x 864, maximum 1152 x 864
default connected primary 1152x864+0+0 0mm x 0mm
   1152x864 0.0*
   1024x768 0.0
   800x600 61.0

settings displays thinks it is a built in monitor. Will attach Xorg.0.log

jerrylamos (jerrylamos) wrote :

Attaching Xorg.0.log.old, maybe this is from black screen boot

Anton (anton56577) wrote :

Also problem.

affects: unity-system-compositor (Ubuntu) → unity-system-compositor
inferrna (inferrna) wrote :
kevin gunn (kgunn72) on 2014-09-02
Changed in unity-system-compositor:
status: Confirmed → Fix Released
Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.