[enhancement] Implement screen rotation

Bug #1203215 reported by Chris Gagnon on 2013-07-19
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Daniel van Vugt
mir (Ubuntu)
Undecided
Unassigned
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

Steps:
1. running xmir
2. open system settings -> display

Expected result:
screen can be rotated

Actual result:
screen rotation cannot be changed

Related branches

summary: - unable to rotate screen on intel
+ unable to rotate screen or change resolution on intel
description: updated

Resolution is already covered by bug 1196239. So making this bug just about rotation.

tags: added: multimonitor
summary: - unable to rotate screen or change resolution on intel
+ unable to rotate screen on intel
description: updated
summary: - unable to rotate screen on intel
+ Unable to rotate screen

Also note: rotation probably requires surface resizing to be implemented first. Ideally...

Daniel van Vugt (vanvugt) wrote :

Actually, no. Screen rotation can be implemented quite separately to surface resizing.

It's only that screen rotation won't look quite right for maximized/fullscreen surfaces till we have resizing.

kevin gunn (kgunn72) wrote :

i would think this would also be part of multi-monitor support

kevin gunn (kgunn72) wrote :

or at least considered for that

Changed in mir:
importance: Undecided → Critical
assignee: nobody → Alexandros Frantzis (afrantzis)
Changed in xmir:
assignee: nobody → Chris Halse Rogers (raof)
importance: Undecided → Critical
Changed in mir:
status: New → Triaged
Changed in xmir:
status: New → Triaged

confirmed issue in our xmir multimonitor testing as of todya

summary: - Unable to rotate screen
+ xmir unable to rotate screens
Changed in mir:
importance: Critical → High
Changed in xmir:
importance: Critical → High
summary: - xmir unable to rotate screens
+ [feature] Implement screen rotation
tags: added: feature
summary: - [feature] Implement screen rotation
+ [enhancement] Implement screen rotation
tags: added: enhancement
removed: feature
Changed in mir:
assignee: Alexandros Frantzis (afrantzis) → Daniel van Vugt (vanvugt)
status: Triaged → In Progress
milestone: none → 0.1.5
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir/devel at revision None, scheduled for release in mir, milestone Unknown

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
status: Fix Committed → In Progress
Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
status: Fix Committed → In Progress
Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
status: Fix Committed → In Progress
Changed in mir:
milestone: 0.1.5 → 0.1.6
Changed in mir:
importance: High → Medium
Changed in xmir:
importance: High → Medium
Changed in mir:
milestone: 0.1.6 → 0.1.7
Daniel van Vugt (vanvugt) wrote :

In terms of graphics and mir_demo_server_shell, this works and has done since Mir 0.1.5. However mouse rotation is not yet implemented so I'll leave it open.

Note that we only need mouse (relative motion device) rotation support implemented to complete this. Touch screens are a different issue and will get their own rotation support later (RAOF).

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir/devel at revision None, scheduled for release in mir, milestone Unknown

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
status: Fix Committed → In Progress
Changed in mir:
milestone: 0.1.7 → 0.1.8
Daniel van Vugt (vanvugt) wrote :

Since Andreas added mouse-movement rotation in Mir 0.1.7 I'm happy to declare this done. For all intensive purposes it works really well now.

Other changes related to rotating the cursor image are coming soon.

Changed in mir:
status: In Progress → Fix Released
Changed in mir (Ubuntu):
status: New → Fix Released
Changed in mir:
milestone: 0.1.8 → 0.1.7
affects: xmir → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
assignee: Chris Halse Rogers (raof) → Robert Ancell (robert-ancell)
tags: added: xmir
Changed in xorg-server (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
Daniel van Vugt (vanvugt) wrote :

No longer related to XMir (1.0) so invalid for xorg.

Changed in xorg-server (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers