DPMS does not work correctly on hybrid systems

Bug #1184999 reported by Maarten Lankhorst on 2013-05-28
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Medium
Maarten Lankhorst
Raring
Undecided
Unassigned

Bug Description

[Impact]
 * When using nvidia drivers in the prime configuration listed in their README will not turn off correctly on DPMS.
 * External displays driven from the non-primary graphics card will not turn off either.

[Test Case]
 * Get an affected system configuration, either with the binary drivers or open source drivers.
 * Run 'xset dpms force off'.
 * Backlight and external displays should turn off.

[Regression Potential]
 * Unlikely, the patch is from upstream. Any regressions would only happen on hybrid systems, and the dpms on/off code is already tested in all drivers in non-hybrid configurations. The most likely regressions would involve backlight somehow.

[Other Info]
 * Commit 6238bd68bd71323f8b4f1808f34dabe2ae447fe3 upstream.
 * Patch is included in the x1.14 release.

Related branches

description: updated
Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Maarten Lankhorst (mlankhorst)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.13.3-0ubuntu10

---------------
xorg-server (2:1.13.3-0ubuntu10) saucy; urgency=low

  * Add patch to fix DPMS. (LP: #1184999)
    - include-GPU-screens-in-DPMS-code.patch
  * Add patch to fix crash on hybrid systems during shutdown. (LP: #1185035)
    - xf86-detach-scanout.patch
 -- Maarten Lankhorst <email address hidden> Tue, 28 May 2013 16:12:12 +0200

Changed in xorg-server (Ubuntu):
status: New → Fix Released

Hello Maarten, or anyone else affected,

Accepted xorg-server into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xorg-server/2:1.13.3-0ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xorg-server (Ubuntu Raring):
status: New → Fix Committed
tags: added: verification-needed

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of xorg-server from raring-proposed was performed and bug 1224198 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1224198 "bot-stop-nagging". Thanks!

tags: added: verification-failed
Maarten Lankhorst (mlankhorst) wrote :

Removing verification-failed, this bug seems to be from someone who doesn't respond, and uses an unsupported configuration. He didn't restart xorg-server after upgrading, which is not really helpful for diagnostics.

tags: removed: verification-failed
tags: added: verification-done
removed: verification-needed
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in xorg-server (Ubuntu Raring):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers