X crash at startup with IBM T22/savage s3

Bug #116239 reported by Sigurd on 2007-05-22
6
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

The machine (IBM T22, laptop) starts up normaly until the point where it tries to start the X-server. After that the screen goes black and does not respond to anything.

This is only a problem on "cold boots" If I restart under the bootprossess, it will load the X-server succsessfully. It will also load X under recoverymode.

A workaround for this problem was to add these lines to xorg.conf:

Option "DmaType" "PCI"
Option "BusType" "PCI"

Here is a thread that confirms another insident of this problem:

http://ubuntuforums.org/showthread.php?t=436942&highlight=t22

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in xorg.

Bryce Harrington (bryce) wrote :

Which version of ubuntu are you using (feisty?)

Also, please attach the output of running `/usr/share/bug/xserver-xorg-core/script`

Changed in xorg:
status: Unconfirmed → Needs Info

I am attempting to install 7.04 onto a T-22 and I end up with a blank screen with nothing happening. I suspect what's going on is that I am running into this X server crash in the installion. Should I open a separate bug? I know of no workaround.

I guess its the same bug, so it shouldn't be nessesary to post a new bug. Have you tried every workaround I suggested above? Did you try to install with the live cd or the alternate one? For me, it crashed when I opened the installer in the live session, so I had to go for the alternate.

Im sorry for not posting the result of: `/usr/share/bug/xserver-xorg-core/script` , but its not my computer, so I havnt had the oppertunety to do it yet.

Bryce Harrington (bryce) wrote :

Sigurd, ok no prob. Instead, can you post your /etc/X11/xorg.conf and /var/log/Xorg.0.log files, and the output from lspci? (that's what the aforementioned script does.)

Eliot, if you could also post these 3 things, it'd help us determine for certain if you're experiencing the same bug.

Can you both confirm that adding the DmaType and BusType options resolves the issue for you? If so, I'll look into getting these added for xorg.confs for this specific hardware.

I tested out installing onto a T30 earlier this week. The one problem I ran into was that the laptop only had 256M memory, and so the installer choked while trying to partition. Manually adding some swap space solved that. I have run into an issue where the screen goes black and unresponsive, but only AFTER it has finished starting up. I suspect the issue is something to do with suspend/hibernation, but haven't tracked it down yet.

Bryce Harrington (bryce) wrote :

Ping... Could you please attach the requested information? Otherwise it will be difficult for us to investigate this any further.

I' sorry it has taken so long to post the required information, and I am sorry to say that I really can't do it. The thing is that my friend wasn't too happy with ubuntu and has put xp back in. I will try to contact others with the same model one the forum and ask if they can post the info you need.

Launchpad Janitor (janitor) wrote :

[Expired for xorg (Ubuntu) because there has been no activity for 60 days.]

Conan (richard-connon) wrote :

This would appear to be the case still using Intrepid with the default (almost empty) xorg.conf

Changed in xorg:
status: Invalid → New
Bryce Harrington (bryce) wrote :

Hi turgon2,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Please attach the output of `lspci -vvnn` too.

[This is an automated message. If this script has reached you erroneously, please accept our apologies; any reply to this message will be sufficient to prevent it from doing further automated processing.]

Changed in xorg:
status: New → Incomplete
Conan (richard-connon) wrote :
Conan (richard-connon) wrote :
Conan (richard-connon) wrote :
Conan (richard-connon) wrote :

Not sure if this is a duplicate of #33617

Bryce Harrington (bryce) on 2009-03-06
Changed in xorg-server:
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers