XDPMS extension doesn't send change events, which forces gnome-power-manager to poll

Bug #114336 reported by Chris Jones on 2007-05-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-power-manager (Fedora)
Fix Released
Medium
xorg-server (Ubuntu)
Wishlist
Unassigned

Bug Description

gnome-power-manager has to frequently poll for DPMS state changes which increases power (ie battery) usage. The XDPMS extension should send events instead.

Related branches

Chris Jones (cmsj) wrote :

Upstream is actually gnome-power-manager, but it's a wishlist bug against xorg.

Changed in gnome-power-manager:
status: Unknown → In Progress
Timo Aaltonen (tjaalton) wrote :

apparently it's not going to happen, because xrandr enabled drivers should be able to do it better or something.

Changed in xorg:
status: New → Confirmed
Changed in gnome-power-manager:
status: In Progress → Incomplete
Changed in gnome-power-manager:
status: Incomplete → Invalid
Changed in gnome-power-manager:
status: Invalid → In Progress
Bryce Harrington (bryce) on 2009-03-06
Changed in xorg-server:
status: Confirmed → Triaged
Changed in gnome-power-manager (Fedora):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package xorg-server - 2:1.6.4-2ubuntu1

---------------
xorg-server (2:1.6.4-2ubuntu1) karmic; urgency=low

  * Merge from Debian unstable. (LP: #447010)
    Remaining Ubuntu changes:
    - debian/control:
      + set Conflicts: xkb-data (<< 0.9), since xkb-path is
        different from previous releases
      + do not Conflict with xserver-xorg-video
      + xvfb Depends on xauth, xfonts-base
      + Set Maintainer to Ubuntu Core Developers
    - debian/rules:
      + build using -fno-stack-protector
      + --with-os-vendor=Ubuntu
    - debian/xserver-xorg-core.install:
      + Add ioport, pcitweak, scanpci scripts & man pages
    - debian/patches:
      + 101_fedora_xserver-1.3.0-document-fontpath-correctly.patch:
        Specify correct paths to fonts
      + 102_ubuntu_sharevts_load_cpu.patch:
        close console fd only when ShareVTs
      + 103_psb_auto.patch:
        Autodetect poulsbo devices (but use -vesa since -psb is broken)
      + 110_fedora_no_move_damage.patch:
        further aiglx support
      + 121_only_switch_vt_when_active.diff:
        Add a check to prevent the X server from changing the VT when killing
        GDM from the console.
      + 135_rethrow_signals.patch:
        When aborting, re-raise signals for apport
      + 140_quell_acpi_errmsgs.patch:
        Avoid generating extraneous warnings when acpi is missing
      + 153_make_dmx_compile.patch:
        Change xcalloc -> calloc, so that dmx compiles.
      + 156_exevents_copykeyclass_nullptrcheck.patch,
        157_check_null_modes.patch, 162_null_crtc_in_rotation.patch,
        166_nullptr_xinerama_keyrepeat.patch, 167_nullptr_xisbread.patch
        169_mipointer_nullptr_checks.patch,
        172_cwgetbackingpicture_nullptr_check.patch:
        Fix various segfaults in xserver by checking pointers for NULL
        values before dereferencing them.
      + 164_trap-aspect-ratios.patch:
        Correct monitor EDIDs that have misreported aspect ratios.
      + 165_man_xorg_conf_no_device_ident.patch
        Correct man page
      + 168_glibc_trace_to_stderr.patch:
        Report abort traces to stderr instead of terminal
      + 174_set_bg_pixmap_of_cow_to_none.patch:
        Set background pixmap of composite overlay window to no background
      + 177_animated_cursor_change_master.patch:
        Don't create animated cursors for slave devices
      + 180_fedora_no_synaptics_mouse_synthesis.patch:
        Don't synthesize a mouse section if a synaptics device is found
      + 181_fedora_log_proc_cmdline.patch:
        Dump /proc/cmdline in the log file too
      + 184_virtual_devices_autodetect.patch:
        Use vesa for qemu device, which is not supported by cirrus
      + 185_dix_badwindow.patch:
        Don't return BadMatch from GetProperty if window isn't actually a window
      + 186_autoconfig_geode.patch
        Perform autodetection correctly for various geode devices
  * Update 184_virtual_devices_autodetect.patch to only include inserting
    cirrus, since vbox is covered by the new fedora patch.
  * Drop patches already included upstream:
    - 187_lastdeviceeventtime-no-reset.patch
    - 178_glx_flush_cache.patch
  ...

Read more...

Changed in xorg-server (Ubuntu):
status: Triaged → Fix Released
Taylor Braun-Jones (nocnokneo) wrote :

Where exactly is the released fix implemented? I'm looking in /usr/include/X11/extensions/dpmsproto.h and see:

#define DPMSNumberEvents 0

Searching around doesn't turn up any evidence of a DPMS event notification system. Am I missing something?

Changed in gnome-power-manager (Fedora):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.