mouse movement crashes when setting Coordinate Transformation Matrix

Bug #1085031 reported by Mark on 2012-11-30
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Low
Unassigned

Bug Description

The problem is the next:
After setting the Coordinate Transformation Matrix of any touch screen (tried 2-3 kind of) The mouse movement crashes:

Nextwindow Fermi Touchscreen: The cursor is blinking in the left top of the screen only. (Able to click, no movement) (crashes when set to the default too)
HuiToo Computer INC. HuiToo Computer INC.: The cursor is moving across the screen but jumping around, no logic in movement. (Able to click)(on default it works)
TOUCHSCREEN: same as on HuiToo

I am using ubuntu 12.04

   uname -r
3.2.0-33-generic-pae

 xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Nextwindow Fermi Touchscreen id=11 [slave pointer (2)]
⎜ ↳ HuiToo Computer INC. HuiToo Computer INC. id=13 [slave pointer (2)]
⎜ ↳ TOUCHSCREEN id=6 [slave pointer (2)]
⎜ ↳ Touch__KiT Touch Computer INC. id=9 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ UCQ01000 Samsung UC Audio id=8 [slave keyboard (3)]
    ↳ HuiToo Computer INC. HuiToo Computer INC. id=12 [slave keyboard (3)]
    ↳ Touch__KiT Touch Computer INC. id=10 [slave keyboard (3)]

   dpkg -s xorg
Package: xorg
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 77
Maintainer: Ubuntu X-SWAT <email address hidden>
Architecture: i386
Version: 1:7.6+12ubuntu1
Provides: x-window-system, x-window-system-core
Depends: xserver-xorg (>= 1:7.6+12ubuntu1), libgl1-mesa-glx | libgl1, libgl1-mesa-dri, libglu1-mesa, xfonts-base (>= 1:1.0.0-1), x11-apps, x11-session-utils, x11-utils, x11-xfs-utils, x11-xkb-utils, x11-xserver-utils, xauth, xinit, xfonts-utils, xkb-data, xorg-docs-core, xterm | x-terminal-emulator, x11-common, xinput
Recommends: xfonts-scalable (>= 1:1.0.0-1)
Suggests: xorg-docs, xfonts-100dpi (>= 1:1.0.0-1), xfonts-75dpi (>= 1:1.0.0-1)

I tried to rotate my touch but it crashed. Ones I tried to set the matrix as the default:
   xinput set-prop {NUMBEROFTOUCHSCREEN} 'Coordinate Transformation Matrix' 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 1.000000
After this the erratic mouse movement started again.

Actual hardwares:

xinput --list 11
Nextwindow Fermi Touchscreen id=11 [slave pointer (2)]
 Reporting 3 classes:
  Class originated from: 11. Type: XIButtonClass
  Buttons supported: 2
  Button labels: None None
  Button state:
  Class originated from: 11. Type: XIValuatorClass
  Detail for Valuator 0:
    Label: None
    Range: -1.000000 - -1.000000
    Resolution: 0 units/m
    Mode: relative
  Class originated from: 11. Type: XIValuatorClass
  Detail for Valuator 1:
    Label: None
    Range: -1.000000 - -1.000000
    Resolution: 0 units/m
    Mode: relative

  xinput --list-props 11
Device 'Nextwindow Fermi Touchscreen':
 Device Enabled (132): 1
 Coordinate Transformation Matrix (134): 0.000000, 1.000000, 0.000000, -1.000000, 0.000000, 1.000000, 0.000000, 0.000000, 1.000000
 Device Accel Profile (256): 0
 Device Accel Constant Deceleration (257): 1.000000
 Device Accel Adaptive Deceleration (258): 1.000000
 Device Accel Velocity Scaling (259): 10.000000

OR

  xinput --list 13
HuiToo Computer INC. HuiToo Computer INC. id=13 [slave pointer (2)]
 Reporting 4 classes:
  Class originated from: 13. Type: XIButtonClass
  Buttons supported: 5
  Button labels: "Button Unknown" "Button Unknown" "Button Unknown" "Button Wheel Up" "Button Wheel Down"
  Button state:
  Class originated from: 13. Type: XIValuatorClass
  Detail for Valuator 0:
    Label: Abs MT Position X
    Range: 0.000000 - 4095.000000
    Resolution: 0 units/m
    Mode: absolute
    Current value: 4034.000000
  Class originated from: 13. Type: XIValuatorClass
  Detail for Valuator 1:
    Label: Abs MT Position Y
    Range: 0.000000 - 4095.000000
    Resolution: 0 units/m
    Mode: absolute
    Current value: 80.000000
  Class originated from: 0. Type: XITouchClass
  Touch mode: direct
  Max number of touches: 9

  xinput --list-props 13
Device 'HuiToo Computer INC. HuiToo Computer INC.':
 Device Enabled (132): 1
 Coordinate Transformation Matrix (134): 0.000000, 1.000000, 0.000000, -1.000000, 0.000000, 1.000000, 0.000000, 0.000000, 1.000000
 Device Accel Profile (256): 0
 Device Accel Constant Deceleration (257): 1.000000
 Device Accel Adaptive Deceleration (258): 1.000000
 Device Accel Velocity Scaling (259): 10.000000
 Device Product ID (252): 1020, 1496
 Device Node (253): "/dev/input/event13"
 Evdev Axis Inversion (498): 0, 0
 Evdev Axis Calibration (499): <no items>
 Evdev Axes Swap (500): 0
 Axis Labels (501): "Abs MT Position X" (496), "Abs MT Position Y" (497), "None" (0), "None" (0)
 Button Labels (502): "Button Unknown" (495), "Button Unknown" (495), "Button Unknown" (495), "Button Wheel Up" (138), "Button Wheel Down" (139)
 Evdev Middle Button Emulation (503): 0
 Evdev Middle Button Timeout (504): 50
 Evdev Third Button Emulation (505): 0
 Evdev Third Button Emulation Timeout (506): 1000
 Evdev Third Button Emulation Button (507): 3
 Evdev Third Button Emulation Threshold (508): 20
 Evdev Wheel Emulation (509): 0
 Evdev Wheel Emulation Axes (510): 0, 0, 4, 5
 Evdev Wheel Emulation Inertia (511): 10
 Evdev Wheel Emulation Timeout (512): 200
 Evdev Wheel Emulation Button (513): 4
 Evdev Drag Lock Buttons (514): 0

OR
  xinput --list 6
TOUCHSCREEN id=6 [slave pointer (2)]
 Reporting 3 classes:
  Class originated from: 6
  Buttons supported: 1
  Button labels: None
  Button state:
  Class originated from: 6
  Detail for Valuator 0:
    Label: None
    Range: 0.000000 - 4095.000000
    Resolution: 4095 units/m
    Mode: absolute
    Current value: 0.000000
  Class originated from: 6
  Detail for Valuator 1:
    Label: None
    Range: 0.000000 - 4095.000000
    Resolution: 4095 units/m
    Mode: absolute
    Current value: 0.000000

   xinput --list-props 6
Device 'TOUCHSCREEN':
 Device Enabled (142): 1
 Coordinate Transformation Matrix (144): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
 Device Accel Profile (259): 0
 Device Accel Constant Deceleration (260): 1.000000
 Device Accel Adaptive Deceleration (261): 1.000000
 Device Accel Velocity Scaling (262): 10.000000

UDEV rules:

   cat /etc/udev/rules.d/41-hid-multitouch.rules
SUBSYSTEM=="usb", ATTRS{idVendor}=="03fc", ATTRS{idProduct}=="05d8", RUN+="/bin/sh /lib/udev/load_hid_multitouch.sh $env{ID_VENDOR_ID} $env{ID_MODEL_ID}"

  cat /etc/udev/rules.d/40-nw-fermi.rules
# NW Fermi Rules
#
# KERNEL!="event[0-9]*", GOTO="nw-fermi-end"
KERNEL=="nwfermi?", SYMLINK+="nw-fermi", RUN+="/usr/sbin/nwfermi_daemon /daemon /instanceId $number"
KERNEL=="hidraw*", SUBSYSTEM=="hidraw", SYSFS{idVendor}=="1926", MODE="0666", SYMLINK+="nw-fermi-device"
KERNEL=="hidraw*", SUBSYSTEM=="hidraw", SYSFS{idVendor}=="0b8c", SYSFS{idProduct}=="0069", MODE="0666", SYMLINK+="nw-fermi-device"
ACTION=="add|change", SUBSYSTEM=="input", ATTRS{name}=="Nextwindow Fermi Touchscreen", ENV{NAME}="nextwindow", ENV{ID_INPUT.tags}="nextwindow"
LABEL="nw-fermi-end"

Mark (mark-a-mester) wrote :

Xorg version 1.11.3 was not mentioned.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
no longer affects: xorg-server-lts-quantal (Ubuntu)
Mark (mark-a-mester) wrote :

The problem is in the udev driver. Updating the driver to the newest version vill solve the problem. (Need to compile manually..)

Mark, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xorg-server REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xorg-server (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Mark (mark-a-mester) wrote :

The update solved the problem, but we are using some old machines in integrated environment and we are unable to update em.
Getting the new version of xorg will solve the problem.

Changed in xorg-server (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers