misc:typo rules doesn't apply on X startup

Bug #1070214 reported by Alexey Ten (Lynn) on 2012-10-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Medium
xorg-server (Ubuntu)
Undecided
Canonical X.org

Bug Description

I have following settings in /etc/default/console-setup
XKBMODEL="pc104"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:caps_toggle,lv3:ralt_switch,misc:typo,terminate:ctrl_alt_bksp"

Logging into text console and starting xinit -- :1 doesn't apply rules for misc:typo option, so I have to run setxkbmap.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xserver-xorg-core 2:1.10.4-1ubuntu4.2
ProcVersionSignature: Ubuntu 3.0.0-21.35-generic 3.0.32
Uname: Linux 3.0.0-21-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,snap,resize,gnomecompat,zoom,vpswitch,compiztoolbox,mousepoll,regex,place,move,imgpng,wall,resizeinfo,unitymtgrabhandles,animation,session,workarounds,expo,fade,unityshell]
CompositorRunning: compiz
Date: Tue Oct 23 11:59:23 2012
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.1.22, 3.0.0-21-generic, x86_64: installed
 vboxhost, 4.1.22, 3.0.0-25-generic, x86_64: installed
 vboxhost, 4.1.22, 3.0.0-26-generic, x86_64: installed
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21da]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: LENOVO 4290RW1
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-21-generic root=UUID=4e956dc0-725f-4246-8c18-bfd8d1220c35 ro quiet splash vt.handoff=7
SourcePackage: xorg-server
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/18/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET46WW (1.16 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4290RW1
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET46WW(1.16):bd05/18/2011:svnLENOVO:pn4290RW1:pvrThinkPadX220:rvnLENOVO:rn4290RW1:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4290RW1
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6.1
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3.2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3.2
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Created attachment 32414
xkbcomp :1 - > bug.xkb.txt

I have following settings in /etc/default/console-setup
XKBMODEL="pc104"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:caps_toggle,lv3:ralt_switch,misc:typo,terminate:ctrl_alt_bksp"

Logging into text console and starting xinit -- :1 doesn't apply rules for misc:typo option, so I have to run setxkbmap.

xprop -root gives right settings:
$ xprop -root
_XKB_RULES_NAMES(STRING) = "evdev", "pc104", "us,ru", ",", "grp:caps_toggle,lv3:ralt_switch,misc:typo,terminate:ctrl_alt_bksp"
XFree86_VT(INTEGER) = 9

Output of xkbcomp after start is attached. Also xkbcomp outputs following to stderr
Warning: Could not load keyboard geometry for :1
                  BadAlloc (insufficient resources for operation)
                  Resulting keymap file will not describe geometry

Created attachment 32415
xkbcomp after running setxkbmap

after running setxkbmap xkbcomp gives no error messages

My system is ubuntu 9.10
ii xorg 1:7.4+3ubuntu10
ii xserver-xorg 1:7.4+3ubuntu10

Alexey Ten (Lynn) (alexeyten) wrote :

The attachment "bug-25873.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Created attachment 68943
git formatted patch

We have to apply patch similar to one in bug #19563 because we have own maprules.c

Changed in xorg-server:
importance: Unknown → Medium
status: Unknown → Confirmed

Alexey, please sign-off your patch. ACK otherwise, I'll merge it as soon as I have your Signed-off-by.

Created attachment 69381
signed off patch

Changed in xorg-server:
status: Confirmed → Incomplete

commit 5b7384a3154a95a805b040e1910e276b52aada96
Author: Alexey Ten (Lynn) <email address hidden>
Date: Tue Oct 23 12:32:31 2012 +0400

    Apply partial matches for option (#25873)

Changed in xorg-server:
status: Incomplete → Fix Released
Bryce Harrington (bryce) on 2013-04-08
Changed in xorg-server (Ubuntu):
assignee: nobody → Canonical X.org (canonical-x)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.