Xorg crashed with SIGABRT from xf86AutoConfigOutputDevice () when config=0x0

Bug #1054051 reported by Yann on 2012-09-21
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Timo Aaltonen

Bug Description

Crash with unknown origin for me

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: xserver-xorg-core 2:1.13.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic i686
ApportVersion: 2.5.2-0ubuntu4
Architecture: i386
Date: Fri Sep 21 15:21:03 2012
DistUpgraded: 2012-09-09 21:26:08,846 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.18, 3.5.0-14-generic, i686: installed
 virtualbox, 4.1.18, 3.5.0-15-generic, i686: installed
ExecutablePath: /usr/bin/Xorg
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:3069]
   Subsystem: Hewlett-Packard Company Device [103c:3069]
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Hewlett-Packard Compaq Presario CQ61 Notebook PC
ProcCmdline: /usr/bin/X :0 -br -once -config /etc/X11/xorg.conf.failsafe -logfile /var/log/Xorg.failsafe.log
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-15-generic root=UUID=35b153aa-8c81-4ba1-9b0a-80a4770d8f15 ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: Xorg crashed with SIGABRT
UpgradeStatus: Upgraded to quantal on 2012-09-09 (11 days ago)
UserGroups:

dmi.bios.date: 10/13/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.20
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3069
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 21.14
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.20:bd10/13/2009:svnHewlett-Packard:pnCompaqPresarioCQ61NotebookPC:pvrRev1:rvnHewlett-Packard:rn3069:rvr21.14:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: Compaq Presario CQ61 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.8.0-0ubuntu1
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120917.7cfd42ce-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120917.7cfd42ce-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.8-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu1

Yann (yourfrenchman) wrote :

StacktraceTop:
 xf86AutoConfigOutputDevice (pScrn=0xb83f2d30, master=0xb8194768) at ../../../../hw/xfree86/modes/xf86Crtc.c:3270
 xf86platformAddDevice (index=0) at ../../../../hw/xfree86/common/xf86platformBus.c:456
 NewGPUDeviceRequest (attribs=0xb83c1c48) at ../../../../../hw/xfree86/os-support/linux/lnx_platform.c:141
 config_udev_odev_setup_attribs (path=path@entry=0xb83caa58 "/dev/dri/card0", syspath=syspath@entry=0xb83ba8e0 "/sys/devices/pci0000:00/0000:00:02.0/drm/card0", probe_callback=0xb765ebf0 <NewGPUDeviceRequest>) at ../../config/udev.c:441
 device_added (udev_device=udev_device@entry=0xb83b9ee8) at ../../config/udev.c:103

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2012-09-24
summary: - Xorg crashed with SIGABRT
+ Xorg crashed with SIGABRT from xf86AutoConfigOutputDevice ()
Changed in xorg-server (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged

Crashes dereferencing config:

    master_provider = config->randr_provider;

This code is from patch 228_autobind_gpu.patch, added in version 2:1.13.0-0ubuntu2 for autobinding gpus.

Bryce Harrington (bryce) on 2012-09-24
summary: - Xorg crashed with SIGABRT from xf86AutoConfigOutputDevice ()
+ Xorg crashed with SIGABRT from xf86AutoConfigOutputDevice () when
+ config=0x0
Timo Aaltonen (tjaalton) wrote :

does it happen every time when you boot up?

Changed in xorg-server (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: Triaged → Incomplete
Timo Aaltonen (tjaalton) on 2012-09-25
tags: added: rls-q-incoming
Yann (yourfrenchman) wrote :

Mostly yes ...

Timo Aaltonen (tjaalton) wrote :

fixed package uploaded to the queue

Changed in xorg-server (Ubuntu):
status: Incomplete → Fix Committed
visibility: private → public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.13.0-0ubuntu5

---------------
xorg-server (2:1.13.0-0ubuntu5) quantal; urgency=low

  * Update 228_autobind_gpu.patch to not crash when the device has no
    randr provider. (LP: #1054051)
 -- Timo Aaltonen <email address hidden> Tue, 25 Sep 2012 09:46:44 +0300

Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers