Xorg crashed with SIGABRT in SetCompatOutput()

Bug #1043458 reported by Dave_Jones on 2012-08-29
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Unassigned

Bug Description

Trying to boot a gui from a usb live image. low graphics mode appears and won't let me navigate options to repair - no mouse cursor.
Copied xorg.conf.failsafe to xorg.conf
a desktop gui then displays afetr servcie lightdm restart but no panel, dash etc
from a pseudo terminal compiz --replace fails

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: xserver-xorg-core 2:1.12.99.905-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-13.13-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu3
Architecture: amd64
CasperVersion: 1.321
Date: Wed Aug 29 17:40:09 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xorg
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:3389]
 Advanced Micro Devices [AMD] nee ATI Whistler XT [AMD Radeon HD 6700M Series] [1002:6740] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:3389]
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120824)
MachineType: Hewlett-Packard HP Pavilion dv7 Notebook PC
ProcCmdline: X -br -ac -noreset -nolisten tcp vt7 :0
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 xf86SetScrnInfoModes ()
 xf86InitialConfiguration ()
 ?? () from /usr/lib/xorg/modules/drivers/modesetting_drv.so
 ?? () from /usr/lib/xorg/modules/drivers/modesetting_drv.so
 InitOutput ()
Title: Xorg crashed with SIGABRT in xf86SetScrnInfoModes()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 10/05/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.1B
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3389
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 10.31
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.1B:bd10/05/2011:svnHewlett-Packard:pnHPPaviliondv7NotebookPC:pvr058C110000244720001620100:rvnHewlett-Packard:rn3389:rvr10.31:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion dv7 Notebook PC
dmi.product.version: 058C110000244720001620100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.38-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120821.c1114c61-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120821.c1114c61-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.905-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1

Dave_Jones (squilla-dave) wrote :

StacktraceTop:
 SetCompatOutput (config=0x7f28cd5445c0) at ../../../../hw/xfree86/modes/xf86Crtc.c:1848
 xf86SetScrnInfoModes (scrn=scrn@entry=0x7f28cd532c20) at ../../../../hw/xfree86/modes/xf86Crtc.c:1862
 xf86InitialConfiguration (scrn=0x7f28cd532c20, canGrow=1) at ../../../../hw/xfree86/modes/xf86Crtc.c:2522
 ?? ()
 ?? ()

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
summary: - Xorg crashed with SIGABRT in xf86SetScrnInfoModes()
+ Xorg crashed with SIGABRT in SetCompatOutput()
tags: removed: need-amd64-retrace
Timo Aaltonen (tjaalton) on 2012-09-20
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) on 2012-09-20
Changed in xorg-server (Ubuntu):
importance: Medium → High
Jonas Schwabe (jonas-schwabe) wrote :

Blacklisting radeon is a work around. Using catalyst should work as well I guess.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.13.0-0ubuntu4

---------------
xorg-server (2:1.13.0-0ubuntu4) quantal; urgency=low

  * Add patches to fix issues with hybrid graphics:
    - 230-fix-compat-output-selection.patch
      Fix compat output selection when the GPU has no outputs
      (LP: #1043458)
    - 231-scan-pci-after-probing-devices.patch
      Fix a race condition when dynamically powering off secondary GPU's
 -- Timo Aaltonen <email address hidden> Thu, 20 Sep 2012 14:34:45 +0300

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.