Ubuntu

Xorg crashed with SIGABRT - FatalError (f=f@entry=0x7f41e2f9a9e2 "no screens found")

Reported by Nightdude on 2012-08-16
982
This bug affects 109 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Robert Hooker

Bug Description

started system.. first in Ubuntu 3d.. no Unity or panels.

Rebooted in Gnome.. crashed, no panels.

This is a dupe of bug 982889

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: xserver-xorg-core 2:1.12.99.904-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-10.10-generic 3.5.1
Uname: Linux 3.5.0-10-generic x86_64
ApportVersion: 2.4-0ubuntu7
Architecture: amd64
CrashCounter: 1
Date: Thu Aug 16 07:17:05 2012
DistUpgraded: 2012-07-25 21:55:38,928 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xorg
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:02bc]
   Subsystem: Dell Device [1028:02bc]
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: Dell Inc. Vostro 1520
ProcCmdline: /usr/bin/X :1 -core -auth /var/run/lightdm/root/:1 -nolisten tcp vt7 -novtswitch
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-10-generic root=UUID=96a2e78c-772d-4b89-986f-a6f29a921dda ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 OsAbort ()
 ?? ()
 FatalError ()
Title: Xorg crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to quantal on 2012-07-26 (21 days ago)
UserGroups: fuse
dmi.bios.date: 09/10/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0T816J
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd09/10/2009:svnDellInc.:pnVostro1520:pvrNull:rvnDellInc.:rn0T816J:rvr:cvnDellInc.:ct8:cvrN/A:
dmi.product.name: Vostro 1520
dmi.product.version: Null
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.8+bzr3249-0ubuntu4
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.38-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.4-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.4-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.904-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1

StacktraceTop:
 OsAbort () at ../../os/utils.c:1266
 AbortServer () at ../../os/log.c:635
 FatalError (f=f@entry=0x7f41e2f9a9e2 "no screens found") at ../../os/log.c:773
 main (argc=9, argv=0x7fffdc7ef7a8, envp=<optimized out>) at ../../dix/main.c:207

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
summary: - Xorg crashed with SIGABRT in raise()
+ Xorg crashed with SIGABRT in OsAbort()
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Looks like the xserver was trying to exit with a failure, and then crashed trying to print out an error message.

Did it crash just the once or has it continued to crash? In particular has it crashed with xserver 2:1.12.99.905-0ubuntu3 ?

summary: - Xorg crashed with SIGABRT in OsAbort()
+ Xorg crashed with SIGABRT - FatalError (f=f@entry=0x7f41e2f9a9e2 "no
+ screens found")
Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) on 2012-08-28
visibility: private → public
Roy Kishun (roy-kishun) wrote :

 It has crashed multiple times in my case...

[rkishun-ubuntu]grep -i xorg apport.log* | grep -i crash
apport.log:ERROR: apport (pid 4815) Tue Aug 28 11:05:30 2012: wrote report /var/crash/_usr_bin_Xorg.0.crash
apport.log.1:ERROR: apport (pid 3171) Mon Aug 27 09:02:11 2012: apport: report /var/crash/_usr_bin_Xorg.0.crash already exists and unseen, doing nothing to avoid disk usage DoS
apport.log.1:ERROR: apport (pid 3189) Mon Aug 27 09:02:23 2012: apport: report /var/crash/_usr_bin_Xorg.0.crash already exists and unseen, doing nothing to avoid disk usage DoS
apport.log.1:ERROR: apport (pid 5990) Mon Aug 27 09:36:54 2012: wrote report /var/crash/_usr_bin_Xorg.0.crash

tags: added: bugpattern-needed
Ursula Junque (ursinha) wrote :

Hello Bryce,

This is happening every time I restart lightdm and log back in. I'm on quantal and am using package xserver-xorg-core version 2:1.13.0-0ubuntu5.

Cheers,

Ursula

Changed in xorg-server (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2012-10-01
Changed in xorg-server (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Canonical X.org (canonical-x)
importance: Medium → High
Bryce Harrington (bryce) wrote :

Robert, would you mind seeing a) if you can reproduce this crash or spot why it's happening, and b) forward it upstream?

Changed in xorg-server (Ubuntu):
assignee: Canonical X.org (canonical-x) → Robert Hooker (sarvatt)
major_ghz (major-ghz) wrote :

Hello,
I don't know if that here i can post a solution on a problem with i915 series.

i was a "no screen found" after an upgrade of 12.04 to 12.10

i add a i915.conf in /etc/modprobe.conf
with : options i915 modeset=1

my lspci:
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

if you need more precision i reply with pleasure.
regard,
major_ghz.

tags: added: raring
Bryce Harrington (bryce) wrote :

A workaround is to add some sleep to /etc/init/lightdm.conf:

    sleep 1
    exec lightdm

description: updated
Bryce Harrington (bryce) wrote :

Since there's so many dupes on this bug, Launchpad times out when I try to dupe it to #982889, but this is the same problem as that bug.

aelgali (aelgali) wrote :

still happening in Ubuntu 13.04 prerelease.

Israel Dahl (israeldahl) wrote :

This bug is related to the other 13.04 bug I have that has rendered Unity useless. These are critical crippling bugs that completely destroy Unity... though LXDE (lubuntu) DE is working beautifully!!

link to other bug (might be the same?? not sure)
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1128348

Maarten Lankhorst (mlankhorst) wrote :

The bug in xorg-server should be fixed with 1.13.3-0ubuntu1, other related bugs may still occur however. Please refer to bug #982889 for the other packages involved.

Changed in xorg-server (Ubuntu):
status: Triaged → In Progress
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers