GNOME crashed when resuming from sleep in NVIDIA performance mode with disconnecting dell-wd19tb-dock

Bug #1879893 reported by Shih-Yuan Lee on 2020-05-21
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Undecided
Unassigned
X.Org X server
Unknown
Unknown
xorg-server (Ubuntu)
Status tracked in Groovy
Bionic
Undecided
Unassigned
Focal
High
Timo Aaltonen
Groovy
Undecided
Timo Aaltonen
xorg-server-hwe-18.04 (Ubuntu)
Status tracked in Groovy
Bionic
Undecided
Timo Aaltonen
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned

Bug Description

1. Install Ubuntu 18.04.2 LTS with linux-oem-osp1 kernel, xserver-xorg-hwe-18.04 and nvidia-driver-440.
2. Select the performance mode in NVIDIA settings and reboot the system.
3. Connect dell-wd19tb-dock to the system.
4. Connect external HDMI monitor to dell-wd19tb-dock.
5. Open a terminal, some GUI applications and then execute `systemctl suspend` in the terminal.
6. Disconnect dell-wd19tb-dock after the system fell asleep.
7. Resume the system and login the GNOME desktop environment.

Expected result:
The terminal and other GUI applications will still exist.

Actual result:
All opened GUI applications in GNOME are gone.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xserver-xorg-core-hwe-18.04 2:1.20.5+git20191008-0ubuntu1~18.04.1
ProcVersionSignature: Ubuntu 5.0.0-1052.57-oem-osp1 5.0.21
Uname: Linux 5.0.0-1052-oem-osp1 x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu7.14
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu May 21 03:31:41 2020
DistributionChannelDescriptor:
 # This is the distribution channel descriptor for the OEM CDs
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-bionic-amd64-20190418-59+beaver-osp1-gilly+X33
InstallationDate: Installed on 2020-05-06 (14 days ago)
InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 20190418-12:10
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg-server-hwe-18.04
UpgradeStatus: No upgrade log present (probably fresh install)

Shih-Yuan Lee (fourdollars) wrote :
tags: added: somerville-1857443
Timo Aaltonen (tjaalton) on 2020-05-21
Changed in xorg-server-hwe-18.04 (Ubuntu Focal):
status: New → Invalid
Changed in xorg-server-hwe-18.04 (Ubuntu):
status: New → Invalid
Changed in xorg-server (Ubuntu Bionic):
status: New → Won't Fix
Changed in xorg-server (Ubuntu Focal):
assignee: nobody → Timo Aaltonen (tjaalton)
Changed in xorg-server-hwe-18.04 (Ubuntu Bionic):
assignee: nobody → Timo Aaltonen (tjaalton)
Shih-Yuan Lee (fourdollars) wrote :

I made this patch by the changes from https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/443/ for xorg-server-hwe-18.04 in bionic, and it works.

The attachment "Modesetting-do-not-stop-on-EnterVT-when-connectors-have-disapeared.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in xorg-server (Ubuntu Focal):
status: New → Fix Committed
importance: Undecided → High
Timo Aaltonen (tjaalton) on 2020-05-21
Changed in xorg-server (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in xorg-server-hwe-18.04 (Ubuntu Bionic):
status: New → In Progress

Hello Shih-Yuan, or anyone else affected,

Accepted xorg-server into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xorg-server/2:1.20.8-2ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in xorg-server (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Daniel van Vugt (vanvugt) wrote :

Can we say which of bug 1421808 / bug 1787332 / bug 1787338 this might be?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

xorg-server (2:1.20.8-2ubuntu3) groovy; urgency=medium

  * modesetting-do-not-stop-on-entervt.diff: Don't crash if connectors
    go missing. (LP: #1879893)

 -- Timo Aaltonen <email address hidden> Thu, 21 May 2020 11:22:15 +0300

Changed in xorg-server (Ubuntu Groovy):
status: Confirmed → Fix Committed
tags: added: hybrid nvidia prime
Shih-Yuan Lee (fourdollars) wrote :

I have tested xorg-server/2:1.20.8-2ubuntu2.1 in focal-proposed and it can fix this issue.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal

All autopkgtests for the newly accepted xorg-server (2:1.20.8-2ubuntu2.1) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

gscan2pdf/2.6.4-1 (s390x)
openjdk-8/8u252-b09-1ubuntu1 (armhf)
apport/2.20.11-0ubuntu27 (amd64)
jsunit/0.2.2-2 (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#xorg-server

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Timo Aaltonen (tjaalton) wrote :

This is also in bionic-proposed for testing, but tracking is broken because I forgot to include the changelog entry in .changes

Changed in xorg-server-hwe-18.04 (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Daniel van Vugt (vanvugt) wrote :

Can we say which of bug 1421808 / bug 1787332 / bug 1787338 this might be?

Shih-Yuan Lee (fourdollars) wrote :

I didn't see any crash log under /var/crash after this issue happened so bug 1421808 / bug 1787332 / bug 1787338 might be irrelevant.

Shih-Yuan Lee (fourdollars) wrote :

I have tested xorg-server-hwe-18.04 2:1.20.8-2ubuntu2.1~18.04.1 in bionic-proposed and it can fix the issue.

tags: added: verification-done-bionic
removed: verification-needed-bionic

The verification of the Stable Release Update for xorg-server has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.20.8-2ubuntu2.1

---------------
xorg-server (2:1.20.8-2ubuntu2.1) focal; urgency=medium

  * modesetting-do-not-stop-on-entervt.diff: Don't crash if connectors
    go missing. (LP: #1879893)

 -- Timo Aaltonen <email address hidden> Thu, 21 May 2020 11:22:15 +0300

Changed in xorg-server (Ubuntu Focal):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Note the fix is released in focal-updates, but still stuck in groovy-proposed.

Changed in xorg-server (Ubuntu Groovy):
assignee: nobody → Timo Aaltonen (tjaalton)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server-hwe-18.04 - 2:1.20.8-2ubuntu2.1~18.04.1

---------------
xorg-server-hwe-18.04 (2:1.20.8-2ubuntu2.1~18.04.1) bionic; urgency=medium

  * Backport for 18.04.5 HWE stack update. (LP: #1876882)
  * control: Relax debhelper requirement.
  * control: Relax libepoxy-dev requirement, we don't need
    EGL_MESA_query_driver on bionic.
  * rules: xdmx-tools isn't packaged, so don't try to skip it.

 -- Timo Aaltonen <email address hidden> Thu, 14 May 2020 22:05:06 +0300

Changed in xorg-server-hwe-18.04 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.20.8-2ubuntu4

---------------
xorg-server (2:1.20.8-2ubuntu4) groovy; urgency=medium

  * xfree86-add-drm-modes-on-non-GTF-panels.patch: Add GTF modes on
    continuous-frequency monitors. (LP: #1883497)

 -- Timo Aaltonen <email address hidden> Wed, 24 Jun 2020 08:50:33 +0300

Changed in xorg-server (Ubuntu Groovy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.