upgrading caused a broken apt cache due to *-lts-vivid packages conflicting with current X packages

Bug #1571677 reported by Mario Limonciello on 2016-04-18
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xorg-lts-transitional (Ubuntu)
Critical
Timo Aaltonen

Bug Description

I upgraded from a 14.04 release that had the various *-lts-vivid packages installed to 16.04 using do-release-upgrade -d.

After upgrading the apt cache is busted because none of the meta and xorg-core packages can get installed.

t@t-XPS-13-9350:/var/crash$ sudo apt upgrade
[sudo] password for t:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-dri-lts-vivid : Conflicts: libgl1-mesa-dri
 xserver-xorg-core-lts-vivid : Conflicts: xserver-xorg-core
                               Conflicts: xserver-xorg-video-modesetting
 xserver-xorg-lts-vivid : Conflicts: libgl1-mesa-dri (>= 0~)
                          Conflicts: libxatracker2 (>= 0~)
                          Conflicts: xserver-xorg
                          Conflicts: xserver-xorg-core (>= 0~)
                          Conflicts: xserver-xorg-video-all (>= 0~) but 1:7.7+13ubuntu3 is to be installed
                          Recommends: xserver-xorg-input-all-lts-vivid but it is not installable
                          Recommends: xserver-xorg-video-all-lts-vivid but it is not installable
                          Recommends: libegl1-mesa-drivers-lts-vivid but it is not installable
                          Recommends: libgles2-mesa-lts-vivid but it is not installable
                          Recommends: libgles1-mesa-lts-vivid but it is not installable
E: Broken packages

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:16.04.11
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Uname: Linux 4.4.0-18-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Mon Apr 18 09:14:22 2016
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-trusty-amd64-osp1-20150720-0
InstallationDate: Installed on 2016-04-03 (14 days ago)
InstallationMedia: Ubuntu 14.04 "Trusty" - Build amd64 LIVE Binary 20150720-04:06
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: Upgraded to xenial on 2016-04-18 (0 days ago)

Mario Limonciello (superm1) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

there were no transitional packages for lts-{utopic,vivid,wily}, but I've now uploaded xorg-lts-transitional for xenial which should fix this.. it's still in NEW queue though, but test upgrade after it's available

affects: ubuntu-release-upgrader (Ubuntu) → xorg-lts-transitional (Ubuntu)
Changed in xorg-lts-transitional (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: Confirmed → Incomplete
Timo Aaltonen (tjaalton) wrote :

in the meantime, could you try ppa:tjaalton/test ?

I already had resolved the conflicts manually after I filed this bug, so it
is already upgraded.

On Tue, Apr 19, 2016 at 5:55 AM Timo Aaltonen <email address hidden> wrote:

> in the meantime, could you try ppa:tjaalton/test ?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1571677
>
> Title:
> upgrading caused a broken apt cache due to *-lts-vivid packages
> conflicting with current X packages
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xorg-lts-transitional/+bug/1571677/+subscriptions
>

Timo Aaltonen (tjaalton) wrote :

No worries, I tried it myself and it worked. Just need to fix it so it gets out of update_excuses..

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1571677

tags: added: iso-testing
Erick Brunzell (lbsolost) wrote :

I suspect bug 1561420 is also a duplicate.

Timo Aaltonen (tjaalton) wrote :

should be fixed with 3:9

xorg-lts-transitional (3:9) xenial; urgency=medium

  * Clear libopenvg1-mesa-* package depends.
  * Fix x-x-v-modesetting-dbg depends.

 -- Timo Aaltonen <email address hidden> Wed, 20 Apr 2016 00:32:08 +0300
xorg-lts-transitional (3:8) xenial; urgency=medium

  * Mesa dropped -dbg packages, depend on the main pkg instead.
  * kbd, mouse, modesetting, s3 are gone, depend on main xserver instead.
  * xspice was never built on i386, drop it from the arch list.
  * Fix short description template so they make more sense.

 -- Timo Aaltonen <email address hidden> Tue, 19 Apr 2016 22:12:01 +0300

xorg-lts-transitional (3:7) xenial; urgency=medium

  * Update for xenial
    - update packages
    - update gencontrol
    - drop obsolete postinst scripts

 -- Timo Aaltonen <email address hidden> Tue, 19 Apr 2016 00:55:33 +0300

Changed in xorg-lts-transitional (Ubuntu):
status: Incomplete → Fix Released
Changed in xorg-lts-transitional (Ubuntu):
importance: Undecided → Critical
Brian Murray (brian-murray) wrote :

I upgrade from Trusty (with the lts-vivid packages installed) to Xenial today and I was able to log into an X desktop. Here's part of my /var/log/dist-upgrade/apt-term.log showing the upgrade:

Unpacking xserver-common (2:1.18.3-1ubuntu2) over (2:1.15.1-0ubuntu2.7) ...^M
Preparing to unpack .../xserver-xorg-core-lts-vivid_3%3a9_amd64.deb ...^M
Unpacking xserver-xorg-core-lts-vivid (3:9) over (2:1.17.1-0ubuntu3.1~trusty1) ...^M
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...^M
dpkg: xserver-xorg-lts-vivid: dependency problems, but removing anyway as you requested:^M
 xorg depends on xserver-xorg (>= 1:7.7+1ubuntu8.1) | xserver-xorg-renamed; however:^M
  Package xserver-xorg is not installed.^M
  Package xserver-xorg-renamed is not installed.^M
  Package xserver-xorg-lts-vivid which provides xserver-xorg-renamed is to be removed.^M
 xorg depends on xserver-xorg (>= 1:7.7+1ubuntu8.1) | xserver-xorg-renamed; however:^M
  Package xserver-xorg is not installed.^M
  Package xserver-xorg-renamed is not installed.^M
  Package xserver-xorg-lts-vivid which provides xserver-xorg-renamed is to be removed.^M
^M
(Reading database ... ^M(Reading database ... 5%^M(Reading database ... 10%^M(Reading database ... 15%^M(Reading database ... 20%^M(Reading database ... 25%^M(Reading database ... 30%^M(Reading database ... 35%^M(Reading database ... 40%^M(Reading database ... 45%^M(Reading database ... 50%^M(Reading database ... 55%^M(Reading database ... 60%^M(Reading database ... 65%^M(Reading database ... 70%^M(Reading database ... 75%^M(Reading database ... 80%^M(Reading database ... 85%^M(Reading database ... 90%^M(Reading database ... 95%^M(Reading database ... 100%^M(Reading database ... 263590 files and directories currently installed.)^M
Removing xserver-xorg-lts-vivid (1:7.7+7ubuntu3~trusty1) ...^M
Selecting previously unselected package xserver-xorg-core.^M
(Reading database ... ^M(Reading database ... 5%^M(Reading database ... 10%^M(Reading database ... 15%^M(Reading database ... 20%^M(Reading database ... 25%^M(Reading database ... 30%^M(Reading database ... 35%^M(Reading database ... 40%^M(Reading database ... 45%^M(Reading database ... 50%^M(Reading database ... 55%^M(Reading database ... 60%^M(Reading database ... 65%^M(Reading database ... 70%^M(Reading database ... 75%^M(Reading database ... 80%^M(Reading database ... 85%^M(Reading database ... 90%^M(Reading database ... 95%^M(Reading database ... 100%^M(Reading database ... 263581 files and directories currently installed.)^M
Preparing to unpack .../xserver-xorg-core_2%3a1.18.3-1ubuntu2_amd64.deb ...^M
Unpacking xserver-xorg-core (2:1.18.3-1ubuntu2) ...^M
Selecting previously unselected package xserver-xorg.^M
Preparing to unpack .../xserver-xorg_1%3a7.7+13ubuntu3_amd64.deb ...^M
Unpacking xserver-xorg (1:7.7+13ubuntu3) ...^M
Selecting previously unselected package xserver-xorg-lts-vivid.^M
Preparing to unpack .../xserver-xorg-lts-vivid_3%3a9_amd64.deb ...^M
Unpacking xserver-xorg-lts-vivid (3:9) ...^M

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers