Can not installed xserver-xorg-lts-saucy.(Conflicts)

Bug #1268463 reported by katsu on 2014-01-13
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
xorg-lts-saucy (Ubuntu)
Undecided
Unassigned

Bug Description

[condition]
* ubuntu 12.04.4-64bit with lts-saucy kernel(kernel-3.11)
  (installed ubuntu 12.04.3 & linux-generic-lts-saucy & full update)

  but ubuntu 12.04.4-32bit in virtualbox --> no problem.
  (installed ubuntu 12.04.1 & linux-generic-lts-saucy & full update)

[situation]
$ sudo apt-get install xserver-xorg-lts-saucy
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-lts-saucy : Depends: xserver-xorg-core-lts-saucy (>= 2:1.11) but it is not going to be installed
                          Depends: xserver-xorg-video-all-lts-saucy but it is not going to be installed or
                                   xorg-driver-video
                          Depends: xserver-xorg-input-all-lts-saucy but it is not going to be installed or
                                   xorg-driver-input
                          Depends: xserver-xorg-input-evdev-lts-saucy but it is not going to be installed
                          Recommends: libgl1-mesa-dri-lts-saucy but it is not going to be installed
                          Recommends: libgl1-mesa-glx-lts-saucy but it is not going to be installed
                          Recommends: xserver-xorg-input-all-lts-saucy but it is not going to be installed
                          Recommends: xserver-xorg-video-all-lts-saucy but it is not going to be installed
                          Recommends: x11-xserver-utils-lts-saucy but it is not going to be installed
                          Conflicts: libgl1-mesa-glx (>= 0~)
                          Conflicts: libgl1-mesa-glx:i386 (>= 0~)
                          Conflicts: libglapi-mesa (>= 0~)
                          Conflicts: libglapi-mesa:i386 (>= 0~)
E: Unable to correct problems, you have held broken packages.

$ dpkg -l | grep libgl1-mesa-glx
ii libgl1-mesa-glx-lts-saucy 9.2.1-1ubuntu3~precise1 free implementation of the OpenGL API -- GLX runtime
ii libgl1-mesa-glx-lts-saucy:i386 9.2.1-1ubuntu3~precise1 free implementation of the OpenGL API -- GLX runtime

$ dpkg -l | grep libglapi-mesa
ii libglapi-mesa-lts-saucy 9.2.1-1ubuntu3~precise1 free implementation of the GL API -- shared library
ii libglapi-mesa-lts-saucy:i386 9.2.1-1ubuntu3~precise1 free implementation of the GL API -- shared library

* ADD Depends package for aptline.
--> but Conflicts is not canceled.

* same?: lts-raring bug
https://bugs.launchpad.net/ubuntu/+source/xorg-lts-raring/+bug/1191563

[workaround]
* installed with i386 package.
$ sudo apt-get install xserver-xorg-lts-saucy libglapi-mesa-lts-saucy:i386 libgl1-mesa-dri-lts-saucy:i386 libgl1-mesa-glx-lts-saucy:i386

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-lts-saucy (Ubuntu):
status: New → Confirmed
Konstantinos Spalas (konnn) wrote :

I removed the -lts-raring package first and then installed the -lts-sausy.No conficts and the installation was ok.

Dima Butyrin (dima.butyrin) wrote :

Looks like it can't resolve :i368 dependencies.
I've made:
dpkg --get-selections | grep lts

Find all :i368 packages and removed it with (in my case):
sudo apt-get remove libgl1-mesa-dri-lts-raring:i386 libgl1-mesa-glx-lts-raring:i386 libglapi-mesa-lts-raring:i386

After that:
sudo apt-get install linux-generic-lts-saucy xserver-xorg-lts-saucy

Bernhard (baumber) wrote :

Hello,

I can confirm the problems with the Xstacks too, there should be a smoother transition to new Xstacks (e.g. precise to saucy) and between Xstacks (e.g. raring to saucy) in LTS-versions.
Maybe it is possible to modify/tune the Xstack-meta-packages because it is not sufficient to install only package xserver-xorg-lts-saucy (and linux-generic-lts-saucy).

I had to use the following command (after removing the old Xstack with installing package xserver-xorg-lts-precise), but that is not smooth!

apt-get install -V libglapi-mesa-lts-saucy libgl1-mesa-glx-lts-saucy xserver-xorg-lts-saucy xserver-xorg-input-all-lts-saucy xserver-xorg-video-all-lts-saucy libgl1-mesa-dri-lts-saucy x11-xserver-utils-lts-saucy libglapi-mesa-lts-saucy:i386 libgl1-mesa-dri-lts-saucy:i386 libgl1-mesa-glx-lts-saucy:i386

Another problem is when using KDE/Kubuntu, you have to remove packages kde-workspace-dev libkwinactiveglesutils1 libkwinglesutils1.
After the installation you can install them again with "apt-get install kde-workspace-dev libkwinactiveglesutils1 libkwinglesutils1" and not with only "kde-workspace-dev" because dependency is broken.

The same with meta-package xorg-dev, it is broken too with the new Xstacks but installing single packages from this meta-package works.

It would be wise to check all dependencies (with a script) in the whole ubuntu repository for problems with the Xstacks and derived problems to get a better update/upgrade experience to Xstacks for the LTS-versions (at least for the new 14.04 LTS).

Thank you, best regards, Bernhard

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers