[FFe] Please sync xmoto 0.4.2-1 from Debian(Unstable)

Bug #204038 reported by Stefan Ebner
6
Affects Status Importance Assigned to Milestone
xmoto (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: xmoto

Please grant this sync :)
Some new features and bugfixes. I don't think there is a reason to not include it into hardy.

 xmoto (0.4.2-1) unstable; urgency=low

   * New upstream release.

 -- Samuel Mimram <email address hidden> Tue, 18 Mar 2008 20:27:10 +0100

xmoto (0.4.1-1) unstable; urgency=low

   * New upstream release.
   * Removed build-dependency on subversion.
   * Builds with gcc 4.3, closes: #462050.

 -- Samuel Mimram <email address hidden> Thu, 14 Feb 2008 21:36:29 +0100

Upstream Changelog:

X-Moto 0.4.2 2008-03-18
-----------------------
 * several rooms possible in configuration
 * option to remove levels not suitable for children
 * man page is no more gunzipped
 * AddPenaltyTime(), PlaySound(), PlayMusic(), StopMusic(), AddForceToPlayer(), SetCameraRotationSpeed() script functions (patches by gaivota)
 * ctrl + down/up in replays to adjust speed
 * --cleanNoWWWLevels to clean levels which are no longer available on the website (move them into ~/.xmoto/Trash)
 * biker interact with world when dead
 * fix layers while autozoom
 * major string printing speedup
 * some other minor modifications
 * dynamic camera while playing

X-Moto 0.4.1 2008-02-13
-----------------------
 * remove svnversion dependency for compilation
 * fix .desktop file
 * fix sqlite troubles
 * some new options to make videos
 * ctrl+s : enable/disable sound

Stefan Ebner (sebner)
Changed in xmoto:
assignee: nobody → sebner
status: New → In Progress
Revision history for this message
Stefan Ebner (sebner) wrote :

hellboy@ubuntu:/var/cache/pbuilder/result$ sudo dpkg -i xmoto*

(Reading database ... 387186 files and directories currently installed.)
Preparing to replace xmoto 0.4.0-2ubuntu1 (using xmoto_0.4.1-1ubuntu1_i386.deb) ...
Unpacking replacement xmoto ...
Preparing to replace xmoto-data 0.4.0-2ubuntu1 (using xmoto-data_0.4.1-1ubuntu1_all.deb) ...
Unpacking replacement xmoto-data ...

Setting up xmoto-data (0.4.1-1ubuntu1) ...
Setting up xmoto (0.4.1-1ubuntu1) ...

Of course the game is working fine :)

Changed in xmoto:
assignee: sebner → nobody
status: In Progress → New
description: updated
Revision history for this message
Cesare Tirabassi (norsetto) wrote :

xmoto is version 0.4.2-1 in unstable:

root@norsetto:/# rmadison -u debian xmoto
     xmoto | 0.2.2-2 | etch-m68k | source, m68k
     xmoto | 0.2.2-2 | stable | source, alpha, amd64, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
     xmoto | 0.3.4-1 | testing | source, alpha, amd64, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
     xmoto | 0.3.4-1 | unstable | m68k
     xmoto | 0.4.1-1 | unstable | armel, hppa, hurd-i386, ia64
     xmoto | 0.4.2-1 | unstable | source, alpha, amd64, arm, i386, mips, mipsel, powerpc, s390, sparc

Revision history for this message
Stefan Ebner (sebner) wrote :

I can swear that I checked that :(
Nvm. I'll change it :)

description: updated
Revision history for this message
Stefan Ebner (sebner) wrote : Re: [FFe] Merge xmoto 0.4.2-1 from Debian(Unstable)
Revision history for this message
Stefan Ebner (sebner) wrote :
Revision history for this message
Stefan Ebner (sebner) wrote :

hellboy@ubuntu:/var/cache/pbuilder/result$ sudo dpkg -i xmoto*

(Reading database ... 387215 files and directories currently installed.)
Preparing to replace xmoto 0.4.1-1ubuntu1 (using xmoto_0.4.2-1ubuntu1_i386.deb) ...
Unpacking replacement xmoto ...
Preparing to replace xmoto-data 0.4.1-1ubuntu1 (using xmoto-data_0.4.2-1ubuntu1_all.deb) ...
Unpacking replacement xmoto-data ...

Setting up xmoto-data (0.4.2-1ubuntu1) ...
Setting up xmoto (0.4.2-1ubuntu1) ...

And again: Running and working fine :)

Revision history for this message
StefanPotyra (sistpoty) wrote :

Also I suck at playing, ACK #1 from me. (Note to sponsors: the xmoto.desktop change seems wrong to me in the debdiff though, only the xmoto-editor.desktop change seems worthwhile).

Revision history for this message
Stefan Ebner (sebner) wrote :

Updated debdiff :)

Revision history for this message
Stefan Ebner (sebner) wrote :

Forget the debdiffs. I talked to Stephan Hermann. It's a sync :)

description: updated
Revision history for this message
Stefan Ebner (sebner) wrote :

The xmoto-edit.desktop isn't necessary since we don't ship the xmoto-edit package.
We can also take the xmoto.desktop file from debian since it's correct and we can reduce the delta.
This was the only remaining change so it's a sync :)

Revision history for this message
StefanPotyra (sistpoty) wrote :

sponsors ack from me for the sync (funnily, I test-build the sync for testing, not the proposed merge).

Revision history for this message
Scott Kitterman (kitterman) wrote :

Ack #2 and approved.

Changed in xmoto:
importance: Undecided → Wishlist
status: New → Confirmed
Revision history for this message
Steve Langasek (vorlon) wrote :

Package(s) synced.

Changed in xmoto:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers