xmms2 equalizer does not work

Bug #1589312 reported by dave on 2016-06-05
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xmms2 (Ubuntu)
Undecided
Unassigned

Bug Description

I have noticed the latest version of xmms2 does not allow the equalizer to work, I obtained a fix from debian and am hopeful it can be incorporated here soon and have attached a patch file to help.

And I have tested this fix and it worked on my systems.

Thanks

Dave

Revision history for this message
dave (dave1967) wrote :
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "This removes the inline declarations that made the equalizer fail." seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xmms2 (Ubuntu):
status: New → Confirmed
Revision history for this message
Aditya (meta1729) wrote :

I cannot use equalizer on Ubuntu 16.04, due to this error:

00:58:51 ERROR: ../src/xmms/plugin.c:375: Failed to open plugin /usr/lib/xmms2/libxmms_equalizer.so: /usr/lib/xmms2/libxmms_equalizer.so: undefined symbol: iir
00:58:51 ERROR: ../src/xmms/xform.c:1593: Couldn't find any effect named 'equalizer'

Revision history for this message
dave (dave1967) wrote :

If you want to try the patch I posted you could compile it yourself, I have stopped using ubuntu now as they seem to ignore bug reports so cannot say if it will work with the current version or not.

Revision history for this message
Aditya (meta1729) wrote : Re: [Bug 1589312] Re: xmms2 equalizer does not work

Thanks Dave, the patch worked. It could be included in the Ubuntu package.

On Tuesday 08 August 2017 05:38 PM, dave wrote:
> If you want to try the patch I posted you could compile it yourself, I
> have stopped using ubuntu now as they seem to ignore bug reports so
> cannot say if it will work with the current version or not.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers