xmms does not start on edgy

Bug #58192 reported by Martin Emrich on 2006-08-30
26
Affects Status Importance Assigned to Milestone
xmms (Ubuntu)
Undecided
Unassigned

Bug Description

Hi!

I just upgraded to edgy, and XMMS no longer starts:

martin@garrett:~$ xmms
Message: device: hw:0,0
XS[src/xmms-sid.c:xs_init:216]: xs_init()
XS[src/xs_config.c:xs_init_configuration:164]: initializing configuration ...
XS[src/xs_config.c:xs_read_configuration:265]: loading from config-file ...
XS[src/xs_config.c:xs_read_configuration:320]: OK
XS[src/xmms-sid.c:xs_reinit:163]: initializing emulator engine #2...
XS[src/xs_sidplay2.cc:xs_sidplay2_init:196]: init builder #1, maxsids=2
XS[src/xs_sidplay2.cc:xs_sidplay2_init:255]: ReSID V1.0.1 Engine:
XS[src/xmms-sid.c:xs_reinit:177]: init#1: OK, 2
XS[src/xmms-sid.c:xs_reinit:189]: init#2: OK, 0
XS[src/xmms-sid.c:xs_init:226]: OK
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 1509 error_code 8 request_code 72 minor_code 0
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 1510 error_code 8 request_code 72 minor_code 0
martin@garrett:~$

Ciao

Martin

LCID Fire (lcid-fire) wrote :

Same here

LCID Fire (lcid-fire) wrote :

BTW: banshee doesn't work either anymore (doesn't play sound) - perhaps it was a more global change...

Martin Emrich (emme) wrote :

After some time, I have the feeling that it is an incompatibility with my X server, maybe some fonts stuff (my emacs does only display white blocks as chars, then there is Bug #58232 ...).

I'm currently comparing my configuration with a freshly installed edgy (where everything works), but this might still take some days.

Ciao

Martin

John Vivirito (gnomefreak) wrote :

Is this still a problem for anyone with version 1.2.10+cvs20060429-1ubuntu1?

Changed in xmms:
status: Unconfirmed → Needs Info
Martin Emrich (emme) wrote :

Using 1.2.10+cvs20060429-1ubuntu:

martin@garrett:~$ xmms
Message: device: hw:0,0
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 1521 error_code 8 request_code 72 minor_code 0
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 1522 error_code 8 request_code 72 minor_code 0

Ciao

Martin

djwong (djwong) wrote :

Same for me w/ 1.2.10+cvs20060429-1ubuntu2:

[503]blackbox:~(0)> xmms
Message: device: default
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 2485 error_code 8 request_code 72 minor_code 0
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 2486 error_code 8 request_code 72 minor_code 0

djwong (djwong) wrote :

This bug has also been reported upstream: http://bugs.xmms.org/show_bug.cgi?id=1907 (Launchpad does not currently do upstream links to xmms bugzilla). Poor interaction between gdk1 and composite that causes crashes and weird behavior when double-size is enabled. I can also verify that setting XLIB_SKIP_ARGB_VISUALS=1 (or disabling double-size) makes the problem go away.

Michiel (fabermichiel) wrote :

I have the same problem,
Upgrade today to edgy

michiel@ubuntu-mifa:~$ xmms
Message: device: default
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 1526 error_code 8 request_code 72 minor_code 0
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 1527 error_code 8 request_code 72 minor_code 0

Firefox had the same problem. Crashed when opening websites containing flash. Solved by installing mozilla-flashplayer.

Is that maybe related?

John Vivirito (gnomefreak) wrote :

Can everyone please install xmms-dbgsym and run a backtrace and attach it to this bug. Thank you.

Dave Rolsky (autarch) wrote :

ENOSUCHPACKAGE (xmms-dbgsym), at least in edgy. If you point me towards such a package I'd be happy to do so, although a guide to generating the backtrace would be helpful too. I'm not a C programmer ;)

John Vivirito (gnomefreak) wrote :

xmms-dbgsym:
  Installed: (none)
  Candidate: 1.2.10+cvs20060429-1ubuntu2
  Version table:
     1.2.10+cvs20060429-1ubuntu2 0
        500 http://people.ubuntu.com edgy/main Packages

thats the output of apt-cache policy xmms-dbgsym

On Mon, 16 Oct 2006, John Vivirito wrote:

> xmms-dbgsym:
> Installed: (none)
> Candidate: 1.2.10+cvs20060429-1ubuntu2
> Version table:
> 1.2.10+cvs20060429-1ubuntu2 0
> 500 http://people.ubuntu.com edgy/main Packages
>
> thats the output of apt-cache policy xmms-dbgsym

That still doesn't tlel me where to get the package. I think there's a bit
missing from there, because that's not a valid repo.

Michiel (fabermichiel) wrote :

The solution given in bug #63144: "Clicking on the double size button crashes XMMS";

export XLIB_SKIP_ARGB_VISUALS=1

solves my problem. I then can run xmms without any problems

John Vivirito (gnomefreak) wrote :

deb http://archive.ubuntu.com/ubuntu/ edgy main restricted is the repo

Dave Rolsky (autarch) wrote :

On Tue, 17 Oct 2006, John Vivirito wrote:

> deb http://archive.ubuntu.com/ubuntu/ edgy main restricted is the repo

I do not see a package named xmms-dbg (or xmms-debug or anything like
that) in there. Taking a look in the pool at
http://archive.ubuntu.com/ubuntu/pool/main/x/xmms/ I _still_ don't see
such a package. I installed xmms-dev, and there's no alternate binary in
there.

John Vivirito (gnomefreak) wrote :

the package name is xmms-dbgsym not xmms-dbg. in terminal type apt-cache search xmms-dbgsym.

Michiel (fabermichiel) wrote :

I can't find the package either.
sudo apt-get install xmms-dbgsym
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package xmms-dbgsym

my sources.list

deb http://archive.ubuntu.com/ubuntu edgy main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu edgy main restricted universe multiverse

## MAJOR BUG FIX UPDATES produced after the final release
deb http://archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse

## UBUNTU SECURITY UPDATES
deb http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse

John Vivirito (gnomefreak) wrote :

After a while of trying to find out why i have it showing in "main" i have come to that the debugging repo it showing it in main. Please add this repo to your /etc/apt/sources.list file and run sudo apt-get update than install xmms-dbgsym.

the repo is: deb http://people.ubuntu.com/~pitti/ddebs edgy main universe

Martin Emrich (emme) wrote :

Installed xmms-dbgsym. Here's my gdb session, I had to interrupt because it stalled after the first error message:

martin@garrett:~$ LANG=C gdb xmms
GNU gdb 6.4.90-debian
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu"...Using host libthread_db library
"/lib/libthread_db.so.1".

(gdb) run
Starting program: /usr/bin/xmms
[Thread debugging using libthread_db enabled]
[New Thread 47162551178288 (LWP 9793)]

Gtk-WARNING **: Unable to locate loadable module in module_path: "libindustrial.
so",

Gtk-WARNING **: Unable to locate loadable module in module_path: "libindustrial.
so",

Gtk-WARNING **: Unable to locate loadable module in module_path: "libindustrial.
so",
[New Thread 1082132816 (LWP 9796)]

Gtk-WARNING **: Unable to locate loadable module in module_path: "libindustrial.
so",

Gtk-WARNING **: Unable to locate loadable module in module_path: "libindustrial.
so",

Gtk-WARNING **: Unable to locate loadable module in module_path: "libindustrial.
so",
Message: device: hw:0,0
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 1509 error_code 8 request_code 72 minor_code 0

 ----------------8<------- pressed CTRL-C here --------------->8----------

Program received signal SIGINT, Interrupt.
[Switching to Thread 47162551178288 (LWP 9793)]
0x00002ae4e2e3b7f6 in poll () from /lib/libc.so.6
(gdb) bt
#0 0x00002ae4e2e3b7f6 in poll () from /lib/libc.so.6
#1 0x00002ae4e2a5b146 in _XRead32 () from /usr/lib/libX11.so.6
#2 0x0004000500000007 in ?? ()
#3 0x0000000000000000 in ?? ()
(gdb) t 2
[Switching to thread 2 (Thread 1082132816 (LWP 9796))]#0 0x00002ae4e25eb8e6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
(gdb) bt
#0 0x00002ae4e25eb8e6 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#1 0x0000000000428e9f in ctrlsocket_func (arg=<value optimized out>)
    at controlsocket.c:230
#2 0x00002ae4e25e83ca in start_thread () from /lib/libpthread.so.0
#3 0x00002ae4e2e4455d in clone () from /lib/libc.so.6
#4 0x0000000000000000 in ?? ()
(gdb)

Ciao

Martin

Michiel (fabermichiel) wrote :

After a reboot i had the same problem again.

michiel@ubuntu-mifa:~/data/music$ xmms u2/
Message: device: default
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 1526 error_code 8 request_code 72 minor_code 0
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 1527 error_code 8 request_code 72 minor_code 0

an:

"export XLIB_SKIP_ARGB_VISUALS=1"

solved the problem immediatly.

For fixing the crash of Firefox related to flash, you have to use the same line.
What is this line doing actually?

Martin Emrich (emme) wrote :

Huh, this one still open..

"export XLIB_SKIP_ARGB_VISUALS=1" fixes it for me, too, both on my desktop (edgy amd64 w/ nvidia+xinerama) and my notebook (edgy i386 w/ radeon).

ricardisimo (ricardisimo) wrote :

What exactly does one need to do with the line "export XLIB_SKIP_ARGB_VISUALS=1"? Is this command line in a terminal, or in the launcher? Thanks.

Vassilis Pandis (pandisv) wrote :

ricardisimo: To run xmms, try in a terminal 'export XLIB_SKIP_ARGB_VISUALS=1' and then 'xmms' to start xmms.

Everybody: This appears to be an issue with gdk-imlib1, a patch for which was written by BernardB. Please take a look at the patch ( bug 70367 ) and report success or failure using it.

Michiel (fabermichiel) wrote :

I still can't set the size to double.
I haven't installed gdk-imlib1 at the moment. Should i do install the package to prevent the crash from happening? I cant think why it should be solved but i am willing to do so.

michiel@ubuntu-mifa:~$ xmms
Message: device: default
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 3050 error_code 8 request_code 72 minor_code 0

Michiel (fabermichiel) wrote :

for your information:
i am running a recent feisty fawn; upgraded from (... > dapper - >) edgy.
generic kernel

Michiel (fabermichiel) wrote :

installed gdk-imlib1 gdk-imlib11 imlib-base
but that did not solve the problem.

Regards mifa

Vassilis Pandis (pandisv) wrote :

Sorry, this seems to be a different issue (I just realized that xmms does not depend on imlib). Again, sorry for the trouble.

Martin Emrich (emme) wrote :

Just going through my old open bugs...

AFAIK this problem has hit many programs, not only XMMS, and it might be rather a problem with the Nvidia (and ATI) proprietary drivers.

Since "AddARGBGLXVisuals" is set in my xorg.conf, I no longer have this problem. AFAIK this is set by default since feisty.

Ciao

Martin

Launchpad Janitor (janitor) wrote :

[Expired for xmms (Ubuntu) because there has been no activity for 60 days.]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers