missing Breaks/Replaces

Bug #878180 reported by Colin Watson on 2011-10-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xmlrpc-c (Ubuntu)
High
Robie Basak

Bug Description

The xmlrpc-c binary packages have been reorganised in the upload with binaries currently waiting in NEW. Some of these overlap with binaries that were previously in Ubuntu (they may have been Ubuntu-specific), and not all the required Breaks/Replaces fields are present. In particular, I believe you need:

  libxmlrpc-c++4 Breaks/Replaces: libxmlrpc-c3-0 (<< 1.16.33-3.1ubuntu1)
  libxmlrpc-core-c3 Breaks/Replaces: libxmlrpc-core-c3-0 (<< 1.16.33-3.1ubuntu1)

(Some of the binaries in this source package already use Conflicts/Replaces pairs for similar purposes. This is discouraged by the Debian policy manual nowadays in favour of Breaks/Replaces, although quite a few packages still use the older incorrect approach.)

Related branches

Colin Watson (cjwatson) on 2011-10-19
Changed in xmlrpc-c (Ubuntu):
importance: Undecided → High
Dave Walker (davewalker) on 2011-10-19
Changed in xmlrpc-c (Ubuntu):
assignee: nobody → Dave Walker (davewalker)
milestone: none → precise-alpha-1
status: New → Confirmed
Robie Basak (racb) wrote :

I've looked at the differences between the files installed by 1.16.32-0ubuntu4 (oneiric) and 1.16.33-3.1ubuntu2 (current precise) respectively. A summary is attached.

New packages are: libxmlrpc-c++4, libxmlrpc-c++4-dev, libxmlrpc-core-c3 and xmlrpc-api-utils.

libxmlrpc-core-c3 did not exist in natty or oneiric but did exist in lucid. libxmlrpc-core-c3-dev has existed since lucid. This strikes me as odd but doesn't seem to need looking at here. Also, xmlrpc-api-utils (new package) is in universe; all other packages are in main.

Old packages xml-rpc-api2cpp and xml-rpc-api2txt no longer exist, and files in those two packages have moved to xmlrpc-api-utils.

Files previously in libxmlrpc-c3-0 have moved to both libxmlrpc-c++4 and libxmlrpc-core-c3.

Files previously in libxmlrpc-c3-dev have moved to both libxmlrpc-c++4-dev and libxmlrpc-core-c3-dev.

Files previously in libxmlrpc-core-c3-0 have moved to libxmlrpc-core-c3.

Files previously in libxmlrpc-core-c3-dev have moved to libxmlrpc-c++4-dev.

So in addition to Colin's breaks/replaces lines above, I have also added libxmlrpc-c++4-dev breaks/replaces libxmlrpc-core-c3-dev (<< 1.16.33-3.1ubuntu2) and libxmlrpc-core-c3 breaks/replaces libxmlrpc-c3-0 (<< 1.16.33-3.1ubuntu2).

I've also updated a couple of existing conflicts to << 1.16.33-3.1ubuntu2, since I've found files that they apply to since Oneiric. I've changed these to breaks while I'm changing the lines anyway, but left conflicts in place where I haven't need to touch them.

Dave Walker (davewalker) on 2011-10-21
Changed in xmlrpc-c (Ubuntu):
assignee: Dave Walker (davewalker) → Robie Basak (racb)
Robie Basak (racb) wrote :

Following Dave's query on the Lucid -> Precise path, I've gone back to look at the files that have been replaced between all three versions. To stop this getting too confusing for me, I wrote a script to do it. My script found a couple of adjustments:

1) Some of my new Breaks/Replaces entries were unnecessarily restrictive on versioning; for binary packages that no longer exist, it's sufficient just to name them.

2) One package (libxmlrpc-c3-dev) vanished in Oneiric but has reappeared in Precise, so the Replaces line now needs a version restriction applied, since the Precise version of libxmlrpc-c3-dev has no replacements made by the Precise version of libxmlrpc-core-c3-dev.

I've updated my branch, attached the analysis from my script, and uploaded the script itself to http://bazaar.launchpad.net/~racb/+junk/deb-find-breaks/revision/1/deb-find-breaks.py

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xmlrpc-c - 1.16.33-3.1ubuntu2

---------------
xmlrpc-c (1.16.33-3.1ubuntu2) precise; urgency=low

  * Rename libxmlrpc-core-c3-0-udeb to libxmlrpc-core-c3-udeb to match the deb
    variant from Debian (LP: #878716).
  * Add Breaks/Replaces to cover binary package reorganisation (LP: #878180).
 -- Robie Basak <email address hidden> Thu, 20 Oct 2011 15:46:59 +0100

Changed in xmlrpc-c (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers