Package very out of date

Bug #1865344 reported by Steveire on 2020-03-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xmlrpc-c (Ubuntu)
Undecided
Unassigned

Bug Description

The package is very out of date for all ubuntu releases:

 https://packages.ubuntu.com/bionic/libxmlrpc-core-c3-dev

Version 1.33.14 is a release from mid 2014.

One of the problems that causes is that it can't be used with current boost releases:

 https://github.com/boostorg/qvm/issues/23

If the package can be patched in all supported ubuntu releases, the xmlrpc maintainer reports:

> You can easily fix this locally just by deleting the problematic #define in
> abyss.h. The macro is used in Xmlrpc-c source code and mistakenly defined in
> the interface header file. No Xmlrpc-c user needs it.

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

This is one of several packages which Ubuntu syncs from Debian, so I took a look to see if there was a corresponding bug report or more information there. That's when I found the package had been orphaned for a while, so looks like it needs a new maintainer. See https://tracker.debian.org/pkg/xmlrpc-c or https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773435 for more details.

tags: added: upgrade-software-version
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.