Need to create POT template on build

Bug #868554 reported by David Planella on 2011-10-05
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
xkeyboard-config (Ubuntu)
High
Timo Aaltonen

Bug Description

This is a regression from bug 562872

Looking at the the xkeyboard-config (2.3-1ubuntu1) changelog it seems that the template update generation rule was dropped from the package, causing again an outdated POT file being uploaded and some strings neither being translatable in Launchpad nor being translated in language packs.

Please re-add the POT template building logic.

Thanks!

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xkb-data 2.3-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Wed Oct 5 19:06:58 2011
Dependencies:

DistUpgraded: Log time: 2011-09-06 06:47:06.668064
DistroCodename: oneiric
DistroVariant: ubuntu
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: ECS GeForce7050M-M
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=ca_ES:en
 LANG=ca_ES.utf8
 LC_MESSAGES=ca_ES.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=0e5b2a04-a2c8-433a-8cd6-b7e8fd8667b6 ro quiet splash vt.handoff=7
SourcePackage: xkeyboard-config
UpgradeStatus: Upgraded to oneiric on 2011-09-06 (29 days ago)
dmi.bios.date: 09/12/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080014
dmi.board.name: GeForce7050M-M
dmi.board.vendor: ECS
dmi.board.version: 1.0
dmi.chassis.type: 3
dmi.chassis.vendor: ECS
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080014:bd09/12/2008:svnECS:pnGeForce7050M-M:pvr1.0:rvnECS:rnGeForce7050M-M:rvr1.0:cvnECS:ct3:cvr:
dmi.product.name: GeForce7050M-M
dmi.product.version: 1.0
dmi.sys.vendor: ECS
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.ia32-libs: ia32-libs 20090808ubuntu24
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

David Planella (dpm) wrote :
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
tags: added: needs-pot-on-build
Timo Aaltonen (tjaalton) wrote :

Ok, so how does launchpad get the updated pot-file? From the source package, or in-flight during the build?

The issue I had (why I removed the logic) was that it left the source tree in an unclean state after a test build, and failed to see the bigger picture so I just dropped it. There are options around that, but I need to be sure the updated file is included properly before a new version is uploaded.

Changed in xkeyboard-config (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → Triaged
Timo Aaltonen (tjaalton) on 2011-10-05
Changed in xkeyboard-config (Ubuntu):
importance: Undecided → High
Timo Aaltonen (tjaalton) wrote :

Ok I think this is sufficiently fixed now. The build creates an updated po/xkeyboard-config.pot, and clean restores the original one. Will upload a new version soon.

Changed in xkeyboard-config (Ubuntu):
status: Triaged → In Progress

El dc 05 de 10 de 2011 a les 19:19 +0000, en/na Timo Aaltonen va
escriure:
> Ok, so how does launchpad get the updated pot-file? From the source
> package, or in-flight during the build?
>

During the build pkgbinarymangler puts all the PO files and the POT file
inside a translations tarball. It picks up any POT file it finds, either
one that is present in the source package, or one that is
generated/updated during the build. The latter is always the best
option, since it ensures the template is always up to date and that
we're not exposing a stale template in Launchpad.

After the build, the translations tarball is picked up by Soyuz, which
then passes it to the Ubuntu translations import queue. From there, once
the PO and POT files it contains are approved, they are imported into
Launchpad Translation.

Timo Aaltonen (tjaalton) wrote :

uploaded to the oneiric queue

Changed in xkeyboard-config (Ubuntu):
status: In Progress → Fix Committed
milestone: none → ubuntu-11.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.3-1ubuntu2

---------------
xkeyboard-config (2.3-1ubuntu2) oneiric; urgency=low

  * rules: Bring back the pot file build, very much needed still.
    This time move the original file away during build, and restore
    on clean. (LP: #868554)
 -- Timo Aaltonen <tjaalton@batty> Wed, 05 Oct 2011 23:34:45 +0300

Changed in xkeyboard-config (Ubuntu):
status: Fix Committed → Fix Released
Gabor Kelemen (kelemeng) wrote :

Strange, the new template should appear here: https://translations.launchpad.net/ubuntu/oneiric/+source/xkeyboard-config/+imports
but it doesn't.

Gabor Kelemen (kelemeng) wrote :

Worked fine during the last build in Precise.

Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers