[SRU] Support for English-Indian keyboards

Bug #712167 reported by Bryce Harrington on 2011-02-02
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
High
Bryce Harrington
Lucid
High
Unassigned
Maverick
High
Unassigned
Natty
High
Bryce Harrington

Bug Description

Binary package hint: xkeyboard-config

[Problem]
The Indian government standards requires an "eng" variant to the "in" keyboard layout.

[Impact]
Affects OEM hardware shipping Ubuntu in India. In particular, the rupee symbol is noticeably absent.

[Development Branch]
This issue is verified fixed in the upstream xkeyboard-config codebase, which is packaged for Natty and will be uploaded once the alpha-2 freeze has lifted.

The upstream fixes are:
  http://cgit.freedesktop.org/xkeyboard-config/commit/?id=920cd81d09c26edb9520b4caa6eea45ef79ea396
  http://cgit.freedesktop.org/xkeyboard-config/commit/?id=396de5b7138f25e49f4de3a0c871f09f08619867

[Stable Branch]
Backports of both patches to maverick and lucid are very straightforward (just a minor tweak required to one Makefile.am file).

[Test Case]
On affected hardware, attempt to set the keyboard to the English-India keyboard layout.
Or, attempt to use the rupee symbol.

[Regression Potential]
None, is just a keyboard layout configuration addition. Since this comes from upstream it has been adequately reviewed. It has been available in the upstream codebase since last September, so it has had plenty of testing time.

Bryce Harrington (bryce) wrote :

The natty merge of xkeyboard-config that includes this fix is committed to this git tree:

 http://git.debian.org/?p=pkg-xorg/data/xkb-data.git;a=shortlog;h=refs/heads/ubuntu

Changed in xkeyboard-config (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Bryce Harrington (bryce)
Changed in xkeyboard-config (Ubuntu Maverick):
status: New → Fix Committed
Changed in xkeyboard-config (Ubuntu Lucid):
status: New → Fix Committed
Changed in xkeyboard-config (Ubuntu Maverick):
importance: Undecided → High
Changed in xkeyboard-config (Ubuntu Lucid):
importance: Undecided → High

Accepted xkeyboard-config into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted xkeyboard-config into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

On Thu, Feb 10, 2011 at 07:17:41AM -0000, Martin Pitt wrote:
> Accepted xkeyboard-config into lucid-proposed, the package will build
> now and be available in a few hours. Please test and give feedback here.
> See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how
> to enable and use -proposed. Thank you in advance!

Martin, I suppose my own testing doesn't count, but... this evening I
put lucid-proposed on my wife's laptop (the only one in the household
not already upgraded to natty *grin*) and verified it added the "Indian
with Rupee" keyboard layout.

Martin Pitt (pitti) wrote :

Bryce, thanks for testing. The point is to test the package from -proposed, not a local build, which you have done.

tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) wrote :

Bryce, can this please be fixed in natty ASAP, so that this can progress to -updates?

Hardik Dalwadi (hardik-dalwadi) wrote :

@ All,

I have also tested in Maverick after enabling "Proposed". It's working out of the box, you have to just select India With Rupee Sign as keyboard layout. The only concern that Layout doesn't show Rupee Symbol under "4". I have attached the .pdf, It only shows u2b09. I think it's bug, in other case, like European keyboard, i can see the euro sign.

And, If we are testing in Lucid, we have to make sure that we have latest Ubuntu Fonts.

On Wed, Feb 16, 2011 at 07:37:22AM -0000, Martin Pitt wrote:
> Bryce, can this please be fixed in natty ASAP, so that this can progress
> to -updates?

It's already fixed in natty. Before I did the lucid and maverick
backports of the patch, I merged in the newer upstream code that
contained the fix. I have also verified the fix is in natty
(easy to do, just navigate to System > Preferences > Keyboard,
pick Layouts, Add, Country = India, and verify there is a Variant called
'India English with RupeeSign' which includes an odd symbol on the 4
key that looks like half the letter R with an = stuck on its top.

Martin Pitt (pitti) wrote :

Closing natty task then, thanks!

Changed in xkeyboard-config (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 1.8-1ubuntu8.1~10.10.1

---------------
xkeyboard-config (1.8-1ubuntu8.1~10.10.1) maverick-proposed; urgency=low

  * Add 129_rupee_1.patch, 130_rupee_2.patch: Cherrypick from upstream
    to enable rupee symbol on English-Indian keyboards.
    (LP: #712167)
 -- Bryce Harrington <email address hidden> Wed, 02 Feb 2011 14:32:12 -0800

Changed in xkeyboard-config (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 1.8-1ubuntu8.1~10.04.1

---------------
xkeyboard-config (1.8-1ubuntu8.1~10.04.1) lucid-proposed; urgency=low

  * Add 129_rupee_1.patch, 130_rupee_2.patch: Cherrypick from upstream
    to enable rupee symbol on English-Indian keyboards.
    (LP: #712167)
 -- Bryce Harrington <email address hidden> Wed, 02 Feb 2011 14:32:12 -0800

Changed in xkeyboard-config (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers