Incomplete support for Apple Aluminium Keyboard

Bug #696232 reported by Damien Ciabrini on 2011-01-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: xkb-data

xkb-data 1.8-1ubuntu8 has cherry picked various commits from xkeyboard-config 1.9 in order to add support for Apple Aluminium keyboard.
Only 6 commits out of 7 have been integrated in the Ubuntu version of package xkb-data.

Unfortunately, the remaining commit (http://cgit.freedesktop.org/xkeyboard-config/commit/?id=dfdc578ae532d6665e6f2c84255168e31fa573e0) provides the rules that enable the correct keycodes, symbols, geometries when specifying the XKB model to be applealu_*.

Consequently, the correct XKB settings for Apple Aluminium Keyboards cannot be activated. For the sake of the example:

> setxkbmap -model applealu_iso -layout fr -option alupckeys -print
xkb_keymap {
 xkb_keycodes { include "evdev+aliases(azerty)" };
 xkb_types { include "complete" };
 xkb_compat { include "complete" };
 xkb_symbols { include "pc+fr+inet(evdev)+level3(ralt_switch)+macintosh_vndr/apple(alupckeys)" };
 xkb_geometry { include "pc(pc104)" };
};

No specific geometry, or symbols matched. The remaining patch brings the expected behavior, i.e.:

xkb_keymap {
 xkb_keycodes { include "evdev+aliases(azerty)" };
 xkb_types { include "complete+numpad(mac)" };
 xkb_compat { include "complete" };
 xkb_symbols { include "macintosh_vndr/apple(alukbd)+macintosh_vndr/fr+inet(evdev)+level3(ralt_switch)+macintosh_vndr/apple(alupckeys)" };
 xkb_geometry { include "macintosh(applealu_iso)" };
};

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xkb-data 1.8-1ubuntu8 [modified: usr/share/X11/xkb/rules/evdev]
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 260.19.06 Mon Sep 13 04:29:19 PDT 2010
 GCC version: gcc version 4.4.5 (Ubuntu/Linaro 4.4.4-14ubuntu5)
Architecture: amd64
Date: Sat Jan 1 14:18:55 2011
Dependencies:

DkmsStatus: nvidia-current, 260.19.06, 2.6.35-22-generic, x86_64: installed
MachineType: System manufacturer P5K Premium
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=c5f5ec92-16eb-4b5f-9b64-47e64a6a8613 ro splash quiet
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: xkeyboard-config
dmi.bios.date: 06/26/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0204
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5K Premium
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0204:bd06/26/2007:svnSystemmanufacturer:pnP5KPremium:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5KPremium:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5K Premium
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-22-generic

Bryce Harrington (bryce) wrote :

Doh! I dimly recall wondering about that seventh patch but I don't recall why it was omitted. I've opened SRU tasks for possibly backporting this to maverick and lucid (no promises, depends on whether I have some spare time).

Anyway, I've packaged the new release for natty which includes the full set of patches including the missing one. It will get uploaded after the Alpha-2 freeze has lifted.

Changed in xkeyboard-config (Ubuntu Natty):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.1-1ubuntu1

---------------
xkeyboard-config (2.1-1ubuntu1) natty; urgency=low

  * Merge from debian of 2.1 release.
    - Fixes Ubuntu bugs:
      + Sindhi keyboard layout (locale: sd_PK, sd_IN) (LP: #588918)
      + Fix conflict between Mali and Malayalam layouts (LP: #575660)
      + Support for Philippines "National Keyboard Layout" (LP: #672881)
      + Support for Kinesis keyboard geometry (LP: #393887)
      + Support for Apple Aluminium keyboards (LP: #696232)
      + Support for abnt2 keyboard, thinkpad variant for Lenovo 3000 v100
        laptops (LP: #359719)
      + Fix CapsLock misspelling (LP: #592448)
    - Remaining Ubuntu changes:
      + xkb-data-i18n.install, xkb-data.install, rules: Split out
        xkb-data-i18n to be used by console-setup.
      + rules: Generate pot file for translations during build
      + 104_macbook_expose_and_dashboard.patch: Add keycode definitions
          required for Apples Expose & Dashboard keys (F3/F4).
      + 105_intelligent_keyboard.patch: Add support for the Intelligent
        Keyboard K04
      + 107_lao.patch: New keyboard layout for Lao, implemented as
        an alternative to the default one.
      + 108_taiwan.patch: New keyboard layouts for Taiwan.
  * Drop 102_mac_aliases.patch: This appears to have some side effects,
    and the patch was not taken by upstream because it was an incomplete
    fix. Reopens bug 327963
  * Drop patches included in the new upstream release:
      - 106_fixspell3d.patch: upstream
      - 109_mali.patch: upstream
      - 110_variants-cleanup.patch
      - 111_il-missing-symbol.patch
      - 112_zero-with-spacing.patch
      - 113_cz-dvorak-ucw.patch
      - 114_ejn_4_level.patch
      - 115_aluminium_geometries.patch
      - 116_aluminium_keycodes.patch
      - 117_aluminium_symbols.patch
      - 118_aluminium_aliases.patch
      - 119_aluminium_pc_compat.patch
      - 120_aluminium_rules.patch
      - 121_tamil_chars.patch
      - 122_olpc-azerty.patch
      - 123_fix_i18n.patch
      - 124_serbian_ru_level3.patch
      - 125_mapping_tools_launch5_menukb.patch
      - 126_swahili_arabic.patch
      - 127_restore_gb_colemak.patch
 -- Bryce Harrington <email address hidden> Tue, 01 Feb 2011 11:57:39 -0800

Changed in xkeyboard-config (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in xkeyboard-config (Ubuntu Lucid):
status: New → Confirmed
Changed in xkeyboard-config (Ubuntu Maverick):
status: New → Confirmed
Joss Winn (josswinn) wrote :

I've just upgraded to Natty Beta2 and have run into what appears to be the same bug. The number pad is not working and some key mappings are incorrect (hash, pound sign).

Previously, my Apple aluminium keyboard worked fine when the right options were set in the Gnome keyboard preferences. However, since the upgrade, I'm getting a warning whenever I login or try to change the keyboard preferences. The error message is asking me to run to commands if reporting a bug:

root@jwinn-desktop:~# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "applealu_iso", "gb", "mac", "terminate:ctrl_alt_bksp,apple:alupckeys,numpad:mac"
_XKB_RULES_NAMES(STRING) = "evdev", "applealu_iso", "gb", "mac", "terminate:ctrl_alt_bksp,apple:alupckeys,numpad:mac"

root@jwinn-desktop:~# gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = []
 model =
 options = [terminate terminate:ctrl_alt_bksp,apple apple:alupckeys,numpad numpad:mac,compat apple:alupckeys,compat numpad:mac]

I have xkeyboard-config (2.1-1ubuntu3) installed.

Thanks for your help.

Hi Joss,

I'm running Maverick with package xkb-data from Natty (2.1-1ubuntu3) as you.
I can run the keyboard without apparent troubles. xprop gives the following XKB settings:

_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "applealu_iso", "us", "", "apple:alupckeys,lv3:ralt_switch"
_XKB_RULES_NAMES(STRING) = "evdev", "applealu_iso", "us", "", "apple:alupckeys,lv3:ralt_switch"

Maybe your troubles come from the fact that you specified a variant "mac" for the "gb" kayout. Could you try to remove it? It seems it doesn't come from GNOME, so maybe it's in your /etc/default/console-setup. Change it with:

sudo dpkg-reconfigure console-setup

If things still don't work, could you please attach the result of:

setxkbmap -print | xkbcomp -xkb - -

Pierre Slamich (pierre-slamich) wrote :

Having the same issues with the French aluminium keyboard for @ and < which are swapped.

famille@famille:~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "pc105", "fr", "oss", ""
_XKB_RULES_NAMES(STRING) = "evdev", "pc105", "fr", "oss", ""
famille@famille:~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 model = applealu_iso
 layouts = []
 options = []
famille@famille:~$ su

Moreover, i can't install xkeyboard-config

The xprop seems to indicate that the XKB config took a fallback path, pc105 instead of the applealu_iso you specified in Gnome. This issue looks different from that of comment #4.

Could you please elaborate on "I can't install xkeyboard-config"?

Also, concerning you keyswap issue, could you please install evtest:
sudo apt-get install evtest

start it:
sudo evtest /dev/input/by-id/usb-Apple__Inc_Apple_Keyboard-event-kbd

press the key labeled "@" on the keyboard(next to the 1 key), as well as the one labeled "<" (next to left shift), and paste the output here?

Adolfo Jayme (fitojb) on 2013-07-06
no longer affects: xkeyboard-config (Ubuntu Lucid)
no longer affects: xkeyboard-config (Ubuntu Maverick)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers