Inclusion of the Philippines "National Keyboard Layout"

Bug #672881 reported by Yahuhanan (יהוחנן) Yukia (雪亮) Sese (謝) Cuneta on 2010-11-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Ubuntu)
Wishlist
Unassigned
Natty
Wishlist
Unassigned

Bug Description

Binary package hint: xkeyboard-config

A request for the inclusion of the new Philippines National Keyboard Layout.
The attached file contains the symbols / mapping, and the information needed
for the .lst and .xml files.

Thank you very much.

Also submitted at: https://bugs.freedesktop.org/show_bug.cgi?id=31073

Created attachment 39660
symbols file

A request for the inclusion of the new Philippines National Keyboard Layout. The attached file contains the symbols / mapping, and the information needed for the .lst and .xml files.

Thank you very much.

Created attachment 39661
information needed for .lst and .xml files

Created attachment 39746
symbols file (correct file)

Created attachment 40131
XKB files edited with PH included

After releasing it to the public, new comments were received. This is the latest version out of it and received zero additional changes and negative feedbacks.

Thanks for the contribution. A couple of notes. symbols/ph file is generally ok. The rules subdirectory is not what I'd expect. Could you please provide the small patch to base.xml.in file?

description: updated

Created attachment 40232
Patch files for base.lst, base.xml, evdev.lst, and evdev.xml

(In reply to comment #4)
> Thanks for the contribution. A couple of notes. symbols/ph file is generally
> ok. The rules subdirectory is not what I'd expect. Could you please provide the
> small patch to base.xml.in file?

Hi,

Thanks. Uploaded a the patch files, I hope I did it correctly, something new to learn.

~ JC

Committed, thanks. Even though it is strange to see variants consisting mostly of VoidSymbols

(In reply to comment #7)
> Committed, thanks. Even though it is strange to see variants consisting mostly
> of VoidSymbols

Hi, thank you very much.

Yes, I would agree. The Baybayin script is alphasyllabry so it is always CV-CV, then other vowels are represented by use of a diacritical mark resulting to just 18 base "glyphs" only.

Initially I did not include "VoidSymbols" but I noticed that if it is left empty, the system checks the next "upper" keyboard in the list and producing the character there first.

1: Latin = Key1234 produces "A"
2: Baybayin = Key1234 is empty

If pressing Key1234 in Baybayin will produce the letter "A" from the Latin layout. I opted instead to hardcode "VoidSymbols" to avoid it. From what I understand, it was intentional?

Anyway, I guess that's for another thread / ticket. Thank you again!

Bryce Harrington (bryce) wrote :

I've packaged the new xkeyboard-config release for natty which includes this fix (thanks for filing it upstream!) It will be uploaded once the Alpha-2 release freeze has lifted.

Changed in xkeyboard-config (Ubuntu):
importance: Undecided → Wishlist
status: New → Fix Committed
Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.1-1ubuntu1

---------------
xkeyboard-config (2.1-1ubuntu1) natty; urgency=low

  * Merge from debian of 2.1 release.
    - Fixes Ubuntu bugs:
      + Sindhi keyboard layout (locale: sd_PK, sd_IN) (LP: #588918)
      + Fix conflict between Mali and Malayalam layouts (LP: #575660)
      + Support for Philippines "National Keyboard Layout" (LP: #672881)
      + Support for Kinesis keyboard geometry (LP: #393887)
      + Support for Apple Aluminium keyboards (LP: #696232)
      + Support for abnt2 keyboard, thinkpad variant for Lenovo 3000 v100
        laptops (LP: #359719)
      + Fix CapsLock misspelling (LP: #592448)
    - Remaining Ubuntu changes:
      + xkb-data-i18n.install, xkb-data.install, rules: Split out
        xkb-data-i18n to be used by console-setup.
      + rules: Generate pot file for translations during build
      + 104_macbook_expose_and_dashboard.patch: Add keycode definitions
          required for Apples Expose & Dashboard keys (F3/F4).
      + 105_intelligent_keyboard.patch: Add support for the Intelligent
        Keyboard K04
      + 107_lao.patch: New keyboard layout for Lao, implemented as
        an alternative to the default one.
      + 108_taiwan.patch: New keyboard layouts for Taiwan.
  * Drop 102_mac_aliases.patch: This appears to have some side effects,
    and the patch was not taken by upstream because it was an incomplete
    fix. Reopens bug 327963
  * Drop patches included in the new upstream release:
      - 106_fixspell3d.patch: upstream
      - 109_mali.patch: upstream
      - 110_variants-cleanup.patch
      - 111_il-missing-symbol.patch
      - 112_zero-with-spacing.patch
      - 113_cz-dvorak-ucw.patch
      - 114_ejn_4_level.patch
      - 115_aluminium_geometries.patch
      - 116_aluminium_keycodes.patch
      - 117_aluminium_symbols.patch
      - 118_aluminium_aliases.patch
      - 119_aluminium_pc_compat.patch
      - 120_aluminium_rules.patch
      - 121_tamil_chars.patch
      - 122_olpc-azerty.patch
      - 123_fix_i18n.patch
      - 124_serbian_ru_level3.patch
      - 125_mapping_tools_launch5_menukb.patch
      - 126_swahili_arabic.patch
      - 127_restore_gb_colemak.patch
 -- Bryce Harrington <email address hidden> Tue, 01 Feb 2011 11:57:39 -0800

Changed in xkeyboard-config (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in xkeyboard-config (Ubuntu Lucid):
status: New → Triaged
Changed in xkeyboard-config (Ubuntu Maverick):
status: New → Triaged

One question. How would you estimate the number of users for colemak variants? I would be inclined to move them to "extras" section (base.extras.xml.in)

Adolfo Jayme (fitojb) on 2013-07-06
no longer affects: xkeyboard-config (Ubuntu Lucid)
no longer affects: xkeyboard-config (Ubuntu Maverick)

This is licensed under GPLv3, instead of MIT as the rest of the layouts. Can this please be changed?

Changed in xkeyboard-config:
status: Fix Released → Confirmed

(In reply to Daniel Stone from comment #10)
> This is licensed under GPLv3, instead of MIT as the rest of the layouts. Can
> this please be changed?
Removed the GPLv3 line. Hope it is ok with everybody.

Changed in xkeyboard-config:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.