Super (Win) key shortcuts don't work in GTK+ apps

Bug #577532 reported by czheng on 2010-05-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GTK+
Unknown
Medium
gedit
Invalid
Undecided
Unassigned
xkeyboard-config
Invalid
Undecided
Unassigned
xkeyboard-config (Ubuntu)
Undecided
Unassigned

Bug Description

Seems that, although mapped correctly, as of Ubuntu 10.04 the Super key no longer works as a modifier key in keyboard shortcuts for Gnome/Gtk apps.

Very detailed description here: https://answers.launchpad.net/ubuntu/+question/110098

Steps to test
----------------------------------------------------------------------
1) Open gedit
2) Go to Edit > Preferences > Plugins and enable the Snippets plugin
3) Click 'Configure Plugin'
4) In the Snippets manager, create a new snippet under 'Global'.
    Enter your name in the 'Edit' box.
    In 'Tab trigger' field, type the letter n.
    Click the Shortcut key field, and then hold down the Super (Win) key and n. Shortcut assigned should read 'Super+N'.
    Close the Snippets manager and the Preferences dialog.
5) Create a new document. In the editor, type the letter n and hit the tab key. You should see your name appear. That means the snippets are working.
6) In the editor, hold the Super key and then hit the n key. You should simply see the letter n.

Additional details
----------------------------------------------------------------------
Have tested this on both Kubuntu 10.04 and UNR 10.04. On both machines, the shortcut keys above worked as expected in K/Ubuntu 9.10, but broke upon upgrade to 10.04 (one machine was upgraded, one fresh-installed).

Have also installed openSUSE via Virtualbox to test this, and it works as expected there, so I've got to assume it's an Ubuntu-specific problem. FWIW, the output of xmodmap and xev testing are basically identical across all three systems.

Bryce Harrington (bryce) on 2010-05-21
tags: added: kubuntu

Just a note that I tested this on a non-Kubuntu install as well.

Simos Xenitellis  (simosx) wrote :

I tried a 'Super' shortcut in gedit and the snippets plugin (Ubuntu 10.04) and I noticed that indeed it does not work.

You can also set up keyboard shortcuts with System»Preferences»Keyboard shortcuts.
I tried setting a shortcut for 'Super'+0 and it worked. Which means that something esoteric might be happening in GTK+ apps and the handling of the key events. I have the feeling that somehow gedit did not receive the shortcut.

In the Keyboard Shortcuts the shortcut description does not say 'Super' but 'mod4'.

There are other global shortcuts working, such as mod4+s, mod4+w, mod4+e, mod4+n.

I strongly believe the issue is not related to xkeyboard-config but rather to keyboard event handling. Some application either does not propagate key events or gedit is not able to capture all key events.

I'll mark this as a gedit or gtk+ issue.
You can search the gtk+ and gedit bugzilla servers for posibble issues,
https://bugzilla.gnome.org/browse.cgi?product=gtk%2B
https://bugzilla.gnome.org/browse.cgi?product=gedit

I strongly suggest to file a bug report for gedit on bugzilla.gnome.org so that the gedit developers have a good look at this.

Also check with compiz disabled whether mod4 is OK; even if 3D effects have little to do with keyboard handling, compiz makes use of shortcuts and it may somehow interfere with the key handling.

Changed in xkeyboard-config (Ubuntu):
status: New → Invalid

Thanks for the detailed explanation. I'll go ahead and post the bug for gedit as you suggest. Sorry for posting this in the wrong place.

Actually, I've posted this against gtk+ instead, since it's not a Gedit-specific problem:
https://bugzilla.gnome.org/show_bug.cgi?id=623421

Simos Xenitellis  (simosx) wrote :

Nice, thanks.

Could you
1. click on 'Also affects' above
2. add the link https://bugzilla.gnome.org/show_bug.cgi?id=623421 to the 'upstream bug report'

In this way, you can link Launchpad to the GNOME Bugzilla report, so automated updates can take place.

Finally, you can change the Status for 'gedit' above from 'New' to 'Invalid'.

Did I do that right?

Changed in gedit:
status: New → Invalid
Simos Xenitellis  (simosx) wrote :

The GNOME bug was not attached to the 'gtk' project. It was attached to the xkeyboard-config (because I did not explain this in my instructions).

I fixed this and this report is properly linked to https://bugzilla.gnome.org/show_bug.cgi?id=623421

I am also fixing the title of this report here so that it is more descriptive. Feel free to update the bug description.

Changed in xkeyboard-config:
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
summary: - 1.8 breaks Super (Win) key shortcuts in Gtk apps
+ Super (Win) key shortcuts don't work in GTK+ apps
description: updated
Changed in gtk:
status: Unknown → New

This appears to be an Ubuntu-only bug. Not sure where to file it but the main Gtk project doesn't seem like the right place. It's to do with some specific set of configurations in Ubuntu 10.04 as far as I can tell...

Changed in gtk:
status: New → Invalid
Changed in gtk:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.