sun type 6 keyboard not supported (bs key not working)

Bug #465926 reported by iWatch on 2009-10-31
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: yelp

just upgraded to 9.10 ... my backspace key no longer works, system wide.
i have a sun type 6 (terminal keyboard layout) the correct layout is not shown when i select add from system->pref->key board
it does show that i have a Sun Type 5/6 .. but a type 5 is not the same a type 6

ProblemType: Bug
Architecture: i386
Date: Fri Oct 30 20:54:35 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: nvidia
Package: yelp 2.28.0-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/ksh
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: yelp
Uname: Linux 2.6.31-14-generic i686

iWatch (dtkerns) wrote :
iWatch (dtkerns) wrote :

I was able to work-around this bug (got my backspace key to work) by selecting "generic 105-key"

Bert Vermeulen (biot) wrote :

I'm seeing the same thing, on a Sun type 6 USB keyboard (PC layout). Keycode 22, which is backspace, simply isn't defined. xmodmap -pk reports no definition, and xev accordingly reports it as "NoSymbol". A temporary workaround is this:

xmodmap -e "keycode 22 = BackSpace"

But of course that gets lost when the X session is finished.

affects: yelp (Ubuntu) → gnome-control-center (Ubuntu)
affects: gnome-control-center (Ubuntu) → xkeyboard-config (Ubuntu)
affects: xkeyboard-config (Ubuntu) → gnome-control-center (Ubuntu)
affects: gnome-control-center (Ubuntu) → xkeyboard-config (Ubuntu)
stu (sgeorge) wrote :

Any movement on this?? its really annoying. I have a type7 usb unix with the same issues. aargh

iWatch (dtkerns) wrote :

I doubt it will ever get fixed since selecting "generic 105-key" gives full functionality.
I was always hoping they'd fix the "picture" for my sun type 6, so I could print it with my xpilot-ng labels ;) .. I ended up finding the a suitable drawing on the sun website.

David Tombs (dgtombs) wrote :

Confirming due to previous comments.

Changed in xkeyboard-config (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2010-03-18
tags: added: karmic
Bryce Harrington (bryce) wrote :

iWatch - I've forwarded this bug upstream to http://bugs.freedesktop.org/show_bug.cgi?id=34368 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xkeyboard-config (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Confirmed
Bryce Harrington (bryce) wrote :

Hi iWatch, upstream has a question for you:

If you do not use xmodmap - what do you see in xev utility when pressing
Backspace?

Also, could you please try the following: in keycodes/sun, find the section
"type6" and append

<BKSP> = 22;

Changed in xkeyboard-config (Ubuntu):
status: Triaged → Incomplete
Bryce Harrington (bryce) wrote :

As per discussion on the upstream bug, appears this issue is particular to a customized configuration, and the original issue is already solved in the upstream codebase (and included in latest ubuntu).

Changed in xkeyboard-config (Ubuntu):
status: Incomplete → Invalid
Changed in xkeyboard-config:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.