Logitech Media Keyboard Elite not fully supported

Bug #46586 reported by Toby Haynes on 2006-05-25
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Medium
Unassigned

Bug Description

The media keys on the Logitech Media Keyboard Elite are not supported properly - the layout appears to be different than the others already included and the kernel does not recognise many of the media/extra keys. Currently I have the keyboard hooked up through the USB port.

I have made the following changes to my system to attempt to support this keyboard. Caution: Pressing the key I have mapped as XF86LaunchC (F11 with the F-mode light off) will reliably crash and reboot the system - I have no idea why.

At boot time, the following script is run to map the scancodes to the console level codes. I assume that this keyboard really requires fixes in the kernel code to recognise this keyboard without the use of extra scan codes.

# Kernel level keycode mappings for the Logitech Media Keyboard Elite USB
# 6a 190 Zoom In
# e004 191 Zoom Out
# 6b 192 Zoom Reset
# e011 193 Messenger
# e05a 194 Mode F (switch function keys)
# e03b 195 (F1 )Help
# e03c 196 (F2 )Word
# e03d 197 (F3 )Excel
# e03e 198 (F4 )Powerpoint
# e03f 199 (F5 )Undo
# e040 200 (F6 )Redo
# e041 201 (F7 )Print
# e042 202 (F8 )Save
# e043 203 (F9 )Box A
# e044 204 (F10)Box B
# e057 205 (F11)Box C
# e058 206 (F12)Box D

        setkeycodes \
            6a 190 \
            e004 191 \
            6b 192 \
            e011 193 \
            e05a 194 \
            e03b 195 \
            e03c 196 \
            e03d 197 \
            e03e 198 \
            e03f 199 \
            e040 200 \
            e041 201 \
            e042 202 \
            e043 203 \
            e044 204 \
            e057 205 \
            e058 206
# ---------------------------------------------------

I also made the following alterations to the symbols in /etc/X11/xkb/symbols/inet:

--- inet.20060516 2006-05-16 20:44:30.000000000 -0400
+++ inet 2006-05-16 20:59:41.000000000 -0400
@@ -1244,6 +1244,39 @@
     key <I2D> { [ XF86AudioRaiseVolume ] };
 };

+// Logitech Media Keyboard Elite
+partial alphanumeric_keys
+xkb_symbols "logimedelite" {
+ include "inet(logitech_base)"
+
+ key <K5A> { [ XF86ZoomIn ] };
+ key <K74> { [ XF86ZoomOut ] };
+ key <I79> { [ XF86Clear ] };
+ key <I22> { [ XF86AudioPlay, XF86AudioPause ] };
+ key <I24> { [ XF86AudioStop ] };
+ key <I19> { [ XF86AudioNext ] };
+ key <K6D> { [ XF86Messenger ] };
+ key <K21> { [ XF86Calculator ] };
+ key <K6F> { [ XF86ModeLock ] };
+
+ key <I15> { [ XF86Help ] };
+ key <I16> { [ XF86Word ] };
+ key <I1A> { [ XF86Excel ] };
+ key <I1B> { [ XF86Finance ] };
+
+ key <I27> { [ XF86Back ] };
+ key <I28> { [ XF86Forward ] };
+ key <I29> { [ XF86Book ] };
+ key <I2B> { [ XF86Save ] };
+
+ key <I2C> { [ XF86LaunchA ] };
+ key <I2D> { [ XF86LaunchB ] };
+ key <I25> { [ XF86LaunchC ] };
+ key <I2F> { [ XF86LaunchD ] };
+
+};
+
+
 partial alphanumeric_keys
 xkb_symbols "logiultrax" {
     include "inet(logitech_base)"

Then the three rules files in /etc/X11/xkb/rules were updated as follows:

toby@nexus:/etc/X11/xkb/rules$ diff -Naur base.20060516 base
--- base.20060516 2006-05-16 21:00:45.000000000 -0400
+++ base 2006-05-16 21:01:43.000000000 -0400
@@ -38,7 +38,7 @@
               honeywell_euroboard \
               rapidaccess rapidaccess2 rapidaccess2a \
               ltcd logiaccess logicdp logicdpa logicdit logicink logiciink \
- logiinkse logiinkseusb logiitc logiik itouch logiultrax \
+ logiinkse logiinkseusb logiitc logiik itouch logimedelite logiultrax \
               mx1998 mx2500 mx2750 \
               microsoftinet microsoftpro microsoftprousb microsoftprooem microsoftprose \
               microsoftoffice microsoftmult \

toby@nexus:/etc/X11/xkb/rules$ diff -Naur base.lst.20060516 base.lst
--- base.lst.20060516 2006-05-16 21:00:54.000000000 -0400
+++ base.lst 2006-05-16 21:02:59.000000000 -0400
@@ -78,6 +78,7 @@
   logiitc Logitech iTouch Cordless Keyboard (model Y-RB6)
   logiik Logitech Internet Keyboard
   itouch Logitech iTouch
+ logimedelite Logitech Media Keyboard Elite (model Y-BN52)
   logiitc Logitech iTouch Cordless Keyboard (model Y-RB6)
   logiik Logitech Internet Keyboard
   logiink Logitech Internet Navigator Keyboard

toby@nexus:/etc/X11/xkb/rules$ diff -Naur base.xml.20060516 base.xml
--- base.xml.20060516 2006-05-16 21:01:01.000000000 -0400
+++ base.xml 2006-05-16 21:06:56.000000000 -0400
@@ -2067,6 +2067,14 @@
     </model>
     <model>
       <configItem>
+ <name>logimedelite</name>
+ <description>Logitech Media Keyboard Elite (model Y-BN52)</description>+ <description xml:lang="fr">Logitech Clavier Media Elite (modèle Y-BN52)</description>
+ <description xml:lang="en_GB">Logitech Media Keyboard Elite (model Y-BN52</description>
+ </configItem>
+ </model>
+ <model>
+ <configItem>
         <name>logiitc</name>
         <description>Logitech iTouch Cordless Keyboard (model Y-RB6)</description>
         <description xml:lang="af">Logitech iTouch Cordless Keyboard (model Y-RB6)</description>

After all these changes are made, the appropriate keyboard layout can be selected in the GNOME keyboard layout chooser and used. It appears to function well (with the exception of the system crash for XF86LaunchC).

Confirming this. Solution looks Ok.

Changed in xkeyboard-config:
status: Unconfirmed → Confirmed
(4M)Stephen (sasimon19) wrote :

Could you write a patch or an executable script for download and running for these users?

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in xkeyboard-config:
status: Confirmed → Incomplete

You can close it. I have a different keyboard now, and so unable to support
you in anymore debugging.

On Sun, Sep 28, 2008 at 2:22 PM, Pablo Castellano <email address hidden>wrote:

> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering is this still an issue
> for you? Can you try with latest Ubuntu release? Thanks in advance.
>
> ** Changed in: xkeyboard-config (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> Logitech Media Keyboard Elite not fully supported
> https://bugs.launchpad.net/bugs/46586
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sincerely,
Ray Walker

Bryce Harrington (bryce) wrote :

Closing as per last comment

Changed in xkeyboard-config:
status: Incomplete → Invalid
Beanow (beanow) wrote :

Still affected by this bug in 13.04
Media keys are only partially supported.

Unsupported keys:
Reset zoom (no keycode)
Zoom in (keycode 418)
Zoom out (keycode 419)
Word key (keycode 421)
Excel key (keycode 423)
Powerpoint key (keycode 425)
Launch A (keycode 328)
Launch B (keycode 329)
Launch C (keycode 330)
Launch D (keycode 331)

Changed in xkeyboard-config (Ubuntu):
status: Invalid → Confirmed
Apfelgriebs (apfelgri) wrote :

Still affected by this bug in 15.04

The media keys work fine as far as I can see, however the following keys produce no keycode (checked with xinput), meaning that can't be used at all.

No keycode:
Reset zoom
Zoom in
Zoom out
Word key
Excel key
Launch A
Launch B
Launch C
Launch D
Messenger

Gunnar Hjalmarsson (gunnarhj) wrote :

It would be great if somebody who is affected by this could file an upstream bug.

https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config

This kind of addition wouldn't be reasonable to patch in Ubuntu only.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers