Macbook/Macbook Pro keyboard layout throws error

Bug #454160 reported by Steve Yelvington on 2009-10-17
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: x11-xserver-utils

When the Macbook / Macbook Pro keyboard configuration is selected, I get a popup error:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
10604000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

The (less specific? not sure why there are two) Apple Laptop configuration does not throw an error.

$ xprop -root |grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "macbook78", "us", "mac", "lv3:ralt_switch"
_XKB_RULES_NAMES(STRING) = "evdev", "apple_laptop", "us", "mac", "lv3:ralt_switch"

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [us mac]
 options = []
 model = macbook78

$ lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10

ProblemType: Bug
Architecture: i386
CheckboxSubmission: b7879171d80801e4a44f9b48d478cb47
CheckboxSystem: 7e42599bda39ea7ff8b528272b6ef52b
Date: Sat Oct 17 14:46:27 2009
DistroRelease: Ubuntu 9.10
MachineType: Apple Inc. MacBook2,1
Package: x11-xserver-utils 7.4+2ubuntu3
ProcCmdLine: root=UUID=1ab021c3-291a-4ceb-83c1-719d0ebc75a9 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: x11-xserver-utils
Uname: Linux 2.6.31-14-generic i686
dmi.bios.date: 06/27/07
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB21.88Z.00A5.B07.0706270922
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F4208CAA
dmi.board.vendor: Apple Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F4208CAA
dmi.modalias: dmi:bvnAppleInc.:bvrMB21.88Z.00A5.B07.0706270922:bd06/27/07:svnAppleInc.:pnMacBook2,1:pvr1.0:rvnAppleInc.:rnMac-F4208CAA:rvrPVT:cvnAppleInc.:ct10:cvrMac-F4208CAA:
dmi.product.name: MacBook2,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-14-generic

Bryce Harrington (bryce) on 2009-10-18
Changed in x11-xserver-utils (Ubuntu):
status: New → Confirmed
Dan (dans564) wrote :

any1 have any idea what to do

Bryce Harrington (bryce) on 2009-11-03
affects: x11-xserver-utils (Ubuntu) → xkeyboard-config (Ubuntu)
NicoInattendu (nico-inattendu) wrote :

I have the same problem with an imac 24 since I upgraded to karmic.
I have the problem with my current account and an a new account on karmic. I do that to verify if the problem is due to my local .XXX files.

What I noticed also tha the number of popups depends on success to my local .Xmodmap file. If .Xmodap loaded only 1 or 2 error popup window, if not 5 to 6 error popups at login.

NicoInattendu (nico-inattendu) wrote :

I noticed in my .xessions-errors file an error message on xmodap :
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
/usr/bin/xmodmap: unable to open file '/usr/share/kubuntu-default-settings/kubuntu.xmodmap' for reading
/usr/bin/xmodmap: 1 error encountered, aborting.

Why he looks on kubtuntu default settings. I upgraded from jaunty to karmic. On jaunty i first insatlled ubuntu tnah kubuntu meta package. That point can be related to the problem ?

Bryce Harrington (bryce) on 2010-03-18
tags: added: karmic
bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in xkeyboard-config (Ubuntu):
status: Confirmed → New
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xkeyboard-config (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.