libx11-data: compose ellipsis problem

Bug #415667 reported by Alex Mauer on 2009-08-19
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Undecided
Unassigned

Bug Description

According to the compose file /usr/share/X11/locale/en_US.UTF-8, pressing Compose, period, period, should give an ellipsis ("…"):
<Multi_key> <period> <period> : "…" ellipsis # HORIZONTAL ELLIPSIS

However, on my system it instead gives a "dot above" (˙, unicode 0x02D9) which should be produced by a totally different sequence involving deadkeys which I don't have.

Bryce Harrington (bryce) wrote :

Hi hawke,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in libx11 (Ubuntu):
status: New → Incomplete
Alex Mauer (hawke) wrote :

I don't think lspci or xorg.log are appropriate for this bug. Certainly xorg has nothing relevant to xkb, besides
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "us"

Changed in libx11 (Ubuntu):
status: Incomplete → New
tags: removed: needs-lspci-vvnn needs-xorglog
Bryce Harrington (bryce) on 2009-08-21
tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in libx11 (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

Alex, you misfiled this bug against libx11 instead of the correct package, xkeyboard-config.

affects: libx11 (Ubuntu) → xkeyboard-config (Ubuntu)
Changed in xkeyboard-config (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → New
Matt Wilson (matt-culturethree) wrote :

I'm seeing this too, after upgrading 8.10 to 9.04. It happens in Pidgin, Firefox and gnome-terminal, but NOT for some reason in xterm or urxvt. My locale is en_NZ.UTF-8. I'll attach the requested logs.

Matt Wilson (matt-culturethree) wrote :
Matt Wilson (matt-culturethree) wrote :
Matt Wilson (matt-culturethree) wrote :
Matt Wilson (matt-culturethree) wrote :

I can confim that this still exists in Karmic Koala.

I have the same problem in karmic.

However, the bug doesn't happen when one selects "X Input Method" as input method (you can change it by right-clicking on a textbox and choose from the "Input Methods" submenu). By default, karmic (and probably jaunty too) uses IBus. As a workaround, you can add "export GTK_IM_MODULE=xim" to /etc/environment.

The drawback is that I face another bug using XIM in gedit: whenever I use a hotkey (for example Alt+... to access menus), the Compose key completely stops working afterwards. To make it work again, I have to reselect XIM from the input methods menu.

Two people have confirmed this bug. Changing status in the hope it will get some visibility.

Changed in xkeyboard-config (Ubuntu):
status: New → Confirmed
AlexYeCu (alexyecu) wrote :

That`s not only Ubuntu`s bug. I use Fedora, so, I`ve noticed this bug in Fedora10. It has came with some of last updates of x11-libs. And this bug is still presented in Fedora12. May be this info will help you to find out the buggy version of libs/data. Or to developers of a buggy package.

gillux (gillou-ray) wrote :

I'm not a ubuntu user too. However I figured out that the default input method in GTK applications can be changed by the GTK_IM_MODULE environment variable. I don't know how its default value is chosen, though. And that may be the point. Available values for this variable should be listed in the first column of /etc/gtk-2.0/gtk.immodules. The one Alex wants is "xim" which stands for "X Input Method". So a workaround is to set GTK_IM_MODULE="xim" in some startup script and you should see it selected by default in the "Input Methods" submenu of the text fields contextual menus. I've also heard of a QT_IM_MODULE similar variable but havn't tested it.

Note that this problem seems to be solved in lucid.

Simos Xenitellis  (simosx) wrote :

I also verify that the issue is fixed in Ubuntu 10.04 (without having to resort to the activation of 'xim').
If you press Compose + . + . you get …

Closing this report, thanks for reporting.

Changed in xkeyboard-config (Ubuntu):
status: Confirmed → Fix Released
Adrián Chaves (gallaecio) wrote :

I’m suffering this issue in Kubuntu 13.04 with KDE applications; has it ever been fixed for those? (Writting this message I’ve just found out that it works on Firefox… ← That’s the proof)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers