[Needs 1.8] Win key as third level chooser doesn't work anymore

Bug #408397 reported by Thura on 2009-08-03
164
This bug affects 28 people
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Debian)
Fix Released
Unknown
xkeyboard-config (Ubuntu)
High
Unassigned
Nominated for Karmic by Alexey Ten (Lynn)

Bug Description

After the upgrade to karmic for testing, i fount out win key as third level choose doesn't work any more ...
I have already checked "Press any of the win keys to choose third level choosers", in keyboard settings
And also checked "Super is mapped to win-keys." in Alt/Win behaviour.

If I use any other keys (Ctrl / Alt) to choose third-level-chooser, it works fine.
Only Win key doens't work.

Any clue ?

not a syndaemon bug actually.

Mod4 is mapped to SUPR, a virtual key. This isn't the same as the physical keys, which are mapped to Super_L and Super_R and don't show up in the core mapping.

setxkbmap -option "altwin:super_win" creates this mapping and it works fine.

Sergey - any reason why this isn't the default?

Thanks! With setxkbmap -option "altwin:super_win" it works.

> Sergey - any reason why this isn't the default?

You mean - why Mod4 is not mapped to LWIN/RWIN in addition to SUPR ? Well, I cannot think of any reason. Should we try that?

On Mon, Mar 02, 2009 at 12:55:05PM -0800, <email address hidden> wrote:
> You mean - why Mod4 is not mapped to LWIN/RWIN in addition to SUPR ? Well, I
> cannot think of any reason. Should we try that?

I think it'd make sense. Since SUPR is a only virtual key it appears in
xmodmap but isn't actually useable. And RWIN/LWIN are mapped to nothing by
default, which is rather pointless.

Committed! Please check.

This change seems to break level3 switch with LWIN/RWIN in GTK+ applications. See Debian bug:

  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=531771

I myself don't really understand why this change would cause this bug, so I guess the problem is in GTK+. Do you have any idea on the subject?

After the upgrade to karmic for testing, i fount out win key as third level choose doesn't work any more ...
I have already checked "Press any of the win keys to choose third level choosers", in keyboard settings
And also checked "Super is mapped to win-keys." in Alt/Win behaviour.

If I use any other keys (Ctrl / Alt) to choose third-level-chooser, it works fine.
Only Win key doens't work.

Any clue ?

According to #23266, this fix is invalid - it breaks things for people using lv3:lwin_switch.

As the result, I am reverting this patch: http://cgit.freedesktop.org/xkeyboard-config/commit/?id=5de02aa07a8d4bbe1957af3a38212c3507f2436f

I'm afraid, you have to specify altwin:super_win explicitly

I can't reproduce this. Tested with 3e6a7a495a4f7ceb8c2dd505003f02c893c18975 added caps:numlock

lv3:lwin_switch, lv3:rwin_switch and lv3:win_switch all work fine and as expected (tested on layout 'de').

what's the magic sauce required to break it?

*** Bug 23266 has been marked as a duplicate of this bug. ***

Reopening, since bug #23266 + Debian's bugzilla say that "fix" is causing troubles

Actually, it works to me as well - but may be it only manifests itself with certain layouts/models...

arky (arky) on 2009-09-09
affects: ubuntu → gnome-control-center (Ubuntu)
affects: gnome-control-center (Ubuntu) → xkeyboard-config (Ubuntu)

This affects me too.. but for me (In a Packardbell EasyNote MX52) Alt Gr doen't work neither Alt neither Super.

Also, the keyboard is not being detected and shewd up as EEUU instedad of Spanish, which should be by default because I've selected Spanish from the LiveCD menu.

Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic

I can confirm too.

I have a suspicion that this might be compiz stealing the keypresses. Something weird is happening for sure, as when I hold alt gr, the currently active text box loses focus until I release the key again.

Changed in xkeyboard-config (Ubuntu):
status: New → Confirmed
Timothy Babych (tymofiy) wrote :

Interesting thing is that Win as third-level chooser works just fine in gnome-terminal, but in other programs it does not.

Timothy Babych (tymofiy) wrote :

And right Alt key chooser stops working when Win key is added too.
It works only when it is the only chooser.

Changed in xkeyboard-config:
status: Unknown → Confirmed
Changed in xkeyboard-config (Debian):
status: Unknown → Confirmed

I can confirm this behaviour, just updated to karmic and had to switch to alt (which is a pain :( ). I am on a Macbook Pro 5,5. Thanks!

Created an attachment (id=30489)
Fix Win key as third level chooser

This patch fixes win-key as third level chooser for me.

This patch fixes win-key as third level chooser for me.

Ok, let user explicitly specify altwin:super_win. Let's see how many complains we're going to get...

Thanks for the patch!

Changed in xkeyboard-config:
status: Confirmed → Fix Released

Lynn, your patch worked wonders, thank you!

Šimánek (jasonsimanek) wrote :

Pardon my ignorance, but will this patch be applied to Karmic? It seems pretty important.

By the way, I checked the referenced Debian bug. They say it only affects Gnome applications. This appears to be correct as I was able to use the Win key to activate third and fourth level keys in Scribus (a KDE/Qt app) while my Gnome/GTK apps all continue to ignore the use of the Win key in reference to third level.

Paulus (paulmd-ya) wrote :

It affects all applications that are aware of mod4 :)
For example gnome-terminal is not affected, but yes, most gnome applications are affected.

Bruno Beaufils (beaufils) wrote :

It is really annoying on MacBookPro3,1. I fixed it *brutally* in my startup scripts with:

echo clear mod4 | xmodmap -

Thura (trh) wrote :

It is still not solved in Karmic ;(
Can anyone guide me how to apply the patch Lynn submitted?

Alexey Ten (Lynn) (alexeyten) wrote :

Thura

I've created PPA https://launchpad.net/~alexeyten/+archive/xkb
You could add it to your source list

Package with my patch above included will be available in 14 hours.

Donjan Rodic (bryonak) wrote :

@Lynn: confirming that your patch (+deb) works. Thank you!

Great fix, Alexey. Thanks!

Donald Rogers (dero9753) wrote :

I have what sounds like the same problem. I am using keyboard layout USA, with option for Adding Esperanto circumflexes to the qwerty keyboard, and key to choose 3rd level: Left Win and Right Alt.

This problem did not occur in Jaunty (9.04), but does occur in Karmic (9.10).
This problem occurs in Gnome and in KDE.
I can confirm that the third level keys work with the terminal, and add that they still work with OpenOffice.org, Kate, Konqueror, and Lokalize,
but they do not work in gedit, Firefox or Thunderbird, Bluefish, gFTP, Gnucash, or Search for Files. When I press a 3rd level key combination no glyph appears on the screen and the cursor does not advance.

Felix Dreissig (f30) wrote :

@Donald: Does installing the patched package by Alexey solve the problem for you? Then it should be fine.
If it doesn't, this might be a different bug. In this case, you should create a new bug report for it.

Joe_Linux (joelinux-earthlink) wrote :

I don't know about a third level chooser, but I can't get the Ubuntu (Win) key to open my Ubuntu menu (9.10)

Felix Dreissig (f30) wrote :

@Joe: Though it isn't directly related to this bug:
Did you try it like that: http://www.howtogeek.com/howto/ubuntu/use-the-windows-key-for-the-start-menu-in-ubuntu-linux/ ?

Alt+F1 is the shortcut for the menu. I think somewhere in GNOME you can set
keyboard shortcuts and change it to the Super (Windows, diamond, Apple, Tux,
Ubuntu, etc...depending on your keyboard) key.

Alexey Ten (Lynn)'s fix (Comment 12) works for me.
Thanks!

I got the same issue on my Macbook 2,1 running Ubuntu 9.10. The patch by Alexey Ten solved my problem. Thanks!

Bryce Harrington (bryce) on 2010-02-11
summary: - Win key as third level chooser doesn't work anymore
+ [Needs 1.8] Win key as third level chooser doesn't work anymore
Changed in xkeyboard-config (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 1.8-1ubuntu4

---------------
xkeyboard-config (1.8-1ubuntu4) lucid; urgency=low

  * Add tw to Makefile so it will install
  * Earlier upload fixed win key as 3rd level chooser (LP: #408397)
 -- Bryce Harrington <email address hidden> Mon, 29 Mar 2010 20:49:47 -0700

Changed in xkeyboard-config (Ubuntu):
status: In Progress → Fix Released
Šimánek (jasonsimanek) wrote :

Just tried the latest rendition of Ubuntu 10.04 Lucid and can confirm that third-level is working again. Thanks!

Changed in xkeyboard-config (Debian):
status: Confirmed → Fix Released
Changed in xkeyboard-config:
importance: Unknown → Medium
Changed in xkeyboard-config:
importance: Medium → Unknown
Changed in xkeyboard-config:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.