No Dvorak layout for multilingual keyboards

Bug #319376 reported by Oleg Zalizniak on 2009-01-20
6
Affects Status Importance Assigned to Milestone
xkeyboard-config
Unknown
Medium
xkeyboard-config (Ubuntu)
Wishlist
Unassigned

Bug Description

I use three languages in my keyboard, so after physically moving keys to dvorak, It created obvious problem.

I made a fix for it, "dvorak - compatible" layouts for phonetic russian & hebrew. Hope It will be usefull to somebody.

Attached files ru & il go to /etc/X11/xkb/symbols

Activating them in xorg.conf:

 Option "XkbLayout" "ru,il,il"
 Option "XKbVariant" "phonetic_dvorak,phonetic_dvorak,dvorak"

Oleg Zalizniak (ramaloke) wrote :

Created an attachment (id=22256)
lng.tar

Forwarding this bug from a Ubuntu reporter:
https://bugs.edge.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/319376

[Original Report]
I use three languages in my keyboard, so after physically moving keys to dvorak, It created obvious problem.

I made a fix for it, "dvorak - compatible" layouts for phonetic Russian & Hebrew. Hope It will be useful to somebody.

Attached files ru & il go to /etc/X11/xkb/symbols

Activating them in xorg.conf:

 Option "XkbLayout" "ru,il,il"
 Option "XKbVariant" "phonetic_dvorak,phonetic_dvorak,dvorak"

Bryce Harrington (bryce) on 2009-01-26
Changed in xorg:
importance: Undecided → Wishlist
status: New → Triaged
Bryce Harrington (bryce) wrote :

Thanks Oleg,

I've forwarded this upstream, to https://bugs.freedesktop.org/show_bug.cgi?id=19749, so they can incorporate it into xkeyboard-config. Please subscribe to that freedesktop bug in case upstream needs additional information or wishes you to test something.

Changed in xkeyboard-config:
status: Unknown → Confirmed

ok, will go in after release.

asked a question on launchpad - regarding number of users

Changed in xkeyboard-config:
status: Confirmed → In Progress

Oleg, is anybody using these variants (except you)? I would not like to bloat the codebase with variants for a single user.

answered you there

Oleg Zalizniak (ramaloke) wrote :

You meen this variants in dvorak? I can't answer that as I _don't know anyone_ who uses dvorak at all. But i suppose there are russian or israeli dvorak users. I don't know the statistics

Where did you take this variant from? Any URL? Or did you compose it yourself?

Oleg Zalizniak (ramaloke) wrote :

The variants phonetic rus/heb & heb exist in xkeyboard for ages.
I took the existing and remapped it to fit dvorak keyboard

I would not like to commit the keyboard which was not really tested/used by anyone but the author. What I offer is you to publish your keyboard on some web page, announce it as publicly as you can (linux.org.ru, opennet.ru, ...) and see what people say. If you see there is some demand for it - I'll commit it.

Yaron (sh-yaron) wrote :

You can use the Hebrew forum to publish the Hebrew dvorak as well
http://www.ubuntu-il.com/forums

And there are many mailing list where you can find most of the active Israeli linux members

And one last thing:
Dvorak was tested to be more efficient and time-saving for English writing, what makes you think that repositioning the characters at the same way in Hebrew will cause it to be more efficient?

Oleg Zalizniak (ramaloke) wrote :

Sorry for long (very :() delay.

Repositioning the characters at the same way in Hebrew WOULDNT make it more efficient.
Hebrew (and russian) already printed on keyboard/stickers, after moving english - hebrew moves as well and becomes useless. so you need new layout.

I will ask at forums if somebody needs it.

PS. Is there dvorak users at all :) ? I'm only one I know :-D

Oleg, any feedback from the Hebrew forum? Regarding the Russian variant, you could do some PR on linux.org.ru or opennet.ru. I would really love to hear from some other users of your layout.

Oleg Zalizniak (ramaloke) wrote :

nothing usefull at hebrew forums, it seems like there is no dvorak users at all :(
also posted at linuxforum.ru, no response there either.

For the reference, http://linuxforum.ru/index.php?showtopic=92761

Well, may be noone needs it actually;) I would try LOR anyway...

Changed in xkeyboard-config:
importance: Unknown → Medium
Changed in xkeyboard-config:
importance: Medium → Unknown
Changed in xkeyboard-config:
importance: Unknown → Medium
Psychonaut (psychonaut) wrote :

Sergey, I've been using Oleg's Russian "phonetic_dvorak" layout for years. I can attest that it's very useful.

However, I think this particular issue can be closed, as the layout seems to have made it into the official X.Org distribution this year: https://bugs.freedesktop.org/show_bug.cgi?id=96537

Hi there

Actually I see this bug is already RESOLVED FIXED.

Cheers

On Wed, Dec 28, 2016 at 4:51 PM, Psychonaut <email address hidden>
wrote:

> Sergey, I've been using Oleg's Russian "phonetic_dvorak" layout for
> years. I can attest that it's very useful.
>
> However, I think this particular issue can be closed, as the layout
> seems to have made it into the official X.Org distribution this year:
> https://bugs.freedesktop.org/show_bug.cgi?id=96537
>
>
> ** Bug watch added: freedesktop.org Bugzilla #96537
> https://bugs.freedesktop.org/show_bug.cgi?id=96537
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/319376
>
> Title:
> No Dvorak layout for multilingual keyboards
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/xkeyboard-config/+bug/319376/+subscriptions
>

Now that we have Russian phonetic dvorak - could someone please create nice clean patch for Hebrew Dvorak?

-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/issues/128.

Changed in xkeyboard-config:
status: In Progress → Unknown
Yaron (sh-yaron) wrote :

Hebrew Dvorak can be found at the following address:
http://mikladot.com/dvorak/hebdvork-linux.zip

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.