keyboard layout switch in gnome results in dead keys

Bug #301137 reported by vladuz976 on 2008-11-23
4
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Undecided
Unassigned

Bug Description

On a Sony Vaio VGN-C71B Japanese laptop keyboard. When setting keyboard layouts via the gnome dialogue, System --> Preferences --> Keyboard, the only layout that works is the standard Japanese. I tried, USA Dvorak, German, US Qwerty but all result in half of the keyboard being dead, letters turning into backspace and/or arrow keys. Really weird behaviour.
Description: Ubuntu 8.10
Release: 8.10

aesis05401 (aesis05401) on 2009-04-13
affects: ubuntu → gnome-control-center (Ubuntu)
Sebastien Bacher (seb128) wrote :

the layout definition are a xkeyboard-config thing

affects: gnome-control-center (Ubuntu) → xkeyboard-config (Ubuntu)
Bryce Harrington (bryce) on 2009-09-02
tags: added: intrepid
Simos Xenitellis  (simosx) wrote :

Reporter, could you please try to reproduce in Ubuntu 10.04?

The problem you describe is quite strange and I cannot think of a reason why this should happen.
Most probably the cause relates to interaction with other keyboard layout software (such as SCIM).

As there has not been activity in this report for a long time, I will close it.
If you can replicate the problem with Ubuntu 10.04, please open a new bug report.
For Japanese, you may use the simple keyboard layout from the Keyboard preferences, or you can use the advanced keyboard layout from 'IBus' (see System/Preferences/IBus Preferences).

Changed in xkeyboard-config (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xkeyboard-config (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers