Keyboard repeat delay does not apply to all keys equally

Bug #293275 reported by Eyal Lotem on 2008-11-03
4
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Undecided
Unassigned

Bug Description

When using the Keyboard preferences to adjust the keyboard repeat rate and delay, it seems to work except it seems to not apply to at least 2 keys: Left-Arrow, Down-Arrow.

Any key-press held down will start repeating after the specified delay (which I set to almost immediately), but left/down remain very slow-to-repeat, and I have to wait about 0.3-0.5 seconds for them to start repeating.

This is an annoyance, especially to fast typists.

I see something quite similar to this, however for me it only occurs when "Slow keys" is enabled. Here are my symptoms:

Keyboard Preferences | General | Repeat keys [checked]
Keyboard Preferences | Accessibility | Slow keys [checked]

Arrow keys no longer auto-repeat.

Disable "Slow keys" and they work again.

Can you try fiddling with these settings and see if we see the same effects?

Austin Lund (austin-lund) wrote :

I cannot confirm this. I get the same delay/speed for the left and down arrows as any other keys.

Also, does this apply only to X or is it the same behaviour in the terminal?

affects: ubuntu → xkeyboard-config (Ubuntu)
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. A new version of xkeyboard-config is available in both Lucid and Maverick and we are wondering if this is still reproducible in any of those versions, May you please test and give us of feedback about it? Thanks in advance.

Changed in xkeyboard-config (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xkeyboard-config (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers