Ubuntu

Intrepid Regression: Tilde key stopped working on Dell Latitude X1

Reported by Andreas Schildbach on 2008-09-23
14
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xkeyboard-config

With Intrepid Alpha 6 and all dist-upgrades applied, the Tilde key stopped working. I have tested almost all other unusual key combinations, and they all work.

This is on a German Dell Latitude X1. Have selected "Dell Latitude series laptop" in the Keyboard Preferences / Layout / Keyboard Model and Selected Layout: Germany. Had the same problem with the default "Generic 105-key (Intl) PC".

$ setxkbmap -print
xkb_keymap {
 xkb_keycodes { include "evdev+aliases(qwertz)" };
 xkb_types { include "complete" };
 xkb_compat { include "complete" };
 xkb_symbols { include "pc+de+inet(evdev)" };
 xkb_geometry { include "pc(latitude)" };
};

This is a regression from Hardy.

And yes, I'm actually pressing twice on the Tilde key, as this is a combination key like the accents.

Some more tests: I can actually combine the tilde with a consonant like ã, õ, ũ. But the 'standalone' Tilde (~) does not work.

Thomas Liebetraut (tommie-lie) wrote :

Andreas, do you also experience this with the acute, grave and circumflex keys? I have the same problem since I upgraded from Hardy to Intrepid. Pressing dead keys twice doesn't give me the symbol anymore. However, dead key + space works, i.e. <AltGr>+<+>,<space> gives me ~.
I'm using the normal "Generic 105-key (Intl) PC".

$ setxkbmap -print
xkb_keymap {
        xkb_keycodes { include "evdev+aliases(qwertz)" };
        xkb_types { include "complete" };
        xkb_compat { include "complete" };
        xkb_symbols { include "pc+de+inet(evdev)+level3(ralt_switch_for_alts_toggle)+altwin(alt_super_win)+group(alts_toggle)" };
        xkb_geometry { include "pc(pc105)" };
};

Yes, I have the same problem with the accents and the circumflex key. And yes, the Space key combination you described works as a workaround.

How can I back the old behaviour?

Changed in xkeyboard-config:
status: New → Confirmed
skotti (jsk-priv) wrote :

Same for me on my two Intrepid machines.
One Acer Aspire 5550 (selected Acer laptop keyboard map/german)
One DIY PC using Sun keyboard, german layout.

rssaddict (simoneau-louis) wrote :

Yeah, same on a Compaq Presario r4000 series with Canadian Multilingual layout. Thanks for the dead key+space workaround, I was having a hard time writing regular expressions without ^

;-)

For me, this has been fixed in one of the latest updates.

rssaddict (simoneau-louis) wrote :

yeah, fixed for me too

Thomas Liebetraut (tommie-lie) wrote :

For me too.

Changed in xkeyboard-config:
status: Confirmed → Fix Released
Philipp (philipp-strack-gmail) wrote :

Same problem for me under Ubuntu 9.04 Jaunty Jackalope, I can get the tilde character.

Pressing

[alt] + [+]
or
[alt] + [+] followed by [space]

does not give the tilde character. I tried the keyboard layout german and german-no-dead keys.

I have the following keyboard http://www.daskeyboard.com/

can I provide further helpful feedback?

Philipp (philipp-strack-gmail) wrote :

I mean I can not get the tilde character - Sorry for the confusion

Philipp (philipp-strack-gmail) wrote :

Should I open a new bug report ?

Philipp: Yes, you should open a new bugreport, as this particular problem has been fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers