Afghanistan keyboard layouts can not be added

Bug #260647 reported by Zabeeh Khan on 2008-08-23
30
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Undecided
Unassigned
Dapper
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

On Ubuntu 8.04

I want to add Pashto layout, so when I click add and choose Afghanistan > Pashto or Pashto OLPC, it gives an error message and I cannot proceed.

It is only for Pashto (all the layouts there in the Afghanistan category) and not for the other languages.

The error message given is:

"
Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
10400090

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
"

and the results of the above commands are:

- The result of xprop -root | grep XKB:

"
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", "grp:alts_toggle"
"

- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

"
layouts = [us,af ps]
model =
options = [grp grp:alts_toggle]
overrideSettings = true
"

elmurato (elmurato87) wrote :

I can confirm this error...

Adam Spain (adamspain) wrote :

Bug #67188 has people with the same error, so that might be relevant.

Zabeeh Khan (zabeehkhan) wrote :

manual configuration or whatever, it doesn't work for Pashto. I tried many different things and also asked in linux questions, but the problem can't be solved in any way.

I hope it is fixed before the release!

Adam Spain (adamspain) wrote :

I think I've found the problem. There appears to be some syntax errors in /usr/share/X11/xkb/symbols/af, with full stops being in three places where there should be a comma. I've attached a fixed version of the file. If you download it and overwrite the file in /usr/share/X11/xkb/symbols (you'll need to be root), you can try removing and adding the Pashto keyboard layout again to see if it fixed it for you. It looks to be working to me, but if you could confirm that would be helpful.

I don't think this problem is present in Intrepid because the file doesn't have these syntax errors, although I haven't tested to check. It would be nice to get this fixed in Hardy as it's pretty broken currently.

Adam Spain (adamspain) wrote :

Attached is a debdiff to fix the syntax errors which cause the error message. The debdiff is against the version of xkeyboard-config currently in hardy-proposed, as I'm assuming that will eventually get approved. Intrepid and Gutsy don't have these same syntax errors in their packages, so I assume they do not have this bug.

I believe the impact of this bug is pretty big as it causes all of the Afghanistan keyboard layouts to be unusable (not just Pashto), as they cannot be selected (using the Gnome or KDE interfaces for setting the keyboard layout). The patch is really pretty minor, just changing a full stop to a comma in three places in the keyboard layout file. I don't see how this change could cause any regressions, but my knowledge of this package is very limited (I only found the syntax errors because the full stops look out of place and like a typo).

TEST CASE:
In Gnome on Hardy go System -> Preferences -> Keyboard, select the Layouts tab and click the "Add" button. From the "Layouts" drop down select "Afghanistan" and select any of the variants from the "Variants" drop down. Click the "Add" button and notice the "Error activating XKB configuration...." error comes up in a box. When the bug is fixed, there should be no error and you should be able to use the Afghanistan keyboard layouts.

Adam Spain (adamspain) on 2008-10-20
Changed in xkeyboard-config:
assignee: nobody → adamspain
status: New → In Progress
Zabeeh Khan (zabeehkhan) wrote :

I am going to test it...just didn't found time..will comment after testing.

Adam Spain (adamspain) on 2008-10-20
Changed in xkeyboard-config:
assignee: adamspain → nobody
status: In Progress → Confirmed
Bryce Harrington (bryce) on 2008-10-21
Changed in xkeyboard-config:
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

There are no "." typos in the dapper version.

Changed in xkeyboard-config:
status: New → Invalid
Martin Pitt (pitti) wrote :

I'll sponsor this for hardy, thank you for the fix!

Changed in xkeyboard-config:
status: New → In Progress
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Adam Spain (adamspain) wrote :

The package in hardy-proposed fixes the error for me and the keyboard layouts seem to work, but feedback from other testers would be helpful.

Thanks,
The problem been solved in 8.10 , now it works fine.

On Tue, Oct 21, 2008 at 2:42 PM, Adam Spain <email address hidden> wrote:

> The package in hardy-proposed fixes the error for me and the keyboard
> layouts seem to work, but feedback from other testers would be helpful.
>
> --
> Afghanistan keyboard layouts can not be added
> https://bugs.launchpad.net/bugs/260647
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in "xkeyboard-config" source package in Ubuntu: Fix Released
> Status in xkeyboard-config in Ubuntu Dapper: Invalid
> Status in xkeyboard-config in Ubuntu Hardy: Fix Committed
> Status in xkeyboard-config in Ubuntu Intrepid: Fix Released
>
> Bug description:
> On Ubuntu 8.04
>
> I want to add Pashto layout, so when I click add and choose Afghanistan >
> Pashto or Pashto OLPC, it gives an error message and I cannot proceed.
>
> It is only for Pashto (all the layouts there in the Afghanistan category)
> and not for the other languages.
>
> The error message given is:
>
> "
> Error activating XKB configuration.
> It can happen under various circumstances:
> - a bug in libxklavier library
> - a bug in X server (xkbcomp, xmodmap utilities)
> - X server with incompatible libxkbfile implementation
>
> X server version data:
> The X.Org Foundation
> 10400090
>
> If you report this situation as a bug, please include:
> - The result of xprop -root | grep XKB
> - The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
> "
>
> and the results of the above commands are:
>
> - The result of xprop -root | grep XKB:
>
> "
> _XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
> _XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", "grp:alts_toggle"
> "
>
> - The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
>
> "
> layouts = [us,af ps]
> model =
> options = [grp grp:alts_toggle]
> overrideSettings = true
> "
>

--
Shafi tokhi

Zabeeh Khan (zabeehkhan) wrote :

yeah..I can also confirm that the problem is solved with this new file when replaced with that old one!

I checked it..

Martin Pitt (pitti) wrote :

hi Zabeekhan,

Zabeehkhan [2008-10-21 14:23 -0000]:
> yeah..I can also confirm that the problem is solved with this new file
> when replaced with that old one!

To make double-sure, can you please install the package from
hardy-proposed and check it out with that one?

Thank you!

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in xkeyboard-config:
status: Fix Committed → Fix Released
Zabeeh Khan (zabeehkhan) wrote :

I am sorry to not be able to help and test the package from hardy-proposed. As I am too busy these days, so couldn't do it.....

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers