~ key does not appear directly after pressing AltGr-4 on Spanish Keyboard

Bug #229966 reported by dibeas on 2008-05-13
6
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Low
Unassigned

Bug Description

After upgrading to Ubuntu 8.04 presssing AltGr-4 followed by space is required to enter ~ symbol. Previously (as with all other linux distros tested) AltGr-4 displays ~ directly. Current key map is spanish 105 (Int'l) keyboard, but same result is obtained with a Dell Inspiron 6000 and Dell Inspiron 6xxx/8xxx keymap.

Replicate problem:

configure spanish keyboard, 105 keys
press AltGr-4

Expected result:

~ appears on screen

Obtained result:

Nothing happens, after pressing space, ~ appears. If a vowel (not e) or n is pressed ã, ĩ, õ, ũ, ñ are obtained.

Ubuntu 8.04

Thanks for your bug report. Your problem should go away if you chose "eliminate dead keys" as the variant of the Spanish key map. Feel free to reopen (set status to new) this bug if this did not solve your issue.

dibeas (dibeas) wrote :

Selecting 'eliminate dead keys' variant does solve that particular problem: AltGr-4 now shows ~ directly, but it also implies that á é í ó ú cannot be typed. Previously (up to ubuntu 7.10) ´ (character to the right of ñ) was composed tilde, which followed by a vowel would print one of ( á é í ó ú ) symbols. At the same time AltGr-4 did print ~ symbol. To compose ~ with another char you could use a combination (Ctrl-ñ IIRC) followed by the second character.

With the current changes, either you cannot type á é í ó ú easily (which are required characters in spanish) or you cannot type ~ with just a single key press. Disappointing for programming in C++... moreover when you have grown used to it for years.

Hi, sorry for so quickly invalidating your bug... I'm afraid I can't help you with your problem then, I don't know whether there was any reason for changing the Spanish keyboard layout - I'll assign the package to libgnomekbd (hope that's the right one...). However, looking at the layout I think you can get the '~' key with a single key press in the standard layout using AltGr + [key right of ? (left of backspace)].

affects: libgnomekbd (Ubuntu) → xkeyboard-config (Ubuntu)
Bryce Harrington (bryce) on 2009-09-02
tags: added: hardy

Hi. It's been a while since you reported this issue -- is this still a problem with Ubuntu Lucid (10.04)? Thanks.

Changed in xkeyboard-config (Ubuntu):
status: New → Incomplete
Changed in xkeyboard-config (Ubuntu):
importance: Undecided → Low
Simos Xenitellis  (simosx) wrote :

In Ubuntu 10.04 with the default Spanish keyboard layout, AltGr + 4 produces ~.
This has been the case since April 2008,
0fb00efe (svu 2008-04-23 18:12:14 +0000 17) key <AE04> { [ 4, dollar, asciitilde, dollar ] };

Could you please try again with Ubuntu 10.04?

The situation you get when you have to press the key and then a space, is that somehow the dead_tilde is being mixed up.
For the Spanish layout, you get dead_tilde if you press AltGr + (that key that shows the Exclamation Down character).

So, if you still get the problem, then you either
1. have a mixed up keyboard model that mixes the '4' key with 'exclamation down'.
2. or you may have enabled by accident IBus (see Language Support, make sure that IBus is disabled).

Bryce Harrington (bryce) on 2010-07-02
Changed in xkeyboard-config (Ubuntu):
status: Incomplete → New
status: New → Incomplete
dibeas (dibeas) wrote :

Sorry, I forgot about the bug and in the later days I have been quite busy to test (I am not running ubuntu with an spanish layout for some time). The problem has been resolved somewhere in the way from the release of 8.04 to 9.04. I have checked whether I can mark the bug as fixed, but I cannot really tell what the proper option would be (fix released?)

Thanks for confirming. Yes "fix released" would be fine, as it was likely fixed by an update. "Invalid" might also be appropriate (because no one really confirmed the bug when you reported it). I set the status to "Fix released".

Changed in xkeyboard-config (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers