french dvorak layout outdated

Bug #205695 reported by Arktus on 2008-03-23
12
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Ubuntu)
Medium
Unassigned

Bug Description

In the /usr/share/X11/xkb/symbols/fr file,
the «France - Bepo, ergonomic, Dvorak way» (which is a french dvorak in development) is an outdated version (v0.6.2),
there are significant changes since this version,
the last version available is v0.6.5.1 .

Here is the official website : http://www.clavier-dvorak.org (in french)
The xkb is available at the bottom of the page : http://www.clavier-dvorak.org/wiki/Version_actuelle (in french)

In the attachment, I add the /usr/share/X11/xkb/symbols/fr file that I modify from the line 433 to the line 540.

I'm using Ubuntu hardy (development branch) 8.04.

Olivier Guéry (nemolivier) wrote :

The last version is the 0.6.5.1, in fact.

Diti Torterat (diti) wrote :

I'm learning fr-dvorak-bepo and I really would like to see the newest version of this LTS! Like Firefox 3.0, there will be a great way to spread this disposition to the community.

Diti Torterat (diti) wrote :

By the way, I have not the file /etc/X11/xkb/symbols/fr ...

Arktus (anael-naoned) wrote :

Oh thanks Dimitri Torterat, I've just seen that /etc/X11/xkb/symbols is a link to /usr/share/X11/xkb/symbols

Have you got the file /usr/share/X11/xkb/symbols/fr ?

I edit the Bug description in consequences, and I add the «.1» after «0.6.5» Olivier ;) .

description: updated
Diti Torterat (diti) wrote :

Yep, I have got /usr/share/X11/xkb/symbols/fr. But for mysterious reasons, manual procedures on this file in order to get the latest version working... don't work. I think it's a bug. Or must I edit more than one file?

Oh, who cares? Let's talk about 0.6.5.1 on Hardy.

Olivier Guéry (nemolivier) wrote :

Sorry to be late, here is a xkb file who work here on my Hardy.
You have to rename it « fr »
I change the outdated comments too.

Colin Watson (cjwatson) wrote :

Has anyone filed this upstream yet? I don't see it. (bugs.freedesktop.org, xkeyboard-config product.) I could file it myself, but it would really be better coming from French people.

Changed in xkeyboard-config:
assignee: nobody → kamion
status: New → Confirmed
Bryce Harrington (bryce) on 2008-04-08
Changed in xkeyboard-config:
status: Confirmed → Incomplete
Arktus (anael-naoned) wrote :

«but it would really be better coming from French people»
Je suis tout à fait d'accord avec toi Colin…

C'est bien ici le site officiel de report de bug d'Ubuntu ?

«Has anyone filed this upstream yet?»
I don't understand. :-/

jd (jd-typhon) wrote :

Arktus, Colin means that, concerning this feature request, it is a kind of an issue that the freedesktop/xkeyboard-project/whoever should deals with, not Ubuntu. I guess one could fill a bug report on the very project that manage the xkb symbols files.

In fact, in the « bépo » team, we are still chatting about waiting for
a 1.0 stable version (whitch will be here soon, I hope) or not before
putting it in xorg.
So i could be great to see it in hardy, but as a xorg patch, not as an
official xorg realese yet.

Némolivier

On Tue, Apr 8, 2008 at 8:17 PM, jd <email address hidden> wrote:
> Arktus, Colin means that, concerning this feature request, it is a kind
> of an issue that the freedesktop/xkeyboard-project/whoever should deals
> with, not Ubuntu. I guess one could fill a bug report on the very
> project that manage the xkb symbols files.
>
>
>
> --
> french dvorak layout outdated
> https://bugs.launchpad.net/bugs/205695
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

--
[Message tapé sur un clavier Bépo : http://www.clavier-dvorak.org ]
Olivier <email address hidden> http://nemolivier.blogspot.com

jd (jd-typhon) wrote :

Olivier told me to post, then here we go :) He wrote, actually:
"In fact, among the « bépo » team, we are still talking about the opportunity to release a 1.0 stable version (which I hope will be out soon) and make it through the Xorg process. So, it would be great to have it in Hardy, but I guess it will be as a Xorg patch rather than shipped within an official Xorg release."

Colin Watson (cjwatson) on 2008-08-19
Changed in xkeyboard-config:
assignee: kamion → nobody
status: Incomplete → Confirmed
importance: Undecided → Medium

Created an attachment (id=20565)
fr-modify

Forwarding this updated layout from a Ubuntu reporter:
https://bugs.edge.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/205695

[Problem]
clavier-dvorak.org provides a newer version of the french dvorak keyboard layout. Is this appropriate to be included?

[Original Report]
In the /usr/share/X11/xkb/symbols/fr file,
the «France - Bepo, ergonomic, Dvorak way» (which is a french dvorak in development) is an outdated version (v0.6.2),
there are significant changes since this version,
the last version available is v0.6.5.1 .

Here is the official website : http://www.clavier-dvorak.org (in french)
The xkb is available at the bottom of the page : http://www.clavier-dvorak.org/wiki/Version_actuelle (in french)

In the attachment, I add the /usr/share/X11/xkb/symbols/fr file that I modify from the line 433 to the line 540.

I'm using Ubuntu hardy (development branch) 8.04.

Created an attachment (id=20566)
fr-bepo-0.6.5.1-hardy

I am happy to update the bepo variant - which of the two attachments is right?

(In reply to comment #2)
> I am happy to update the bepo variant - which of the two attachments is right?
>

  Hello Serguey,

Nope of the two attachments are up to date : the Ubuntu bug report has be done in the beginning of 2008, since then, some updates have be done to the Bépo layout, to give the 1.0rc2 I'm trying to integrate in Xorg, with the help of James and you (see bugs #17821 and #17822).

  About the 17822 bug, compositions in libX11, it is almost already done. The remaining problem which prevents me to submit a final patch for xkeyboard-config and libX11 is about the ISO_Level5_Latch solution proposed by James, I'll do an e-mail about this soon.

  with regards,
    Frédéric Boiteux.

Great. So I guess I just should patiently wait for the final version of the bepo variant (hopefully soon). Sorry for not answering your 17822 mails - I see, you and James basically sorted it out.

Bryce Harrington (bryce) wrote :

Hi, I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=18692. Please subscribe to this bug in case upstream has additional questions. Thanks in advance.

Changed in xkeyboard-config:
status: Confirmed → Triaged
Changed in xkeyboard-config:
status: Unknown → Confirmed

As this bug is a clone of 18721+18722, which have been fixed, I think it can be also closed.

I am fine with that!

Changed in xkeyboard-config:
status: Confirmed → Fix Released
Bryce Harrington (bryce) wrote :

Fixed in xkeyboard-config 1.5 now in jaunty.

Changed in xkeyboard-config:
status: Triaged → Fix Released
Changed in xkeyboard-config:
importance: Unknown → Medium
Changed in xkeyboard-config:
importance: Medium → Unknown
Changed in xkeyboard-config:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.