Strange Apple keyboard behaviour (Spanish layout)

Bug #1886215 reported by Pedro A. Aranda
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Undecided
Unassigned

Bug Description

I have an Apple Aluminium keyboard with Spanish/Castillian layout connected to my laptop:

lsusb output:

...
Bus 002 Device 006: ID 05ac:0221 Apple, Inc. Aluminum Keyboard (ISO)
Bus 002 Device 004: ID 05ac:1006 Apple, Inc. Hub in Aluminum Keyboard
...

I'm running Focal:

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04 LTS"

I want to enable the regular Spanish keyboard layout for the laptop's internal keyboard and the Macintosh layout for the Apple Aluminum keyboard.

When I press the key to the left of 'z' which should be '<' and I have the layout, I see the right key being highlighted but I get 'º' on the terminal

Likewise, when I press the key to the left of '1', I see it correctly highlighted but I get a '<' instead of a 'º'

affects: launchpad → ubuntu
Revision history for this message
Adolfo Jayme (fitojb) wrote :

just guessing a package to associate this report with

affects: ubuntu → xkeyboard-config (Ubuntu)
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Check out this Ask Ubuntu question for a way to handle Apple devices:

https://askubuntu.com/q/843590

But please note, though, that such an entry in /etc/default/keyboard would switch the keys for your built-in keyboard too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers