Left Win-key compose does not work anymore

Bug #187677 reported by Stefano on 2008-01-31
14
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Undecided
Unassigned

Bug Description

Since yesterday's upgrades, the compose key does not produce any effects anymore.

Which version of Ubuntu are you using?
Are you running compiz? Is the bug still valid when you turn compiz off?

Thanks in advance!

No I am not running compiz and I have the latest hardy.

On Feb 3, 2008 6:03 PM, Ralf Nieuwenhuijsen <email address hidden>
wrote:

> Which version of Ubuntu are you using?
> Are you running compiz? Is the bug still valid when you turn compiz off?
>
> Thanks in advance!
>
> --
> Left Win-key compose does not work anymore
> https://bugs.launchpad.net/bugs/187677
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Stefano (cantap) wrote :

I don't know for what reason, but if you uncheck the compose option, and then check it again, then it seems to work. I hope it will at the next reboot.

Stefano

Michael R. Head (burner) wrote :

I have capslock set to be compose. Worked fine under gutsy, now capslock toggles capslock. I've tried ticking it on and off in the Keyboard control panel to no effect.

Joseph Piché (josephpiche) wrote :

I can confirm that this is a bug. When setting a compose key, such as Left Win key, the changes take effect and it works. However, upon reboot, when going into the dialog again, the box is still checked, yet the compose key does not work. Un-checking and re-checking the box does work.

Output of `uname -a':
Linux w 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

Simos Xenitellis  (simosx) wrote :

Joseph, have you configured your Ubuntu so that it does not ask for password during login?

Joseph Piché (josephpiche) wrote :

That's it. If enable automatic login, then the compose key doesn't work until I reset the option. But if it's turned off, compose works fine.

Bjorn Hansen (holomorph) wrote :

I'm seeing this bug as well. Is there a fix to make the compose key work on login when automatic login is enabled? If not, I would be willing to spend some time to figure it out, but I'm not sure where to start.

CarloBaldassi (carlobaldassi) wrote :

I have made a script which fixes this issue, it's attached. Save it somewherere, make it executable and add it to the startup programs (in the "System/Preferences/Sessions" Gnome menu).
In the file there's an initial delay (at line 3): it is necessary in order for it to work: on my system I set it to 45 seconds, so that the code executes right after gnome startup completion (for me, it doesn't work unless all the applets are loaded). If it doesn't work for you, you may have to edit the script and increase that value a bit.

Joseph Piché (josephpiche) wrote :

I'm glad that you have a workaround, but does anybody have an idea how this might be truly fixed? Also, has anybody tested this is gutsy? Maybe it's a regression.

Definately a regression.

But what is more shocking is that turning auto-login on can cause
these kinds of side-effects in the first place.

Somehow the design/architecture of gdm is such that there can be a
difference between an auto-started session and a session where you
login manually.

The fact this kind of bug can exist in the gdm package makes me very
tempted to just replace it with another display manager.
Any one have any suggestions for a display manager that is clear
minimal and well maintained?

2008/9/5 Joseph Piche <email address hidden>:
> I'm glad that you have a workaround, but does anybody have an idea how
> this might be truly fixed? Also, has anybody tested this is gutsy? Maybe
> it's a regression.
>
> --
> Left Win-key compose does not work anymore
> https://bugs.launchpad.net/bugs/187677
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Arnaud Soyez (weboide) wrote :

Better fix, use ~/.gnomerc (see attachment) :

This sets up the Menu key as the compose key.

Arnaud Soyez (weboide) wrote :

Confirmed in Hardy 8.04.1

Changed in xkeyboard-config:
status: New → Confirmed
Arnaud Soyez (weboide) wrote :

Fixed in Intrepid Beta!!!

Stefan van der Walt (stefanv) wrote :

It is not fixed entirely. After hibernation, I see the same happening -- and then the fixes suggested above may not work.

Joseph Piché (josephpiche) wrote :

I believe this is fixed in Intrepid. Since I've upgraded, I haven't been able to reproduce this.

Stefan van der Walt (stefanv) wrote :

I am running Intrepid with the latest updates. The bug is not fixed. Have you tried to hibernate and wake up?

Joseph Piché (josephpiche) wrote :

Yes, I have tried hibernate, suspend, and reboot, and it's worked every time. Also, for this install I have not applied any of the fixes mentioned.

Arnaud Soyez (weboide) wrote :

Running latest Ubuntu Intrepid updates, I couldn't try hibernate or suspend because my computer doesn't support it, but rebooting doesn't affect the compose key. so to me, it's fixed against rebooting at least.

Bryce Harrington (bryce) on 2009-01-26
Changed in xkeyboard-config:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers