Euro sign not working on keyboard (Macbook)

Bug #1785387 reported by Jarno Suni on 2018-08-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Undecided
Unassigned

Bug Description

https://askubuntu.com/q/1059447/21005

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xfce4-settings 4.12.0-2ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-29.31~16.04.1-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Aug 4 13:18:18 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-01-05 (575 days ago)
InstallationMedia: Xubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
SourcePackage: xfce4-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Jarno Suni (jarnos) wrote :

Does it work properly elsewhere? Login screen, TTY, different DE, etc.

Changed in xfce4-settings (Ubuntu):
status: New → Incomplete
Jarno Suni (jarnos) wrote :

No, not on login screen or TTY. I have no other DE installed.

So, this is not some Xubuntu/Xfce specific issue.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=671824

>As a side note, MacBooks (as most other recent EU keyboards) use "EuroSign" and not the "currency" sign at shift-4. It's a bit silly to require everyone to create a Xmodmap file, so perhaps this should be changed in the upsteam xkb model.

affects: xfce4-settings (Ubuntu) → xkeyboard-config (Ubuntu)
Changed in xkeyboard-config (Ubuntu):
status: Incomplete → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

<Shift> + 4 has resulted in the ¤ character on Nordic XKB keyboard layouts for quite some time. If new keyboards tend to have the € character printed on that key instead, there may be a reason to reconsider it.

However, in any case this won't be changed in Ubuntu only. I would suggest that you file an upstream bug report too.

https://bugs.freedesktop.org/buglist.cgi?product=xkeyboard-config

If you do, please post the URL to the upstream bug in a comment here.

Let me add: Using <AltGr> + E is not a workaround. It's currently *the* natural way to type the € character with the keyboard layout - Finnish (Macintosh), identical with Swedish (Macintosh) btw - you are using.

(To make it a bit extra complicated: The currency of Sweden is not Euro.)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.