mm (Myanmar / Burmese) for zawgyi keyboard layout

Bug #1766063 reported by kokoye2007  on 2018-04-22
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Arch Linux)
New
Undecided
kokoye2007 
xkeyboard-config (CentOS)
New
Undecided
kokoye2007 
xkeyboard-config (Debian)
Fix Released
Medium
xkeyboard-config (Fedora)
New
Undecided
kokoye2007 
xkeyboard-config (Gentoo Linux)
New
Undecided
Unassigned
xkeyboard-config (Ubuntu)
Wishlist
Unassigned
xkeyboard-config (Unity Linux)
New
Undecided
Unassigned

Bug Description

https://bugs.freedesktop.org/show_bug.cgi?id=106169

New Keyboard Layout addition in Myanmar / Burmese

--- New Keyboard Layout ---

Added New Keyboard Layout - Burmese Zawgyi Keyboard
This is similar to Burmese MM.
Its most popular keyboard in Burmese.

tags: added: keyboard
description: updated
tags: added: xkeyboard-config
removed: keyboard
Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in xkeyboard-config (Debian):
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in xkeyboard-config (CentOS):
assignee: nobody → kokoye2007  (kokoye2007)
assignee: kokoye2007  (kokoye2007) → nobody
Changed in xkeyboard-config:
status: Confirmed → Fix Released
Changed in xkeyboard-config (Debian):
status: Confirmed → Fix Released
Changed in xkeyboard-config (Ubuntu):
assignee: nobody → kokoye2007  (kokoye2007)
status: New → Fix Committed
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report and your patch!

However, this is too late for Ubuntu 18.04, which will be released in a few days. Many users change xkb-data files to set up personal keyboard configuration, and we don't do stable release updates of this package unless absolutely necessary, since it would overwrite such changes.

I see that it was included upstream, so the new Burmese layout variant will most likely be included in Ubuntu 18.10.

Changed in xkeyboard-config (Ubuntu):
assignee: kokoye2007  (kokoye2007) → nobody
importance: Undecided → Wishlist
milestone: none → later
status: Fix Committed → Triaged
Gunnar Hjalmarsson (gunnarhj) wrote :

Not sure what you consider was done. That repository imports automatically from the upstream one. What I said, i.e. that it will be included in the xkb-data package only in 18.10, still stands.

kokoye2007  (kokoye2007) wrote :

https://bugs.freedesktop.org/show_bug.cgi?id=106169 is done

all of CentOS, Fedora, Arch, Debian is include

but still not include in 19.04

Changed in xkeyboard-config (Arch Linux):
assignee: nobody → kokoye2007  (kokoye2007)
Changed in xkeyboard-config (CentOS):
assignee: nobody → kokoye2007  (kokoye2007)
Changed in xkeyboard-config (Fedora):
assignee: nobody → kokoye2007  (kokoye2007)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.26-2ubuntu1

---------------
xkeyboard-config (2.26-2ubuntu1) eoan; urgency=medium

  * Merge with Debian (LP: #1766063, LP: #1825786), remaining changes:
    - control, rules, xkb-data-i18n.install, xkb-data.install: Split out
      xkb-data-i18n to be used by console-setup.
    - xkb-data.postinst: Remove the xkb cache to make sure it gets
      regenerated.
  * Dropped patch, applied upstream:
    - debian/patches/git_airplane_key.patch

xkeyboard-config (2.26-2) unstable; urgency=medium

  * Revert following commits:
    - ed67b29e (Map evdev keycode KEY_BRIGHTNESS_CYCLE to
      XF86MonBrightnessCycle)
    - d0e5e63c (Map evdev keycode KEY_KEYBOARD to XF86Keyboard)
    - e6103610 (Map evdev keycode KEY_FAVORITES to XF86Favorites)
    (Closes: #921867, #921940, #922020).

xkeyboard-config (2.26-1) unstable; urgency=medium

  * New upstream release.
    - Map evdev keycodes KEY_RFKILL and KEY_WWAN to XF86RFKill and
      XF86WWAN (Closes: #917157).
    - allowMultipleSelection is wrong in korean data (Closes: #902234).
  * Drop fix-typo.diff, upstreamed.
  * Cherry-pick af6c0f29 (Fixed broken pt layout) from upstream.
  * Let uscan check upstream tarball signatures.
  * Update Vcs-* URLs to point to salsa.debian.org.
  * Bump debhelper compat to 10.
  * Raise Priority to optional.
  * Set source format to 1.0.
  * Bump standards version to 4.3.0.

 -- Gunnar Hjalmarsson <email address hidden> Mon, 22 Apr 2019 08:08:00 +0200

Changed in xkeyboard-config (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.