[FFe] Elfdalian layout + merge with Debian 2.19-1

Bug #1655782 reported by Gunnar Hjalmarsson on 2017-01-11
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xkeyboard-config
Unknown
Unknown
xkeyboard-config (Ubuntu)
Medium
Gunnar Hjalmarsson

Bug Description

Please add the Elfdalian keyboard layout which has been added upstream (see the Freedesktop bug report).

I also propose that we take this opportunity to merge with Debian xkeyboard-config 2.19-1.

Gunnar Hjalmarsson (gunnarhj) wrote :

Proposed upload to fix this bug is available in this PPA:

https://launchpad.net/~gunnarhj/+archive/ubuntu/xkeyboard-config

tags: added: upgrade-software-version
summary: - Elfdalian layout + merge with Debian 2.18-1
+ Elfdalian layout + merge with Debian 2.19-1
description: updated

Thanks for the work Gunnar but there is a problem with the version in your ppa, debdiffing between 2.19-1 from Debian and your 2.19-1ubuntu1~ppa1 it looks like your reverted the version update

e.g

--- xkeyboard-config-2.19.orig/configure.ac
+++ xkeyboard-config-2.19/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT(xkeyboard-config, 2.19)
+AC_INIT(xkeyboard-config, 2.18)
 AC_CONFIG_SRCDIR(rules/base.xml.in)
 AM_INIT_AUTOMAKE([foreign dist-bzip2])
 AM_MAINTAINER_MODE

Gunnar Hjalmarsson (gunnarhj) wrote :

So it seems... Embarrassing! :(

I must have had the 2.18 upstream source on disk when dput'ing, but I still uploaded the correct upstream tarball. Shouldn't the package system complain in such a case?

Anyway, it's fixed now (I hope). Sorry.

Henning (wuelpi) wrote :

Will this get added to Zesty? Right now it is not in the repo: https://launchpad.net/ubuntu/zesty/+source/xkeyboard-config and the feature freeze is the day after tomorrow.

Sebastien Bacher (seb128) wrote :

Thank you but debdiffing the 2.19-1 version from Debian and the ppa it looks like some files are being removed in Ubuntu compared to Debian (.gitignore, iso15924.csv, extractGroupNames.sh, ...), the changelog doesn't seem to cover that, could you explain what's going on?

Gunnar Hjalmarsson (gunnarhj) wrote :

@Sebastien: What happened was mistake number 2 by me. :( I assumed incorrectly that everything outside the /debian folder is included in the *orig.tar.gz file, which it apparently is not in this case.

So I uploaded it again with the complete source including what Debian's *diff.gz file adds to folders outside /debian. (It doesn't seem to change what actually goes to the xkb-data package.)

My apologies. Third time's the charm.

Henning (wuelpi) wrote :

Will this update be in zesty?

Gunnar Hjalmarsson (gunnarhj) wrote :

I think and hope so, Henning. It would have been in already if I hadn't made a couple of stupid mistakes when preparing the proposed upload.

Gunnar Hjalmarsson (gunnarhj) wrote :

Since this has taken some time, and we now are in FF, I request a FFe.

It's a mixture of upstream bug fixes and new layout variants. Even if there is no revolutionary news in this upload, typing is an essential part of the user experience, and being decently up-to-date with this package is highly desirable (and of course important to those affected).

Please note that SRU:ing later is not an option; many users configure their keyboards by editing package owned files, so xkb-data should basically never be SRU:ed.

summary: - Elfdalian layout + merge with Debian 2.19-1
+ [FFe] Elfdalian layout + merge with Debian 2.19-1
Gunnar Hjalmarsson (gunnarhj) wrote :

Adding the ubuntu-debian delta for the convenience of a possible sponsor.

Iain Lane (laney) wrote :

I don't know what the regression potential of new xkeyboard-config releases is... can you give a bit more detail? What's in the release and how safe is it?

Assuming it is, I think it should be okay in principle. I didn't look at this particular proposed package from a sponsorship POV to know if it is right.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Iain: The nature of the changes between 2.17 and 2.19 can be viewed here:

https://cgit.freedesktop.org/xkeyboard-config/log/

And the complete diff is in the PPA:

https://launchpadlibrarian.net/306582771/xkeyboard-config_2.17-1ubuntu1_2.19-1ubuntu1~ppa2.diff.gz

It's to a large extent additional layouts/variants, and such changes don't at all affect the commonly used layouts for the big countries. There are also a few specific bug fixes. Please note that we are talking about data (the binary package xkb-data).

xkeyboard-config 2.19 is in Stretch. FWIW I have used it myself for a couple of months. :) I'd say that the regression risk is very low.

Adolfo Jayme (fitojb) on 2017-03-23
Changed in xkeyboard-config (Ubuntu):
importance: Wishlist → Medium
Iain Lane (laney) wrote :

Yeah, I can see the changes, I just don't know how to assess the impact of them or likely regression potential. I'll ask Timo or something to help me out. :)

Iain Lane (laney) wrote :

s/something/someone/!

Iain Lane (laney) wrote :

Ok apparently it's low risk, so go ahead.

Michael Terry (mterry) wrote :

I've uploaded this to zesty, thanks Gunnar!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.19-1ubuntu1

---------------
xkeyboard-config (2.19-1ubuntu1) zesty; urgency=medium

  * Merge with Debian, remaining changes:
    - control, rules, xkb-data-i18n.install, xkb-data.install: Split out
      xkb-data-i18n to be used by console-setup.
    - xkb-data.postinst: Remove the xkb cache to make sure it gets
      regenerated.
  * debian/patches/elfdalian-kb-layout.diff:
    - Addition of an Elfdalian keyboard layout (LP: #1655782).

xkeyboard-config (2.19-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 3.9.8.

xkeyboard-config (2.18-1) unstable; urgency=medium

  * Team upload.

  [ Timo Aaltonen ]
  * New upstream release.

  [ Julien Cristau ]
  * Update upstream URLs in packaging to use https.

 -- Gunnar Hjalmarsson <email address hidden> Wed, 15 Feb 2017 19:58:00 +0100

Changed in xkeyboard-config (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.