Kayboard 105 with Slovenian diagraphs is no QWERTZ

Bug #162462 reported by Boris Domajnko on 2007-11-13
2
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Ubuntu)
Medium
Unassigned

Bug Description

After upgrading to 7.10 the old problem from Feisty reappeared:

Keyboard layout: international 105, "Slovenian with diagraphs"
The keyboard gives wrong characters:
TYPE GET
q lj
w nj
y ž
x dž

When I change the setting from "Slovenian with diagraphs" to "Slovenian", it works ok - Slovenian QWERTZ keyboard.
I do not understand the actual meaning of "Slovenian with diagraphs". Maybe it does not need to exists at all.

Tools:
System->Administration->Keyboard

Timo Aaltonen (tjaalton) wrote :

Please try 8.10 alpha6 livecd if it works properly now.

Changed in xorg:
status: New → Incomplete
Boris Domajnko (boris-hermes) wrote :

8.10 alpha6 livecd:
- Setting to default Slovenian language during installation: ok
- Changing the Preferences->Keyboard: Country:Slovenia/variants:Slovenia: ok

However, the last three variants in the menu Preferences->Keyboard->Variants (...diagraphs, ....diagraphs, ....letters) are unneeded and a surplus. They seem to be a result from cut&paste from other language (e.g. Croatian,Serbian). Note that letters like 'lj' or 'nj' are treated as a single letter, but this is not the case not in Slovenian language.
Kind regards, B.

Michael Nagel (nailor) on 2008-11-03
Changed in xkeyboard-config:
status: Incomplete → New
Bryce Harrington (bryce) wrote :

Hi boris-hermes,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Changed in xkeyboard-config:
status: New → Incomplete

Hello Bryce,
it is only a default configuration issue: I am offered too many
possibilites. Some of the mentioned options are wrong and if I by mistake
select the "Slovenian with diagraphs", I cannot use the Slovenian keyboard
correctly. This is the only problem - there are no diagraphs on any
Slovenian keyboard (diagraph = Two letters that represent one speech
sound).

Regards, B.

On Pet, November 7, 2008 10:02, Bryce Harrington wrote:
> Hi boris-hermes,
>
>
> Please attach the output of `lspci -vvnn`, and attach your
> /var/log/Xorg.0.log file from after reproducing this issue. If you've
> made any customizations to your /etc/X11/xorg.conf please attach that as
> well.
>
>
> ** Changed in: xkeyboard-config (Ubuntu)
> Status: New => Incomplete
>
> --
> Kayboard 105 with Slovenian diagraphs is no QWERTZ
> https://bugs.launchpad.net/bugs/162462
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Bryce Harrington (bryce) on 2009-01-06
Changed in xkeyboard-config:
importance: Undecided → Medium
status: Incomplete → Confirmed

Forwarding this bug report from a Ubuntu reporter:
https://bugs.edge.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/162462

[Problem]
Several variants are given for Slovenian keyboards, but most appear to be unneeded and perhaps should be removed.

[Discussion]
The following variants are available:

    name[Group1]="Slovenia";
    name[Group1]= "Slovenia - US keyboard with Slovenian letters";
    name[Group1]= "Slovenia - Use guillemets for quotes";
    name[Group1]= "Slovenia - Use Slovenian digraphs";
    name[Group1]= "Slovenia - US keyboard with Slovenian digraphs";

This appears to mirror the ba variants, so it is thought perhaps this was a cut-and-paste error when deriving this file.

[Original Report]
Keyboard layout: international 105, "Slovenian with diagraphs"
The keyboard gives wrong characters:
TYPE GET
q lj
w nj
y ž
x dž

When I change the setting from "Slovenian with diagraphs" to "Slovenian", it works ok - Slovenian QWERTZ keyboard.
I do not understand the actual meaning of "Slovenian with diagraphs". Maybe it does not need to exists at all.

8.10 alpha6 livecd:
- Setting to default Slovenian language during installation: ok
- Changing the Preferences->Keyboard: Country:Slovenia/variants:Slovenia: ok

However, the last three variants in the menu Preferences->Keyboard->Variants (...diagraphs, ....diagraphs, ....letters) are unneeded and a surplus. They seem to be a result from cut&paste from other language (e.g. Croatian,Serbian). Note that letters like 'lj' or 'nj' are treated as a single letter, but this is not the case not in Slovenian language.

it is only a default configuration issue: I am offered too many
possibilites. Some of the mentioned options are wrong and if I by mistake
select the "Slovenian with diagraphs", I cannot use the Slovenian keyboard
correctly. This is the only problem - there are no diagraphs on any
Slovenian keyboard (diagraph = Two letters that represent one speech
sound).
Kind regards, B.

Bryce Harrington (bryce) wrote :

Hi Boris,

Okay, I think I understand the problem. I've forwarded the issue upstream at https://bugs.freedesktop.org/show_bug.cgi?id=19530 for review. Can you please subscribe to that bug in case upstream needs further information or wishes you to test something? Thanks ahead of time.

Changed in xkeyboard-config:
status: Confirmed → Triaged

First of all, it's 'digraph', not 'diagraph'.

Secondly, each of those layouts are different. You can view visually the differences when you go through the preview window in GNOME.

The 'digraph' layouts produce the correct Unicode characters for characters such as lj Lj nj Nj dž Dž. Some users may use 'lj', etc, though technically this is not the correct form per Unicode.

I would consider this report as INVALID.

Bryce Harrington (bryce) wrote :

Hi Boris,

Upstream feels your request to be invalid. Please discuss it with them upstream if you still feel your suggested change is worthwhile.

Changed in xkeyboard-config:
status: Triaged → Incomplete

Hello,
why is it so difficult to understand:
- there is no keyboard like "Slovenian with digraphs" (check on Google)
- in Slovenian language there are no single letter characters lj Lj nj Nj dž Dž.
- generally it is true that "Some users may use 'lj', etc, ", but there are many many other letters someone could want to use. But we still do not have Slovenian with German umlauts, or Slovenian with Spanish accents and tildas, etc.

Simon, isn't there a policy to consult a specialist for a specific language before making such decisions that are not related to known standars? Or at least consult wikipedia, e.g.
http://en.wikipedia.org/wiki/Keyboard_layout#Bosnian.2C_Croatian.2C_Serbian_.28Latin.29_and_Slovene

If the user selects the wrong (kbd) option, he cannot use the keyboard properly any more. I made this installation error (as a Slovenian not knowing what a digraph is!) and this is why I reported the problem. I feel I am spending too much time on this issue.

Regards, B.

Changed in xkeyboard-config:
status: Unknown → Confirmed

I also haven't seen or heard of any such keyboards. Switching to the unicode or unicodeus variant pretty much cripples a user on a standard keyboard.

Looking at the git log, I see no mention why these two were added when the previous rules were rewritten. So I agree it is likely a copy/paste issue.

Bryce Harrington (bryce) wrote :

Thanks for pushing for this upstream. Marking bug triaged for now. Hopefully it gets sorted out in time for beta-freeze (last point where we can accept xkeyboard-config changes for Jaunty).

Changed in xkeyboard-config:
status: Incomplete → Triaged

So, should I just drop it? Any other fixes?

Created an attachment (id=22937)
removed unicode and unicodeus variants

Short version: drop unicode and unicodeus.

Long version:
I'd just drop the two unicode variants, but I'm not sure about the alternatequotes one. If you are a grammar nazi, the proper quotes in slovenian are indeed the guillemets »« and not „“ (both are currently bound to the third level of s and d respectivelly). The layout picture in wikipedia includes the current quotes, so I guess it is fine.
But since the alternatequotes layout just swaps the quotes, I see no really compelling reason for not keeping it. Translators like to use the guillemets and on the current layout they're hiding on the fourth level (x,y,s,d). So maybe alternatequotes is useful for someone.

Lovely! Done!

I don't see it in git yet (forgot to push?), but I realised I forgot to remove them from rules/base.xml.in.

Could you please check?

Created an attachment (id=22955)
base.xml.in fix

Here it is, I see you didn't notice it.

You, right. Well, at some point later I'd catch it anyway - but thanks for the quick patch.

Changed in xkeyboard-config:
status: Confirmed → Fix Released

This has been fixed upstream now.

Bryce Harrington (bryce) wrote :

Queued up for next xkeyboard-config upload.

Changed in xkeyboard-config (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 1.5-2ubuntu8

---------------
xkeyboard-config (1.5-2ubuntu8) jaunty; urgency=low

  * Update 106_ru_fix_shift.patch: Remove extraneous parts to only
    change the minus/underscore issue. Upstream.
    (LP: #309844)
  * Add 109_de_low_quotemarks.patch: Add keys for typing low quotation
    marks. Upstream.
    (LP: #59572)
  * Add 110_fi_brokenbar.patch: Add keys for bar and broken bar symbols in
    the finnish keymap. Upstream.
    (LP: #181595)
  * Add 111_si_rm_unnecessary_diagraph_layouts.patch
    and 112_si_rm_unnecessary_diagraph_layouts_basexmlin.patch:
    Remove unnecessary diagraph layouts. Upstream.
    (LP: #162462)
  * Add 113_kg_fix_kyrgyz_layouts.patch: Update to official Kyrgyz
    Republic layouts. Upstream.
    (LP: #198655)

 -- Bryce Harrington <email address hidden> Wed, 18 Mar 2009 22:02:42 -0700

Changed in xkeyboard-config:
status: Fix Committed → Fix Released
Changed in xkeyboard-config:
importance: Unknown → Medium
Changed in xkeyboard-config:
importance: Medium → Unknown
Changed in xkeyboard-config:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.