Cannot modify some keys (here: "alt-gr p")

Bug #1374918 reported by nZain on 2014-09-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Undecided
Unassigned

Bug Description

As a software developer (german keyboard) I'm using a custom keyboard layout, essentially de(basic) with four additional keys:
alt-gr ö = {
alt-gr ä = }
alt-gr p = [ (unable to modify this one from thorn)
alt-gr ü = ]

Over the ubuntu versions the way to modify those keys has changed, where my favorite was xmodmap (or similar, don't remeber exactly). After my upgrade vom 12.04 to 14.04 we're back at editing "/usr/share/X11/xkb/symbols/de". While this is not very comfortable, I'm ok with that. I also found out that compiled keyboard maps are used by X11 now, so I have to
   sudo dpkg-reconfigure xkb-data
to make the changes take effect. This worked for remapping those german umlaut keys öäü with alt-gr into bracketleft/right {} and braceright ] but not for the 'alt-gr p', which always gives me a thorn 'þ' symbol. I even tried remapping the shift-p into 'O', but that didn't work either.

The original line in 'de' reads
    key <AD10> { [ p, P, dead_hook, NoSymbol, thorn, THORN, dead_hook, NoSymbol ] };
and my modified version is
    key <AD10> { [ p, P, braceleft, NoSymbol, thorn, THORN, dead_hook, NoSymbol ] };

There are only four entries for the key AD10:
1. german(T3) - the one I modified.
2. dvorak - nope, no dvorak here
3. neo-base - I don't even know what this is for, but also certainly not the one I'm interested in
4. htc-dream - well no, using a desktop computer with regular german keyboard.

I'm guessing, something overrides the default ASCI keys? Is there a base layout I'm not aware of? Doesn't make much sense.
best regards
  Patrick

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xkb-data 2.10.1-1ubuntu1 [modified: usr/share/X11/xkb/symbols/de]
ProcVersionSignature: Ubuntu 3.13.0-36.63-generic 3.13.11.6
Uname: Linux 3.13.0-36-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.4
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Sep 28 09:18:36 2014
Dependencies:

DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
InstallationDate: Installed on 2014-09-18 (9 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-36-generic root=UUID=6c4788d0-ad34-46c9-84a5-c40b32015622 ro quiet
SourcePackage: xkeyboard-config
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/09/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P2.10
dmi.board.name: H87 Pro4
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP2.10:bd07/09/2014:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnH87Pro4:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz 1:0.9.11.2+14.04.20140714-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Sun Sep 28 07:54:25 2014
xserver.configfile: default
xserver.errors: open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.15.1-0ubuntu2.1

nZain (patrick-stalph) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers