X.org is missing a keymap definition

Bug #131820 reported by Jens Georg on 2007-08-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xkeyboard-config
Unknown
Medium
xkeyboard-config (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xkb-data

The xkb-data package is missing a definition for my keyboard, the Microsoft natural multimedia keyboard rev 1.0a

Bryce Harrington (bryce) wrote :

The patch looks good, but the init script probably should be integrated into hotkey-setup or something, rather than having a separate init script just for this keyboard.

Changed in xkeyboard-config:
importance: Undecided → Medium
status: New → Confirmed
Jens Georg (yg-jensge) wrote :

I agree, the init script is rather a clumsy approach, but I didn't know better. From what I see hotkey-setup seems laptop related, while this is a PS/2 desktop keyboard (it even depends on laptop-detect)

Forwarding this Ubuntu patch for upstream consideration:
https://bugs.edge.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/131820

This patch adds support for the MS Natural Multimedia 1.0a keyboard. I checked that it's not already included in the 1.3 we're carrying in Ubuntu.

Created an attachment (id=20022)
patch

Created an attachment (id=20023)
init script

The contributor also provided this init script to enable the keyboard, however I'm not sure how necessary this is.

Bryce Harrington (bryce) wrote :

I've forwarded this patch upstream - http://bugs.freedesktop.org/show_bug.cgi?id=18359

It'd be helpful if you'd subscribe to that bug in case there's questions.

Changed in xkeyboard-config:
status: Confirmed → Triaged
Changed in xkeyboard-config:
status: Unknown → Confirmed

The mapping is very similar to "microsoftmult" model, except for those keys:
key K66 { [ XF86Reply ] };
key I6F { [ XF86Documents ] };
key K63 { [ XF86New ] };
key K64 { [ XF86Open ] };
key K65 { [ XF86Close ] };

Could the init script be changed to make mapping exactly same as microsoftmult? That way I'd just add the alias...

Created an attachment (id=21557)
Updated section of symbols

Just in case, I updated symbols (using "include" and sorting keycodes)

Bryce Harrington (bryce) wrote :

Jens, would you mind following up with upstream on bug 18359? Sounds like the concept is generally acceptable but needs some additional tweaking in order to get it accepted there. Once there is a patch acceptable for upstream, I can cherrypick it for Jaunty if it's done by beta-freeze.

starslights (starslights) wrote :

Hello,

in my log sys on Kubuntu Karmic 2.6.31-10-generic, i have XKB error:

no components provided for device Virtual core keyboard couldn't load XKB keymap back to pre-XKB keymap

Bryce Harrington (bryce) wrote :

Hi Jens, I'd love to get this bug closed, but to do this upstream has some questions for you - mind replying to them on the upstream bug? Thanks

https://bugs.freedesktop.org/show_bug.cgi?id=18359

Changed in xkeyboard-config (Ubuntu):
status: Triaged → Incomplete

I added the init script because the kernel told me that I had to call setkeycodes:
atkbd.c: Use 'setkeycodes e064 <keycode>' to make it known.

I will check if this is still necessary with current kernels.

Jens Georg (yg-jensge) wrote :

Sorry, totally forgot about it. I will have a look

Unfortunatly this does not work anymo(In reply to comment #3)
> The mapping is very similar to "microsoftmult" model, except for those keys:
> key K66 { [ XF86Reply ] };
> key I6F { [ XF86Documents ] };
> key K63 { [ XF86New ] };
> key K64 { [ XF86Open ] };
> key K65 { [ XF86Close ] };
>
> Could the init script be changed to make mapping exactly same as microsoftmult?
> That way I'd just add the alias...
>

Actually this mapping does not work anymore. The keycodes set with setkeycode do not match to the X keycodes from either evdev or xfree86 so the layout is totally bogus now :-/

Bryce Harrington (bryce) wrote :

[According to Jens' comment on the upstream bug, the patch no longer resolves the issue, so untagging it as a fix. We'll need to get more advice from upstream on this one to proceed.]

(In reply to comment #6)
Jens, I suspect you're using evdev now? Do evdev keycodes work ok for you?

Bryce Harrington (bryce) wrote :

In theory, according to the upstream bug report this should now be resolved when using evdev.

(For some reason, this bug report is also triggering an oops in launchpad, so if the problem still exists please file a new bug report.)

Changed in xkeyboard-config (Ubuntu):
status: Incomplete → Fix Released
Changed in xkeyboard-config:
importance: Unknown → Medium
Changed in xkeyboard-config:
importance: Medium → Unknown
Changed in xkeyboard-config:
importance: Unknown → Medium

-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/issues/31.

Changed in xkeyboard-config:
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.