Segmentation fault

Bug #783019 reported by Pavlo Bohmat on 2011-05-15
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xiphos (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xiphos

Falls at startup. Segmentation error...

:~$ xiphos
** Message: MAINTAINER_MODE
** Message: /usr/share/xiphos/languages
** Message: create main_mgr time is 0.001086
Number of Text modules = 3
Number of Commentary modules = 0
Number of Dict/lex modules = 2
Number of Book modules = 0
Number of Percomm modules = 0
Number of Devotion modules = 0
Number of Prayer modules = 0

** Message: var fontname Sans 11
** Message: fixed fontname Monospace 10
Starting xiphos-3.1.4
Building Xiphos interface

** Message: MAINTAINER_MODE
** Message: MAINTAINER_MODE
** Message: /usr/share/xiphos/navbar_versekey.glade
** Message: context_id: 1
message: Добро пожаловать в Xiphos
** Message: create main_mgr time is 0,004090
Starting sword-1.6.1
Initiating SWORD
path to sword: /usr/share/sword/
SWORD locale is ru_RU
Checking for SWORD Modules
Number of Text modules = 3
Number of Commentary modules = 0
Number of Dict/lex modules = 2
Number of Book modules = 0
Number of Percomm modules = 0
Number of Devotion modules = 0
Number of Prayer modules = 0

Initiating Xiphos
** Message: create SWMgr time is 0,000824
** Message: create main_mgr time is 0,000888
Displaying Xiphos

** (xiphos:9423): CRITICAL **: murrine_style_draw_box_gap: assertion `height >= -1' failed
** Message: on_notebook_main_switch_page
** Message: mod_name = RST
Segmentation error

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xiphos 3.1.4-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun May 15 16:51:55 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANGUAGE=ru_UA:ru:en_GB:en
 LANG=ru_UA.UTF-8
 SHELL=/bin/bash
SourcePackage: xiphos
UpgradeStatus: No upgrade log present (probably fresh install)

Pavlo Bohmat (bohm) wrote :
Malfet (malfet) wrote :

Same segmentation fault for me in Ubuntu 11.04
Neved had this problem before on earler versions of Ubuntu.

Eduardo Rivas (jerivasmelgar) wrote :

Same issue, all I've seen of Xiphos in Natty is the splash screen for a split second. Please, fix this one, the application is simply unusable now! Thanks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xiphos (Ubuntu):
status: New → Confirmed
Neil Manson (nelydajo) wrote :

I am also getting this same segmentation fault on a clean install of Ubuntu 11.04 on a Lenonvo T500.

ibidem (ibid-ag) wrote :

Following is a GDB session under Precise (the module chosen doesn't matter in my experience):
Initiating Xiphos
** Message: create SWMgr time is 0.005059
** Message: create main_mgr time is 0.003632
Displaying Xiphos
** Message: on_notebook_main_switch_page

Program received signal SIGSEGV, Segmentation fault.
0x01007ca6 in ?? () from /lib/i386-linux-gnu/libc.so.6
(gdb) where
#0 0x01007ca6 in ?? () from /lib/i386-linux-gnu/libc.so.6
#1 0x00e25671 in set (newVal=0x1b <Address 0x1b out of bounds>,
    this=0xbffff49c) at /build/buildd/sword-1.6.2+dfsg/include/swbuf.h:187
#2 sword::SWBuf::SWBuf (this=0xbffff49c,
    initVal=0x1b <Address 0x1b out of bounds>, initSize=0)
    at /build/buildd/sword-1.6.2+dfsg/src/utilfuns/swbuf.cpp:41
#3 0x080a052c in BackEnd::module_has_testament (this=0x84f6718,
    module_name=0x1b <Address 0x1b out of bounds>, testament=2)
    at ../src/backend/sword_main.cc:583
#4 0x080cd3e4 in main_display_bible (key=0x8667e20 "Romans 8:28",
    mod_name=0x1b <Address 0x1b out of bounds>) at ../src/main/sword.cc:1161
#5 main_display_bible (mod_name=0x8599bc0 "Darby",
    key=0x8667e20 "Romans 8:28") at ../src/main/sword.cc:1081
#6 0x080925f6 in gui_notebook_main_switch_page (notebook=0x84a9d48, page=0x0,
    page_num=0, tl=0x80f3e10) at ../src/gnome2/tabbed_browser.c:916
#7 0x080947d2 in gui_notebook_main_setup (tabs=1, tabsfile=0x0)
    at ../src/gnome2/tabbed_browser.c:1485
#8 0x080994f7 in frontend_display (tabs=0x0) at ../src/gnome2/xiphos.c:182
#9 0x08061fbd in main (argc=1, argv=0xbffff684) at ../src/main/main.c:191
(gdb)

ibidem (ibid-ag) wrote :

I installed libsword8 1.6.1, and Xiphos worked.

I suspect that Xiphos will run, if recompiled for SWORD 1.6.2.

Pavlo Bohmat (bohm) wrote :

xiphos_3.1.4-3_amd64: FAIL
libsword8_1.6.2+dfsg-1_amd64
~ubuntu 12.04

ibidem (ibid-ag) wrote :

Paul: Did you recompile it yourself?
sudo apt-get build-dep xiphos
apt-get source --compile xiphos
If not, the Precise version was compiled against libsword8_1.6.1, and then libsword8 was upgraded to 1.6.2; there appears to be a small binary incompatability..
This may be a separate bug that we're having.

ibidem (ibid-ag) wrote :

Paul: I filed a separate bug for Xiphos/libsword8 in suite Precise: LP #935574
Please use that bug report for Precise.

Ernest Kudron (kudron2) wrote :

sudo apt-get build-dep xiphos
apt-get source --compile xiphos
Did not fix. Problem still exists.

dFlyer (ggaribaldi) wrote :

xiphos and sword-language-pack-en seems broken. When I install both xiphos can't locate the .sword directory in my home folder. If I remove .sword from my home folder and than recreate .sword and than copy the /usr/share/sword/ directories to my home .sword folder than sword works. I can also create a link to the usr/share/sword directories to my home folder and that works also. So I believe that it's the sword-language-pack-en program that is broken.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers