changing button mapping with xinput does not work after Jaunty upgrade

Bug #366887 reported by akincisor on 2009-04-25
2
Affects Status Importance Assigned to Milestone
xinput (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xinput

I have an Evoluent Vertical Mouse 3. In intrepid I used the command:

xinput set-button-map "Kingsis Peripherals Evoluent VerticalMouse 3" 1 8 2 4 5 6 7 3 9

to achieve the buttom mapping I liked. This no longer works after upgrading to Jaunty.

xinput get-button-map "Kingsis Peripherals Evoluent VerticalMouse 3"

shows output

1 8 2 4 5 6 7 3 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10

which shows that the buttons should be remapped, but in practice they are unchanged. Using xev, only the first 5 buttons (left, middle, right, scroll up, scroll down) register. The other two buttons are not detected.

Bryce Harrington (bryce) wrote :

Hi ubuntu+launchpad,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xinput (Ubuntu):
status: New → Incomplete
akincisor (ubuntu+launchpad) wrote :

This bug doesn't affect me anymore since July. I suspect it was fixed by an update in the interim.

Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty
Timo Aaltonen (tjaalton) wrote :

Thanks, closing as fixed.

Changed in xinput (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers