Xine-UI defaults to sound volume to 0%

Bug #231507 reported by nanopino on 2008-05-18
78
This bug affects 12 people
Affects Status Importance Assigned to Milestone
xine-ui (Ubuntu)
Undecided
Unassigned

Bug Description

When opening up a video or audio track using "xine FILENAME" the UI opens up and plays fine, but the volume control defaults to 0%. I have to always readjust the volume to a louder setting. Messing with the UI settings and config file located at "~/.xine/config" does not fix this issue. It worked fine in Gutsy.

striscio (gianpaolo-racca) wrote :

I confirm the bug and I agree that is very annoying.

mmalmeida (mmalmeida) wrote :

I confirm the bug.

I also upgraded from Gutsy to Hardy and worked fine before.

Tom Haddon (mthaddon) wrote :

I'm experiencing the same issue on a Dell Inspiron 530 (desktop), but not on a Dell Inspiron 1420N (laptop).

I thought I might be able to work around this by calling the "--session volume=100" option. However, even with this, there's no sound. If I hit one of the volume up or volume down keys within Xine (not the Gnome system volume) then the sound appears instantly (at the correct level). So for instance, if I hit the "Volume Down" key once, suddenly I have sound at 99%.

I tried removing my .xine config directory and re-running xine, but still the same.

striscio (gianpaolo-racca) wrote :

I just discovered that killing pulseaudio solves the issue. If it can be called a solution.

mustangtyson (tysonsmith) wrote :

I have the same problem. Confirm the bug

Tom Haddon (mthaddon) wrote :

I can also confirm that "killall pulseaudio" works around this issue. This would suggest that pasuspender should work too (I believe it's supposed to suspend pulse audio for the duration of the script it's calling), but that didn't seem to work for me while "killall pulseaudio" works for the duration of the current session.

Changed in xine-ui:
status: New → Confirmed
Oliver Joos (oliver-joos) wrote :

Same here with xine-ui 0.99.5+cvs20070914-2
But I think I solved it!

Try to set "settings - audio - pulseaudio_device" to the string "pulseaudio" (the default name of local pulseaudio server)
and "settings - audio - volume.mixer_volume" to 100%
and "settings - audio - volume.remember_volume" to true.

If this really solves it for everybody, then this bug is just a bad default for an empty pulseaudio_device. Moreover the parameter name "remember_volume" is misleading and neither does act like its title declares (at least in the german translation): if "remember_volume" is false and xine starts then its volume is reset to the most recent "mixer_volume" that was saved together with "remember_volume" set to true - quite confusing!

So I think this IS a bug, but cause(s) and effect are a bit far apart. :-)

Tom Haddon (mthaddon) wrote :

I can confirm the following setting in .xine/config fixed it for me: "audio.pulseaudio_device:pulseaudio"

nanopino (whichone) wrote :

after some testing i confirm that Olivers configuration suggestion does fix this bug...

edgar9000 (edgar9000) wrote :

i try to apply this configuration but it doesn't fix the problem... when I open the xine-ui the volumen level is still in 0%

Robertjm (robertjm) wrote :

This is also happening in Intrepid Ibex

David Kohen (kohen-d) wrote :

Happens for me on Intrepid, and the workaround works.

return13 (return13) wrote :

Same Problem on Jaunty - but like Tom have said - setting "audio.pulseaudio_device" to "pulseaudio" solves the problem.

return13 (return13) wrote :

Der Vollständigkeit halber - ~/.xine/config

audio.driver:pulseaudio
audio.pulseaudio_device:pulseaudio

Michal Bořek (mibo) wrote :

audio.pulseaudio_device:pulseaudio not a solution. not use pulseaudio, but alsa

xine --verbose=10 videofile

for audio.pulseaudio_device: pulseaudio
*****
load_plugins: plugin /usr/lib/xine/plugins/1.26/xineplug_ao_out_pulseaudio.so found
main: probing <pulseaudio> audio output plugin
audio_pulse_out: host pulseaudio sink (null)
audio_pulse_out: failed to connect context object Connection refused
load_plugins: failed to load audio output plugin <pulseaudio>
main: probing <alsa> audio output plugin
audio_alsa_out : supported modes are 8bit 16bit 32bit mono stereo (4-channel not enabled in xine config) (4.1-channel not enabled in xine config) (5-channel not enabled in xine config) (5.1-channel not enabled in xine config) (a/52 and DTS pass-through not enabled in xine config)
*****

for audio.pulseaudio_device:
****
load_plugins: plugin /usr/lib/xine/plugins/1.26/xineplug_ao_out_pulseaudio.so found
main: probing <pulseaudio> audio output plugin
audio_pulse_out: host (null) sink (null)
audio_pulse_out: ao_open bits=16 rate=48000, mode=8
****

Robertjm (robertjm) wrote :

Michel,

I thought that ubuntu was moving away from Alsa towards Pulse Audio?

Michal Bořek (mibo) wrote :

Robertjm,
xine-ui default output pulseaudio, but volume control defaults to 0%
xine-ui with "audio.pulseaudio_device: pulseaudio" or "audio.pulseaudio_device: anything" output alsa and volume control defaults by settings

Robertjm (robertjm) wrote :

Going over past bugs reported.

I have not upgraded to Karmic Koala. As installed, the problem still existed.
When I checked my .xine/config file I found:

....
# audio driver to use
# { auto null pulseaudio alsa oss esd file none }, default: 0
# audio.driver:auto

# device used for pulseaudio
# string, default:
# audio.pulseaudio_device:
---

Changed to:

---
# audio driver to use
# { auto null pulseaudio alsa oss esd file none }, default: 0
audio.driver:pulseaudio

# device used for pulseaudio
# string, default:
audio.pulseaudio_device: pulseaudio
---

Before restarting xine I cranked my default volume to full. After starting my opening volume is now full in Xine so changing the settings per return13 fixed the problem.

Robertjm (robertjm) wrote :

Can't find a way to edit the previous comment so adding a clarification.

I meant to say "...I have upgraded to Karmic Koala. As installed, the problem still exists..."

Bartek (tschew) wrote :

The configuration option suggested does not really fix the problem because with it the channel controlled by the xine volume slider is the master channel, which should be controlled only by the desktop system volume control.

summary: - Xine-UI defaults to sound volume to 0% in Hardy
+ Xine-UI defaults to sound volume to 0%
Peter (peterroots) wrote :

I have the same problem in Lucid as well - setting pluseaudio, as suggested, works. Have found the problem very irritating but only just got round to searching for an answer! Thanks for providing one

footer (footer) wrote :

Maverick Meerkat appears to have this problem as well. I just used Robertjm (Post #18) suggestion and it worked like a charm. My xine ui volume now slides with the master control (desktop) volume and is remembered.

Thanks!

Nils B (nils-nothingnew) wrote :

Confirming this for Maverick as well.

The workaround with setting "audio.pulseaudio_device: pulseaudio" just causes xine to use the alsa driver instead of pulseaudio because the device name is invalid. So, you could just change the audio.driver config to alsa instead, the effect will be the same.

Oliver Joos (oliver-joos) wrote :

In Natty pulseaudio finally seems to work as expected! As Nils wrote above the workaround must not be applied anymore. Just leave "audio.pulseaudio_device" empty and enable "audio.volume.remember_volume".

I don't set this bug to "Fix Released" as it is still an issue in Lucid (LTS !).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers