Amarok intermittently gives the error "no suitable demux plugin found" when trying to play remote streams/files

Bug #94047 reported by Gabriel Dragffy
28
Affects Status Importance Assigned to Milestone
Amarok
Invalid
Medium
xine-lib
Unknown
Unknown
amarok (Ubuntu)
Undecided
Unassigned
xine-lib (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: amarok

Trying to play remotely stored music files (e.g. mp3) or radio streams sometimes gives an error pop-up that no suitable demux plugin was found.

To reproduce:
Double click on one of my radio streams and sometimes it will play OK, other times it will give me an error. If it gives an error I just keep trying to play different radio streams until it starts working again - then the original will work again.

As stated it is intermittent and annoying! It also happens when trying to play music over samba shares. Could it be a problem with the KIO slaves?

I have all required codecs installed, as I said it occurs randomly and will start working again if you keep fiddling with it. I can play all my mp3s, and radio streams perfectly using Totem or Rythmbox.

Will attach a screen grab of that error message.

Revision history for this message
Gabriel Dragffy (dragffy-deactivatedaccount) wrote :
Revision history for this message
Sujee Maniyam (sujee) wrote :

I had experienced an almost similar problem:

1) start playing an stream (playlist gets populated with stream)
2) stop
3) network settings change (get a new IP via dhcp or laptop hibernates and comes back up)
4) try to play the same item in *PLAYLIST*
           --> error
5) delete the contents of playlist
6) drag the stream back onto playlist
7) Amarok will play it with no issues

This makes me think it could also be KIOSlave problem. Probably this is more of an Amarok issue than a Kubuntu issue.

Revision history for this message
Mark Meredith (mwm126) wrote :

I am also seeing this issue, for amarok 1.4.5-0ubuntu7 in feisty. Opening a stream results in the error dialog. After clicking on a local mp3 file in the playlist and then trying the stream again, it plays ok.

Revision history for this message
rvadmin (rvadmin) wrote :

i can confirm.
Amarok 1.4.5 kubuntu Feisty

Changed in amarok:
status: Unknown → Rejected
Revision history for this message
Andres Mujica (andres.mujica) wrote :

I can confirm this bug

Changed in amarok:
status: Unconfirmed → Confirmed
Revision history for this message
Andres Mujica (andres.mujica) wrote :

I've removed the duplicated mark because maybe is not the same but somehow related.

maybe this bug has something to do with:

http://bugs.kde.org/show_bug.cgi?id=130709

and with:

https://bugs.launchpad.net/kdepim/+bug/70981

Revision history for this message
Anders (andersja+launchpad-net) wrote :

I can confirm this bug. Some times when opening a stream from my list of stations (I only ever listen to the IPv4 unicast streams from this site, if that helps you debugging: http://media.hiof.no/scripts/stream_details.php ) i get the error, clicking the same stream or another stream opens up fine. I think it's always the first time I open the stream there's a problem

Revision history for this message
Randy Winchester (randy) wrote :

Also confirming the bug because I want to follow the progress. I get the same error while trying to open the radio stream CBC Radio 2: http://www.cbc.ca/livemedia/cbcr2-toronto.asx
I've got all the correct codecs installed. The stream plays fine in Rhythmbox.

Revision history for this message
Jeff Mitchell (jefferai) wrote :

This is probably the same as https://bugs.launchpad.net/bugs/120732 and should be treated likewise.

If realplayer plays it, try the helix engine. If xine-ui or xine on the command line also doesn't play it, it's a xine issue, and should be assigned as such.

Revision history for this message
Lukáš Zapletal (lzap) wrote :

I have tried this

xine "http://www.jamendo.com/get/track/id/album/audio/play/3699/?item_o=track_no_asc&n=all"

It doesnt work. Its a bug in xine.

Revision history for this message
Mathieu 7-7 (informathieu) wrote :

I can confirm this bug.
Amarok 1.4
Ubuntu Gutsy Gibbon, 2.6.22-12-generic
x86_64, AMD Athlon 64 2.2 Mhz,
Geforce 6600 GT AGP,
1go RAM.

Playlists/Podcasts right clic Add Podcast... RSS link http://radiofrance-podcast.net/podcast/rss_16496.xml
OK
But when I clic on my podcast : Error Loading Media No suitable demux plugin. This often means that the file format is not supported.

I don't think Amarok have download any mp3 file at all.

Revision history for this message
Anders (andersja+launchpad-net) wrote :

I can confirm that this bug is still present in the latest Amarok in Ubuntu Hardy Heron Alpha 6.
Steps to reproduce: attempt listening to any IPv4 unicast stream from here: http://media.hiof.no/scripts/stream_details.php

The first stream will not play, error message displayed. The next attempt will work.

Revision history for this message
Lydia Pintscher (lydia-pintscher) wrote :

This is not an Amarok bug as you can read in the upstream bug report about this.
Marking as invalid for Amarok therefore. This needs to be fixed in Xine.

Thank you for your report.

Changed in amarok:
status: Confirmed → Invalid
Revision history for this message
Jeff Mitchell (jefferai) wrote :

By the way, this means: go poke Xine. If you don't report it, they can't/won't fix it.

Revision history for this message
Andrew Ash (ash211) wrote :

Reassigning to xine-lib then.

Changed in amarok:
status: Invalid → Incomplete
Revision history for this message
Anders (andersja+launchpad-net) wrote :

@Jeff/Lydia, thanks for digging a bit deeper to find the source of the problem. However, for the end user, your replies don't help much. "go poke Xine"? I'm a user (albeit maybe a "power user") but there are numerous other users too having subscribed to / contributed to this bug. How can we "poke Xine"? The above SourceForge link now reports:

http://sourceforge.net/tracker/index.php?func=detail&aid=1266858&group_id=9655&atid=109655
"ERROR

Artifact: This Artifact Has Been Made Private. Only Group Members Can View Private ArtifactTypes. "

I'm happy for this bug to be triaged "Low" or lower, but don't fob the problem off and make it users' responsibility to chase it further? Please advise how we can help?

Revision history for this message
Jeff Mitchell (jefferai) wrote :

I don't know, maybe do a Google search for "xine", click on the top result which takes you to the Xine home page, and click on the Mailing Lists link.

http://sourceforge.net/mail/?group_id=9655

I have no idea what URL you're pointing to above.

Revision history for this message
Adam Spain (adamspain) wrote :

>> I have no idea what URL you're pointing to above.

It's the link to the bug at SourceForge in the table of related bugs at the top of the Launchpad page, where it says "sf #1266858".

Revision history for this message
Lydia Pintscher (lydia-pintscher) wrote :

@Adam: Xine changed their bugtracker recently so this link is probably invalid.
As it is now assigned to xinelib in Ubuntu it will be taken care of there and hopefully linked to the right xine bugreport.

Thank you for your report.

Revision history for this message
Horacio Arroyo (deblike) wrote :

Thank you amarok!!
I never got the mp3 stream working, but in the meaning I re-discovered Beepx media player, and now I'm quite happy with it! Everything work just the way it's supposed to!!

Daniel T Chen (crimsun)
Changed in xine-lib:
status: Incomplete → Confirmed
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Since this is a confirmed xine problem and not a problem in amarok, I am invalidating the amarok task.

Changed in amarok:
status: New → Invalid
Changed in amarok:
importance: Unknown → Medium
George Gill (ggilliii10)
description: updated
Changed in xine-lib (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.