[Kubuntu Lucid] Very noisy playback of AAC streams in FLV container

Bug #594966 reported by Uwe Geuder on 2010-06-16
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xine-lib
Fix Released
Medium
xine-lib (Ubuntu)
Undecided
Unassigned

Bug Description

When playing an FLV file containing an AAC encoded audio stream in dragon player, the sound is extremely noisy. Most (all???) other media formats work fine. Also gstreamer + totem (in a dual boot Ubuntu Lucid installation on the same HW) can play the sound without problems

The issue can be fixed by building xine-lib 1.1.18.1 from upstream. Because dragon + xine-lib is the default video player in Kubuntu, I'd suggest to package the new version for Ubuntu repos (or cherry pick the relevant fixes).

The full details of my investigations are at http://usrmisc.wordpress.com/2010/06/15/solving-a-dragon-video-player-problem/

I'll attach a small example file and run apport collect.

Uwe Geuder (ubuntulp-ugeuder) wrote :

Oops, forgot to mention: Yes, I have looked at https://bugs.launchpad.net/bugs/503361. Teh reported issue sound very similar, just the media formats are different. However, that bug has been marked as invalid for xine-lib and I can fix my issue by upgrading only xine-lib. So I came to the conclusion that this must be separate issue.

Uwe Geuder (ubuntulp-ugeuder) wrote :

Hmm, apport-collect fails with:

apport-collect 594966
Package xine-lib not installed and no hook available, ignoring

The binary package name is libxine1 and the source package name is xine-lib. Any advice how I can run apport-collect correctly?

Uwe Geuder (ubuntulp-ugeuder) wrote :

As long as I don't know how to run apport-collect, here is the most essential version info:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04 LTS
Release: 10.04
Codename: lucid

$ apt-cache policy libxine1
libxine1:
  Installed: 1.1.17-1ubuntu3
  Candidate: 1.1.17-1ubuntu3
  Version table:
 *** 1.1.17-1ubuntu3 0
        500 http://fi.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

And as mentioned: this is a Kubuntu installation.

summary: - [Kubuntu Lucid] Very noisy playback off AAC streams in FLV container
+ [Kubuntu Lucid] Very noisy playback of AAC streams in FLV container
Uwe Geuder (ubuntulp-ugeuder) wrote :

Ok, when trying to produce a real small sample I learned that not all FLV files with AAC are affected. All my small samples actually worked fine. Not sure whether size is the culprit or whether some little coding attribute.

I attach the smallest file I have, which demonstrates the problem.

Uwe Geuder (ubuntulp-ugeuder) wrote :

When trying to produce the small attachment I actually learned a work-around for the problem.

I a file has the noisy sound, you can try

ffmpeg -i file.flv -vcodec copy -acodec copy copy.flv

The copy plays nicely. (ffmpeg needs to be installed separately. I have the medibuntu version, but I'd assume for just copying the streams the Ubuntu version should be enough.)

Uwe Geuder (ubuntulp-ugeuder) wrote :

Problem still exists even after the KDE upgrade https://bugs.launchpad.net/bugs/691068

Changed in xine-lib (Ubuntu):
status: New → Confirmed
John Doe (b2109455) wrote :

The upstream bug is https://bugs.xine-project.org/show_bug.cgi?id=297. The patch can be found here: https://bugs.xine-project.org/attachment.cgi?id=174&action=diff. I guess it can be easily backported to libxine 1.1.17.

Changed in xine-lib:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.