xine refuses to play old ogg files

Bug #56153 reported by ciasaboark on 2006-08-12
2
Affects Status Importance Assigned to Milestone
xine-lib
Unknown
Unknown
xine-lib (Debian)
Fix Released
Unknown
xine-lib (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: libxine-main1

I've been having some weird problems with xine for a few years now, mainly as the xine backend in amarok. Other than general stability issues, I have been having trouble getting xine to play some ogg files, while others play just fine. I finally decided to look for some more info since the amarok package I'm using doesn't have any other backends available, and as a large part of
my music collection is in ogg format.

I have a short list of what ogg vorbis versions will work in xine, and which
wont:
1.0 RC 2 yes
1.0 yes
1.1.0 RC1 yes
1.0.1 yes

1.0 RC 1 no
1.0 beta 4 no

That is by no means a complete lists. I am sure there were other versions packaged for debian/ubuntu.

Reading the bug reports on the xine website it seems like this is a regression
 *original bug report (with non-working patch): http://sourceforge.net/tracker/index.php?func=detail&aid=892508&group_id=9655&atid=109655
 *new bug report (with semi working patch): http://sourceforge.net/tracker/index.php?func=detail&aid=1465298&group_id=9655&atid=109655

Seeing as how the patch only requires changing the buffer size in one file this would be an easy fix for the libxine-main1 maintainer in ubuntu, until the upstream sources are patched. The second bug was reported 4 months ago, and the cvs version still hasn't been fixed.

ciasaboark (ciasaboark) wrote :

This is an ugly patch created for xine1.1.1. You can apply the patch to the sources yourself and build a replacement libxine-main1 package:

mkdir xine
cd xine
apt-get source libxine-main1
cd xine-lib*
cd src/xine-engine
patch -p1 -b audio_decoder.c < /path/to/the/provided/diff
cd ../../
fakeroot dpkg-buildpackage
sudo dpkg -i ../libxine-main*.deb

Reinhard Tartler (siretart) wrote :

I was able to reproduce this problem

Changed in xine-lib:
importance: Untriaged → Medium
status: Unconfirmed → Confirmed
Changed in xine-lib:
status: Unknown → Confirmed

> On Tuesday 23 October 2007 04:28:15 am you wrote:
>> About that special patch, did you have asked upstream for their opinion
>> on this patch?

Jonathan Nelson <email address hidden> writes:
> I posted a patch on the xine bug tracking system over a year ago to
> fix this problem [1]. ... I'm assuming that the xine authors consider
> it either a trivial issue, or just haven't noticed the bug reports
> yet.

I've just talked on IRC with one xine developer (#xine on Freenode):

14:55:50 < siretart> _ds_: how do you think about the patch in https://bugs.edge.launchpad.net/ubuntu/+source/xine-lib/+bug/56153. any reason not to apply it upstream?
14:56:28 < siretart> _ds_: I noticed that a xine user has tried to upload a xine package with that patch to ubuntu (but obviously failed because of his gpg key not in the keyring)
14:56:55 < siretart> I asked him whats up and he said that he wasn't
able to gain any feedback from 'xine upstream'
15:28:49 < _ds_> I don't like that patch - it affects all audio.
15:41:25 < siretart> but it seems to fix problems. hmm
16:44:03 < siretart> what bad could happen with that patch?
16:45:58 < _ds_> It's basically excessive memory allocation (consider also the number of buffers). The proper fix for this should be in the Vorbis decoder.
16:48:02 < siretart> ok. thanks for explanation

I have to admit that I agree to upstream here, and I don't see why we
should carry around a bad patch in ubuntu and/or debian.

> I've been using a patched version of xine-lib since noticing the second bug
> report, and haven't had any issues with xine.

Did you measure the increased memory overhead? Please show some numbers.

> I'm afraid I don't really know the correct procedure for doing this

You did okay: Talking to the relevant parties.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Changed in xine-lib:
status: Confirmed → Incomplete
Bogdan Butnaru (bogdanb) wrote :

I'm not sure if it's the same bug that's affecting me, but I have trouble playing at least some ogg files in Amarok.

The original poster doesn't describe exactly what "doesn't work" means for him. In my case Amarok complains "Error loading media: there is no available decoder".

ciasaboark (ciasaboark) wrote :

The original problem was that xine (or any xine frontend including amarok) would not play the audio in the ogg file. There were no error dialogs or status bar messages in amarok, it would just skip to the next item in the playlist. Xine would give some relevant errors IIRC, but only if you upped the verbosity.

Eventually I got tired of manually patching xine and just used soundkonverter to reencode all of the offending ogg files.

Reinhard Tartler (siretart) wrote :

could someone please attach a test file for this bug, please?

I got this same problem too, didnt try all the different versions though

Changed in xine-lib (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.