noisy playback of 24bit/96khz flac files

Bug #503361 reported by mokabar on 2010-01-05
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Amarok
Fix Released
Medium
Phonon
Won't Fix
Medium
xine-lib
Invalid
Medium
xine-lib (Ubuntu)
Undecided
Unassigned
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: amarok

trying to play some flac files (24bit, 96khz) with amarok (karmic), the files are played back, but the playback is very noisy (not a clean white noise, but close to). as if 24bit files would be played back as 16bit

hth

Andrew Ash (ash211) wrote :

This sounds like the type of issue that wouldn't be Amarok specific but instead closer to the underlying media framework that plays the files. In Amarok's case, that is Phonon, which will usually plug into Xine or Gstreamer in the backend.

Here are several things I'd like you to try so we can get a better sense of where the problem is:

1) play the files with another media program
2) play other files (standard mp3s or other filetype)
3) switch the phonon backend gstreamer<->xine

In which of these 3 scenarios do you hear the noisy playback?

4) Also, what version of Ubuntu are you running? Are you fully updated on patches?

Changed in amarok (Ubuntu):
status: New → Incomplete
mokabar (tim-klingt) wrote :

1) play the files with another media program

aqualung plays the files fine

2) play other files (standard mp3s or other filetype)

other flac files (44.1/48kHz) work fine

3) switch the phonon backend gstreamer<->xine

i'm using the xine backend, since the gstreamer backend doesn't play back anything on my machine.

xine/44kHz: good playback
xine/96kHz: noisy playback
gstreamer/anything: no playback

(i don't want to start debugging gstreamer)

4) Also, what version of Ubuntu are you running? Are you fully updated on patches?

apt-cache policy amarok
amarok:
  Installed: 2:2.2.1-0ubuntu1~karmic1~ppa1
  Candidate: 2:2.2.1-0ubuntu1~karmic1~ppa1
  Version table:
 *** 2:2.2.1-0ubuntu1~karmic1~ppa1 0
        500 http://ppa.launchpad.net karmic/main Packages
        500 http://ppa.launchpad.net karmic/main Packages
        100 /var/lib/dpkg/status
     2:2.2.0-0ubuntu2 0
        500 http://at.archive.ubuntu.com karmic/main Packages

Andrew Ash (ash211) wrote :

Hmm, this is starting to sound a bit like a xine bug. A few more questions/directions to try:

1) What backend are you using for aqualung?
2) Is playback still noisy playing files with xine-ui in a terminal?
3) What version of xine and phonon are you running?

Here's an old thread on ubuntuforums about your issue, though they don't reach any conclusions [1]. Can you try playing around with the xine-config file?

In general, the xine backend playing flac seems to be a bit flaky:

Missing playback at the end of flac files -- http://bugs.kde.org/show_bug.cgi?id=172394
Can't play 24/96 flac files at all -- https://bugs.kde.org/show_bug.cgi?id=182640
Can't fast-forward flac files -- https://bugs.edge.launchpad.net/xine-lib/+bug/162470

There is an upstream bug on the xine tracker about noisy playback [2], but the direction they started going was into ffmpeg. The best direction from here is to confirm that the bug occurs when playing with xine-ui, and then following up on that report [2].

[1] http://ubuntuforums.org/archive/index.php/t-629272.html
[2] http://bugs.xine-project.org/show_bug.cgi?id=221

mokabar (tim-klingt) wrote :

1) What backend are you using for aqualung?

aqualung doesn't have the notion of `backend'. it natively decodes via libsndfile or libflac, resamples via libsamplerate and plays back via libjack

2) Is playback still noisy playing files with xine-ui in a terminal?

xine tries to display a video (black with a few white points). interestingly, the stream info shows that no video stream is available and that the audio stream format is 96000khz/16 bit, while the file is a 24bit file

3) What version of xine and phonon are you running?

libjack1: Version: 1.1.16.3-0ubuntu4+withjack1
libphonon4: Version: 4:4.3.1-4ubuntu1

Andrew Ash (ash211) wrote :

Hmm ok, I wasn't sure about aqualung backends before, since it says it can output to OSS, ALSA, Jack, or Pulseaudio.

But the interesting part is that the xine-ui frontend incorrectly detects the bitrate of the file as 16 instead of 24. Since the Phonon backend we're using is xine, that means that this error could be occurring when Amarok plays as well, since xine is in the audio chain (Amarok -> Phonon -> Xine -> ... -> speaker).

I think the version you labeled as libjack1 should actually be the version of xine-lib. It seems that you have installed jack-related packages from this PPA.
https://edge.launchpad.net/~motin/+archive/until-jack-is-included-in-main

If possible, could you please confirm that the same noise occurs with the xine-lib in main as well?

So here are the new questions:

1) Does the noise still exist with xine-lib in main?
2) Is playback still noisy playing files with xine-ui in a terminal? (you said it misdetects the bitrate, but not whether or not it still sounds noisy)

I'm going to go ahead and direct this bug towards xine if your answer to (2) is yes. After that, we'll need to file a bug upstream, since I have no idea what direction to go in to fix the bug, and this is something that upstream would be better able to handle.

Patrick Walker (phobiac) wrote :

I don't know exactly how relevant this is, but I am experiencing the exact same problem in Amarok 1.4
I'm running 64-bit karmic, and I have compiled the Amarok 1.4 sources. I assumed it was a bug in the old and no longer supported code, but now I'm thinking it might not be.

Here's the output of sudo apt-cache policy libxine1

libxine1:
  Installed: 1.1.16.3-0ubuntu4
  Candidate: 1.1.16.3-0ubuntu4
  Version table:
 *** 1.1.16.3-0ubuntu4 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Jonathan Thomas (echidnaman) wrote :

Sounds like a xine problem then. Thanks for that bit of info.

affects: amarok (Ubuntu) → xine-lib (Ubuntu)
Changed in xine-lib (Ubuntu):
status: Incomplete → Confirmed
Patrick Walker (phobiac) wrote :

I have a file that regularly does this, would it be helpful to upload it?

Bogdan Butnaru (bogdanb) wrote :

I thought it might be useful to point you guys to http://bugs.xine-project.org/show_bug.cgi?id=221

It seems there's a problem in Xine that they have at least a work-around for. I know too little about Xine to determine if it's applicable to Ubuntu.

Changed in xine-lib (Ubuntu):
status: Confirmed → Fix Committed

It is possible ro update libxine1 before maverick release?

Changed in xine-lib:
status: Unknown → Invalid
Changed in phonon:
status: Unknown → Fix Released
Changed in amarok:
status: Unknown → Fix Released

Version of xine in Maverick is 1.1.18.1. In this version this bug is already fixed. I also can not reproduce this bug in Maverick with Amarok player.

Changed in xine-lib (Ubuntu):
status: Fix Committed → Fix Released
Changed in phonon:
status: Fix Released → Won't Fix
Changed in phonon:
importance: Unknown → Medium
Changed in amarok:
importance: Unknown → Medium
Changed in xine-lib:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.